X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

hide address bar

Kuphostiwe

Hello I wanted to running firefox in Kiosk mode which hides all tool bars and stuff. So I downloaded Plug in for kiosk mode. but still the address bar in the bottom keep coming up when i hover something. I linked the image of the address bar image I took a screen capture below. http://controlandpowerresearchgroup.com/wp-content/themes/imbalance2/images/Untitled-2.jpg

is there any way I can hide the pop up bar as well?

Hello I wanted to running firefox in Kiosk mode which hides all tool bars and stuff. So I downloaded Plug in for kiosk mode. but still the address bar in the bottom keep coming up when i hover something. I linked the image of the address bar image I took a screen capture below. http://controlandpowerresearchgroup.com/wp-content/themes/imbalance2/images/Untitled-2.jpg is there any way I can hide the pop up bar as well?

Eminye Imininingwane Yohlelo

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_8_2) AppleWebKit/536.26.17 (KHTML, like Gecko) Version/6.0.2 Safari/536.26.17

Eminye Imininingwane

kobe 441 izisombululo 5048 izimpendulo
Kuphostiwe

Maybe you can use some css for that (Testing my css ability that im just learning).

Maybe you can use some css for that (Testing my css ability that im just learning). * http://kb.mozillazine.org/index.php?title=UserChrome.css&printable=yes

Okulungisiwe ngu kobe

kobe 441 izisombululo 5048 izimpendulo
Kuphostiwe

look down one post

look down one post

Okulungisiwe ngu kobe

kobe 441 izisombululo 5048 izimpendulo
Kuphostiwe

actually put this all together and you dont need a addon to run kiosh mode in firefox refer to my pastebin here => http://pastebin.com/Bj0u4Xmc and follow the instructions in the link in my first post.

actually put this all together and you dont need a addon to run kiosh mode in firefox refer to my pastebin here => http://pastebin.com/Bj0u4Xmc and follow the instructions in the link in my first post.

Okulungisiwe ngu kobe

kobe 441 izisombululo 5048 izimpendulo
Kuphostiwe

for other users looking to do this, here ya go.

http://userstyles.org/styles/91005/kiosh-mode-mozilla-firefox?r=1374746290

once as you install all toolbars will be removed, im not liable to damages to your firefox profile

for other users looking to do this, here ya go. http://userstyles.org/styles/91005/kiosh-mode-mozilla-firefox?r=1374746290 '''once as you install all toolbars will be removed, im not liable to damages to your firefox profile'''
cor-el
  • Top 10 Contributor
  • Moderator
17540 izisombululo 158604 izimpendulo
Kuphostiwe

Impendulo Ewusizo

Hiding the Navigation Toolbar won't really help because you can always use the Ctrl+L keyboard shortcut to bring up a location bar replacement if the real location bar is hidden (e.g. no Navigation Toolbar visible) or not present on one of the visible toolbars (i.e. moved to the toolbar palette).

What shows in your screenshot if the alert that show a link on hover and other status messages while the page is loading.


@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

#statusbar-display { display: none !important; }
Hiding the Navigation Toolbar won't really help because you can always use the Ctrl+L keyboard shortcut to bring up a location bar replacement if the real location bar is hidden (e.g. no Navigation Toolbar visible) or not present on one of the visible toolbars (i.e. moved to the toolbar palette). What shows in your screenshot if the alert that show a link on hover and other status messages while the page is loading. ---- <pre><nowiki>@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */ #statusbar-display { display: none !important; } </nowiki></pre>
kobe 441 izisombululo 5048 izimpendulo
Kuphostiwe

So my css will allow Ctrl + L and show the urlbar?

So my css will allow Ctrl + L and show the urlbar?
cor-el
  • Top 10 Contributor
  • Moderator
17540 izisombululo 158604 izimpendulo
Kuphostiwe

You can try that out yourself. That is always the best way to find out how it works.

You can try that out yourself. That is always the best way to find out how it works.
kobe 441 izisombululo 5048 izimpendulo
Kuphostiwe

Nope it doesnt block it and have no idea what to do.

Nope it doesnt block it and have no idea what to do.
cor-el
  • Top 10 Contributor
  • Moderator
17540 izisombululo 158604 izimpendulo
Kuphostiwe

You can hide that pop-up as well with code in userChrome.css:

#urlbar-container, #openLocation { display:none!important; }
You can hide that pop-up as well with code in userChrome.css: <pre><nowiki>#urlbar-container, #openLocation { display:none!important; } </nowiki></pre>
kobe 441 izisombululo 5048 izimpendulo
Kuphostiwe

okay, thank you, i will add that later this evening

okay, thank you, i will add that later this evening
kobe 441 izisombululo 5048 izimpendulo
Kuphostiwe

I had added it to the user style and it works fine, no Ctrl + L box.

I had added it to the user style and it works fine, no Ctrl + L box.
Jack McElwee 0 izisombululo 21 izimpendulo
Kuphostiwe

BION I don't have a blasted address bar on the newest Firefox 23! Where is it and how do I bring it up? Thanks I hope- Jack/keimanzero

BION I don't have a blasted address bar on the newest Firefox 23! Where is it and how do I bring it up? Thanks I hope- Jack/keimanzero

Okulungisiwe ngu Jack McElwee

cor-el
  • Top 10 Contributor
  • Moderator
17540 izisombululo 158604 izimpendulo
Kuphostiwe

Hi keimanzero

Note that this thread is about hiding the location bar.
You have a different problem and aren't seeing the location bar, so best would have been to create a new thread.

Make sure that you do not run Firefox in full screen mode (press F11 or Fn + F11 to toggle; Mac: Command+Shift+F).

If you are in full screen mode then hover the mouse to the top of the screen to make the Navigation Toolbar and Tab bar appear. Click the Maximize button (top right corner of the Navigation Toolbar) to leave full screen mode or right-click empty space on a toolbar and choose "Exit Full Screen Mode" or press the F11 key.


Make sure that toolbars like the "Navigation Toolbar" and the "Bookmarks Toolbar" are visible.

  • Firefox menu button > Options
  • View > Toolbars (press F10 to display the menu bar)
  • Right-click empty toolbar area

Use Toolbar Layout (Customize) to open the Customize window and set which toolbar items to display.

  • if missing items are in the toolbar palette then drag them back from the Customize window on the toolbar
  • if you do not see an item on a toolbar and in the toolbar palette then click the "Restore Default Set" button to restore the default toolbar setup

You can check for problems caused by a corrupted localstore.rdf file if the above didn't help.

Hi keimanzero Note that this thread is about hiding the location bar.<br /> You have a different problem and aren't seeing the location bar, so best would have been to create a new thread. Make sure that you do not run Firefox in full screen mode (press F11 or Fn + F11 to toggle; Mac: Command+Shift+F). *https://support.mozilla.org/kb/how-to-use-full-screen If you are in full screen mode then hover the mouse to the top of the screen to make the Navigation Toolbar and Tab bar appear. Click the Maximize button (top right corner of the Navigation Toolbar) to leave full screen mode or right-click empty space on a toolbar and choose "Exit Full Screen Mode" or press the F11 key. ---- Make sure that toolbars like the "Navigation Toolbar" and the "Bookmarks Toolbar" are visible. *Firefox menu button > Options *View > Toolbars (press F10 to display the menu bar) *Right-click empty toolbar area Use Toolbar Layout (Customize) to open the Customize window and set which toolbar items to display. *if missing items are in the toolbar palette then drag them back from the Customize window on the toolbar *if you do not see an item on a toolbar and in the toolbar palette then click the "Restore Default Set" button to restore the default toolbar setup *https://support.mozilla.org/kb/How+to+customize+the+toolbar *https://support.mozilla.org/kb/Back+and+forward+or+other+toolbar+items+are+missing You can check for problems caused by a corrupted localstore.rdf file if the above didn't help. *http://kb.mozillazine.org/Corrupt_localstore.rdf
Jack McElwee 0 izisombululo 21 izimpendulo
Kuphostiwe

Thanks a lot cor-el, Restore Default Set brought back the address bar! I am not too familiar with all the Firefox stuff yet. I'd added Speed Dial addon and I thought that ahd mucked up the address bar. Sorry for posting in the wrong thread. See ya later- Jack

Thanks a lot cor-el, Restore Default Set brought back the address bar! I am not too familiar with all the Firefox stuff yet. I'd added Speed Dial addon and I thought that ahd mucked up the address bar. Sorry for posting in the wrong thread. See ya later- Jack
cor-el
  • Top 10 Contributor
  • Moderator
17540 izisombululo 158604 izimpendulo
Kuphostiwe

You're welcome keimanzero

You're welcome keimanzero