X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

HTTPS: This Connection is Untrusted -> click "Add Exception" -> can NOT click "Confirm Security Exception" button

Kuphostiwe

When using FF 19.0.2 on Ubuntu or Win7, to work on lab machines where an invalid self-signed cert has previously been "permanently stored", but has since changed. I (and much of the rest of the internet it would seem) frequently get caught in a catch 22 where an exception must be added to continue, but FF will not permit an exception to be added because "This site provides valid, verified identification. There is no need to add an exception".

I see this reported time & again in forums, but it seems as yet unfixed.

Doesn't seem to be an issue if one is rigorous and _always_ UN-checks "Permanently store this exception". To fix includes contortions through numerous work arounds, including clearing certs (hard, when cert list is full of self-signed localhost certs), history, cache, etc. until FF finally lets you "Confirm Security Exception".

I am at my wits end, and will have to start thinking of alternative browsers for day to day use.

FYI: IE & Chrome both let me confirm the damn exception and move on with my life.

When using FF 19.0.2 on Ubuntu or Win7, to work on lab machines where an invalid self-signed cert has previously been "permanently stored", but has since changed. I (and much of the rest of the internet it would seem) frequently get caught in a catch 22 where an exception must be added to continue, but FF will not permit an exception to be added because "This site provides valid, verified identification. There is no need to add an exception". I see this reported time & again in forums, but it seems as yet unfixed. Doesn't seem to be an issue if one is rigorous and _always_ UN-checks "Permanently store this exception". To fix includes contortions through numerous work arounds, including clearing certs (hard, when cert list is full of self-signed localhost certs), history, cache, etc. until FF finally lets you "Confirm Security Exception". I am at my wits end, and will have to start thinking of alternative browsers for day to day use. FYI: IE & Chrome both let me confirm the damn exception and move on with my life.

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Shockwave Flash 11.2 r202
  • This plug-in detects the presence of iTunes when opening iTunes Store URLs in a web page with Firefox.
  • The Totem 3.0.1 plugin handles video and audio streams.
  • DivX Web Player version 1.4.0.233

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:19.0) Gecko/20100101 Firefox/19.0

Eminye Imininingwane

https://support.mozilla.org/en-US/kb/secure-connection-failed-error-message?esab=a&as=aaq#w_bypassing-the-warning
Note that step "5" does NOT work, as the button is greyed out.
Exact steps to reproduce bug (I have screen shots, and can repro at will):
1 - Access site w/invalid self-signed cert
2 - Understand Risks
3 - Add Security Exception (Permanently store)
4 - [generate new self-signed cert]
5 - Access same site w/new invalid self-signed cert
6 - Understand Risks
7 - Can NOT Add Security Exception
Bonus points for this being an ongoing issue for, what, years?

Umnikazi wombuzo

https://support.mozilla.org/en-US/kb/secure-connection-failed-error-message?esab=a&as=aaq#w_bypassing-the-warning

Note that step "5" does NOT work, as the button is greyed out.

Exact steps to reproduce bug (I have screen shots, and can repro at will):

1 - Access site w/invalid self-signed cert

2 - Understand Risks

3 - Add Security Exception (Permanently store)

4 - [generate new self-signed cert]

5 - Access same site w/new invalid self-signed cert

6 - Understand Risks

7 - Can NOT Add Security Exception

https://support.mozilla.org/en-US/kb/secure-connection-failed-error-message?esab=a&as=aaq#w_bypassing-the-warning Note that step "5" does NOT work, as the button is greyed out. Exact steps to reproduce bug (I have screen shots, and can repro at will): 1 - Access site w/invalid self-signed cert 2 - Understand Risks 3 - Add Security Exception (Permanently store) 4 - [generate new self-signed cert] 5 - Access same site w/new invalid self-signed cert 6 - Understand Risks 7 - Can NOT Add Security Exception

Okulungisiwe ngu donco

Umnikazi wombuzo

FYI:

To work around the issue, _usually_ one must only:

1 - Edit -> Preferences

2 - Advanced tab/button

3 - Encryption tab

4 - View Certificates

5 - Servers tab

6 - [find cert]

7 - Delete button

8 - OK to confirm delete

9 - OK to close Certificate Manager

10 - Close to close Preferences


11 - Add Exception button

12 - Confirm Security Exception button grayed out?

If not, you are done (jump to step 22); if not, continue to step 13.


13 - Cancel Add Security Exception

14 - Edit -> Preferences again

15 - Privacy tab/button

16 - clear your recent history link

17 - Time range to clear (I suggest Everything)

18 - Unselect all; Select Cache [only]

19 - Clear Now button

20 - Close to close Preferences


21 - Add Exception

22 - Unselect Permanently store this Exception

23 - Confirm Security Exception

And in 23 some odd steps, you too can work around this otherwise innocuous, frequently experienced issue in your lab environment.


Seriously, illustrious FF coders, fix this bug.


NOTE: If you still have a problem after step 23, get a young priest and an old priest, because I have this issue occur like clock work, and like clock work, the above fixes it every time.

FYI: To work around the issue, _usually_ one must only: 1 - Edit -> Preferences 2 - Advanced tab/button 3 - Encryption tab 4 - View Certificates 5 - Servers tab 6 - [find cert] 7 - Delete button 8 - OK to confirm delete 9 - OK to close Certificate Manager 10 - Close to close Preferences 11 - Add Exception button 12 - Confirm Security Exception button grayed out? If not, you are done (jump to step 22); if not, continue to step 13. 13 - Cancel Add Security Exception 14 - Edit -> Preferences again 15 - Privacy tab/button 16 - clear your recent history link 17 - Time range to clear (I suggest Everything) 18 - Unselect all; Select Cache [only] 19 - Clear Now button 20 - Close to close Preferences 21 - Add Exception 22 - Unselect Permanently store this Exception 23 - Confirm Security Exception And in 23 some odd steps, you too can work around this otherwise innocuous, frequently experienced issue in your lab environment. Seriously, illustrious FF coders, fix this bug. NOTE: If you still have a problem after step 23, get a young priest and an old priest, because I have this issue occur like clock work, and like clock work, the above fixes it every time.

Okulungisiwe ngu donco

Social 0 izisombululo 1 izimpendulo
Kuphostiwe

I select permanently store this exception for sites in Firefox

Hello, Our solution is here about the issue “select permanently store this exception for sites in Firefox” Open Firefox, 1. Tools 2. Privacy 3. Don’t use private browsing 4. OK 5. Restart Firefox You will be able to use: Permanently store this exception for the required web page After you can reactivate again the point 3 for your private browsing if desired. Let me know if it works

I select permanently store this exception for sites in Firefox Hello, Our solution is here about the issue “select permanently store this exception for sites in Firefox” Open Firefox, 1. Tools 2. Privacy 3. Don’t use private browsing 4. OK 5. Restart Firefox You will be able to use: Permanently store this exception for the required web page After you can reactivate again the point 3 for your private browsing if desired. Let me know if it works