Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

How do I keep No Proxy Configuration from changing back to Manual Proxy Configuration when I reboot Firefox?

  • 5 uphendule
  • 86 zinale nkinga
  • 76 views
  • Igcine ukuphendulwa ngu dcthomas62035

more options

I was infected with the 'Spyware Protection' virus. I was able to remove most of it with Malwarebytes Anti-Malware but one of the traces it left was resetting the proxy setting in Firefox to Manual Proxy configuration. This effectively means that Firefox can't access the net. I reset the proxy setting to No Proxy, but when I re-open Firefox the proxy setting returns to Manual Proxy configuration. I tried commenting out user_pref("network.proxy.http", "127.0.0.1"); user_pref("network.proxy.http_port", 58505); in prefs.js, I tried saving prefs.js as user.js with the statements commented out/deleted but when I re-open Firefox the proxy setting returns to Manual Proxy configuration. How do I keep Firefox from reverting to Manual Proxy configuration?

All Replies (5)

more options

prefs.js was not set to Read Only. Also, I tried was to rename prefs.js to prefs-bak.js and restarting Firefox. The proxy settings in Firefox were once again set to Manual Proxy configuration and prefs.js reappeared with Manual Proxy configuration. Thanks for trying.

more options

I looked for files modified at the time I thought a similar Malware acted on my PC.

Found 3 lines added to the:

C:/users/xxxxxmyprofile/appdata/roaming/mozilla/firefox/profiles/xxxxx.default/extensionsfoxmarks@kei.com/default/preferences/prefs.js

I removed them, and I saved the prefs.js file again. They were like: user_pref("network.proxy.http", "127.0.0.1"); user_pref("network.proxy.http_port", 58505); user_pref("network.proxy.type", 1); More or less.

My suggestions: Check all *.js files in firefox/ subfolders, plugins included (in my case, as you can see, it was in foxmarks subfolder).

Took me a while, finally solved.

more options

I registered for an account just so I could say "Thank you" to paronigor!! I have been working on this situation all day, jumping through all kinds of hoops. This is the only thing that solved it. Your instructions were well laid out & worked like a charm. THANK YOU!

more options

Great work. Maybe your instructions say this, but I deleted the pref.js file, went back to options and specified the 'auto-detect proxy settings for this network' button again. I closed Firefox and re-opened. Shazaam. Again, thank you for your post. If anyone knows how this malware is being propagated, please let us know.