Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Opening PDFs

  • 4 uphendule
  • 0 zinale nkinga
  • 20 views
  • Igcine ukuphendulwa ngu zeroknight

more options

Hello,

I want Firefox to open PDFs in browser. I have opt in for two options from setting both are not working.

1. I have choose always ask where to save files and that is not working because it is always saving files in downloads. 2. I have choose Firefox option from save or open files to open files and not save files; it did not work (Firefox downloaded the files not opened it). Then I tried always ask, from always ask menu then I choose open with Firefox and it opened in Firefox but it saved the file.

Please let me know how can this issue be resolved. I do not want to download files and when I do want to download, I want to choose a specific location for each file. I am trying a transition to Firefox from chrome. So, I am very new to these settings.

I have attached a picture of setting in this request.

Thank you for your help! Dilpreet

Hello, I want Firefox to open PDFs in browser. I have opt in for two options from setting both are not working. 1. I have choose always ask where to save files and that is not working because it is always saving files in downloads. 2. I have choose Firefox option from save or open files to open files and not save files; it did not work (Firefox downloaded the files not opened it). Then I tried always ask, from always ask menu then I choose open with Firefox and it opened in Firefox but it saved the file. Please let me know how can this issue be resolved. I do not want to download files and when I do want to download, I want to choose a specific location for each file. I am trying a transition to Firefox from chrome. So, I am very new to these settings. I have attached a picture of setting in this request. Thank you for your help! Dilpreet
Ama-screenshot ananyekiwe

All Replies (4)

more options

Change browser.download.open_pdf_attachments_inline and/or browser.download.force_save_internally_handled_attachments to true in about:config then restart the browser.

Helpful?

more options

Did all three things and still same problem.

Helpful?

more options

Thank you for choosing Firefox, unfortunately Firefox has not support in the case of not downloading the file to open the PDF file in the Web, but you want to save the PDF file in your own location, this can be achieved! First in the Firefox settings will be set to open the PDF with Firefox, and then find the button shown in the figure, so you can save the PDF as your favorite location. As for the residual PDF files in the download folder, you can take the time to clean up.

Helpful?

more options

It works for me with those settings, try applying them in a new profile. An easy way to test a new profile is to install Developer Edition and see if it happens there or refresh your existing profile. Make sure you stay signed out of your sync account when testing.

Helpful?

Buza umbuzo

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.