Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

No support of 64bit PKCS#11 drivers for signing devices (i.e. smart cards) on 64bit Firefox

  • 1 baphendule
  • 2 zinale nkinga
  • 38 views
  • Igcine ukuphendulwa ngu kralpatr

more options

Hi, this is the same issue as as described here for Mozilla Thunderbird: 64bit Thunderbird issues with 64bit PKCS#11 drivers

– Firefox 122.0 (64-bit) – Windows 11 Pro 64bit (– Thunderbird 64bit)

Even though, I use a 64bit version of Firefox, it is not able to load any 64bit PKCS#11 module for security devices. Tried on several different PCs and several different 64bit PKCS#11 drivers for different smart cards.

When I try to load e.g. C:\Windows\SysWOW64\eop2v1czep11.dll for the Czech eID, it returns "Unable to add module". When I do the same from C:\Windows\System32\eop2v1czep11.dll, it works.

The issue is that some issuers of qualified and commercial certificates (like e.g. Komerční banka) do not issue a 32bit version of PKCS#11 drivers for their smart cards anymore and the only driver available is C:\Windows\SysWOW64\mopkcs11.dll, which cannot be loaded by Firefox or Thunderbird either.

I don't see a problem in implementing the support for 64bit PKCS drivers in a 64bit browser and a 64bit email client. And if it does have the support, then there is something wrong going on.

Hi, this is the same issue as as described here for Mozilla Thunderbird: [[No support of 64bit PKCS#11 drivers for signing device (i.e. smart cards) on 64bit Thunderbird|64bit Thunderbird issues with 64bit PKCS#11 drivers]] – Firefox 122.0 (64-bit) – Windows 11 Pro 64bit (– Thunderbird 64bit) Even though, I use a 64bit version of Firefox, it is not able to load any 64bit PKCS#11 module for security devices. Tried on several different PCs and several different 64bit PKCS#11 drivers for different smart cards. When I try to load e.g. C:\Windows\SysWOW64\eop2v1czep11.dll for the [https://info.identitaobcana.cz/eOP/OvladaceKarty.aspx Czech eID], it returns "Unable to add module". When I do the same from C:\Windows\System32\eop2v1czep11.dll, it works. The issue is that some issuers of qualified and commercial certificates (like e.g. [https://www.kb.cz/en/certification-services-kb Komerční banka]) do not issue a 32bit version of PKCS#11 drivers for their smart cards anymore and the only driver available is C:\Windows\SysWOW64\mopkcs11.dll, which cannot be loaded by Firefox or Thunderbird either. I don't see a problem in implementing the support for 64bit PKCS drivers in a 64bit browser and a 64bit email client. And if it does have the support, then there is something wrong going on.
Ama-screenshot ananyekiwe

Isisombululo esikhethiwe

Sorry for the confusion, Windows are a bit ati-intuitive compared to MacOS or Ubuntu. System32 is a 64-bit repository and SysWOW64 is a 32bit repository. The 64-bit versions of Firefox and Thunderbird correctly support the PKCS#11 drivers from System32 (the 64-bit repository).

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (1)

more options

Isisombululo Esikhethiwe

Sorry for the confusion, Windows are a bit ati-intuitive compared to MacOS or Ubuntu. System32 is a 64-bit repository and SysWOW64 is a 32bit repository. The 64-bit versions of Firefox and Thunderbird correctly support the PKCS#11 drivers from System32 (the 64-bit repository).

Helpful?

Buza umbuzo

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.