Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Don't close tabs on exit

  • 6 uphendule
  • 1 inale nkinga
  • 26 views
  • Igcine ukuphendulwa ngu pr0paGandhi

more options

I prefer to have all my previous tabs open when I start up Firefox, which means that I don't want them to close upon exit. Recently, Firefox started closing my tabs upon exit, even though:

- I tried both hitting the X and choosing Exit from the hamburger menu
- I have checked "Open previous windows and tabs" upon startup in settings
- I have not checked "Delete Cookies and Site Settings when Firefox is closed"

- I have the option "Firefox will remember history" selected

- I do not open in Private Browsing mode

What other settings do I need to change? Debra

I prefer to have all my previous tabs open when I start up Firefox, which means that I don't want them to close upon exit. Recently, Firefox started closing my tabs upon exit, even though: - I tried both hitting the X and choosing Exit from the hamburger menu - I have checked "Open previous windows and tabs" upon startup in settings - I have not checked "Delete Cookies and Site Settings when Firefox is closed" - I have the option "Firefox will remember history" selected - I do not open in Private Browsing mode What other settings do I need to change? Debra

All Replies (6)

more options

Are you possibly using "Clear history when Firefox closes" and did you check its settings ?

Note that reopening tabs isn't about "Delete cookies and site data when Firefox is closed" (that is about a website remember you/login automatically), but about clearing the history when you close Firefox.

more options

Does it still happen with all your extensions disabled?

more options

Thanks for the suggestions. I don't have any extensions loaded and have the option "Firefox will remember history" chosen already. Could not find "Clear history when Firefox closes" in settings. However, the problem does appear to be resolved; my tabs do reopen when I open Firefox. I had 2 instances when the tabs did not reopen yesterday and toggled off/on all of the settings that I mentioned in my question in my troubleshooting endeavors, so perhaps one of these settings had not "stuck" previously, but did after the toggling.

more options

This can happen when a different profile is loaded, you can see other profiles by visiting about:profiles in the address bar.

more options

Thanks for the thought, but there are no other profiles loaded. As I mentioned in the last post, the issue has been resolved.

more options

Chiming in in case anyone else ever has this problem.

Had the exact same issue, all options pointed towards "leave my goddamn tabs open between sessions" and yet Firefox would ask me if I'm sure I want to close them every time I wanted to exit Firefox (force exiting through task manager luckily worked correctly)

Resolved by following OPs solution: Go into Options, re-do all the relevant options (untick and tick again or vice versa) and bam, works again.