Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Credit card autofill feature has disappeared from settings??

  • 12 uphendule
  • 2 zinale nkinga
  • 261 views
  • Igcine ukuphendulwa ngu zeroknight

more options

I constantly used the auto fill for credit cards, but went to pay for something and it didn't auto fill so I went to settings and there is no auto fill section under privacy and security?? WTH??

I constantly used the auto fill for credit cards, but went to pay for something and it didn't auto fill so I went to settings and there is no auto fill section under privacy and security?? WTH??

Isisombululo esikhethiwe

Change browser.search.region to US in about:config then restart the browser.

It could possibly be confused be recent travel or using a VPN/proxy in a different country.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 5

All Replies (12)

more options

Surely someone knows the answer to this - how does it just disappear? Why is there no customer service?

more options

Hi

Are you able to share a screenshot of what you see when you try to follow the steps in this support article?

https://support.mozilla.org/en-US/kb/autofill-credit-cards-firefox-ios

more options

Very simple - the autofill option simply isn't there where it always used to be under passwords in settings as shown in screen shot.

more options

Hi

It looks like you are using a desktop version of Firefox rather than Firefox for iOS. This support article should help:

https://support.mozilla.org/en-US/kb/credit-card-autofill

more options

You need to be in a supported country (US, CA, GB, FR, DE). You can force-enable it by adding your two-letter country code to extensions.formautofill.creditCards.supportedCountries in about:config. Nightly 118 has additional support for IT, ES, AT, BE and PL.

more options

I am in the States! That's why I was using it. Using extensions.formautofill.creditCards.supportedCountries doesn't change anything as US is already listed.

Okulungisiwe ngu cobbsimone

more options

Isisombululo Esikhethiwe

Change browser.search.region to US in about:config then restart the browser.

It could possibly be confused be recent travel or using a VPN/proxy in a different country.

more options

Thanks zeroknight, that fixed it!

more options

I am having this issue on iOS. I have read the online article that says it should be under settings, then under privacy. I have no such option. I am in the US and do not have my VPN running. Any help would be greatly appreciated!

more options

I can confirm that with 119, using all of the proposed suggestions above, the credit card section is completely missing from the Settings, under any search term ('payment', 'credit', 'pay', and so on). In fact, the entire "Forms and Autofill" section is gone on 119.b05 on my Linux machine, but on my Mac running 119.b03, it is still present.

I'll roll back on my Linux box to 119.b03 and see if it was removed between b03 and b05.

[...] .. time passes

Confirmed: Rolling back to 119.b03 on Linux returns the missing "Forms and Autofill" dialog. I'll block automatic upgrades via policy and hold on this version.

Okulungisiwe ngu setuid

more options

Try to set the extensions.formautofill.* prefs that have a value of "detect" to "on". Close and restart Firefox after modifying the settings to apply changes.

Okulungisiwe ngu cor-el

more options

The above methods still work for me on 119.0b5, in addition to:

extensions.formautofill.addresses.supported = on extensions.formautofill.creditCards.supported = on