Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Cannot do fresh install - Get "Can not open temp folder archive" message

  • 2 uphendule
  • 1 inale nkinga
  • 3 views
  • Igcine ukuphendulwa ngu K in NC

more options

Firefox wasn't working well on a seldom-used laptop, and the update to 100.0.1 didn't go quite right, so I deleted the old version and (using the odious Edge) tried downloading a fresh copy of the software.

But then I get a message from "7-ZIP" that reads "Can not create temp folder archive"

I'm stuck. Advice?

Firefox wasn't working well on a seldom-used laptop, and the update to 100.0.1 didn't go quite right, so I deleted the old version and (using the odious Edge) tried downloading a fresh copy of the software. But then I get a message from "7-ZIP" that reads "Can not create temp folder archive" I'm stuck. Advice?

Isisombululo esikhethiwe

I solved my problem just seconds before I heard from you.

I tried the .msi version and had the same problem, but then I did two things (and, no, I'm not sure which worked, but in any case I'm fine now):

1 - Deleted any files identifiable as from Mozilla in my TEMP folder, and 2 - Re-ran the install wearing my Administrator hat instead of my Just-Plain-Me hat.

And I'm back in business, and glad of it!

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (2)

more options

Is this a managed system, i.e., security is controlled by an IT department? From time to time, users discover that they cannot use the regular installers, which are packaged using 7-zip, an open source archiving program, because it runs into a security restriction. However, at this point I can't recall the fix for that.

Does it make any difference if you use the .msi version of the installer from here:

http://archive.mozilla.org/pub/firefox/releases/101.0.1/win64/en-US/

That is U.S. English, so if you prefer a different language or locale, click the .. link to navigate up one level and click into the folder for your preferred locale.

more options

Isisombululo Esikhethiwe

I solved my problem just seconds before I heard from you.

I tried the .msi version and had the same problem, but then I did two things (and, no, I'm not sure which worked, but in any case I'm fine now):

1 - Deleted any files identifiable as from Mozilla in my TEMP folder, and 2 - Re-ran the install wearing my Administrator hat instead of my Just-Plain-Me hat.

And I'm back in business, and glad of it!