On Aug 14th 11 PM ET/Aug 15th 03:00 UTC, due to scheduled Firefox Account server maintenance, users may not be able to sign in or create a new subscription. This is expected to last approximately 30 minutes. Status updates can be found at https://status.vpn.mozilla.org or https://status.relay.firefox.com.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Thunderbird autodetele messages interval

  • 3 uphendule
  • 1 inale nkinga
  • 56 views
  • Igcine ukuphendulwa ngu Toad-Hall

more options

Hello. Decided to turn on auto-delete messages feature, but default autodelete time set at 30 days. When trying to enable this feature, mozilla says that this will delete messages from PC and server, so here's the question, how to set it up around 900 days before enabling? (need to delete messages older than 2018)

Hello. Decided to turn on auto-delete messages feature, but default autodelete time set at 30 days. When trying to enable this feature, mozilla says that this will delete messages from PC and server, so here's the question, how to set it up around 900 days before enabling? (need to delete messages older than 2018)

Isisombululo esikhethiwe

Good question. Something has changed because I previously tested those areas, albeit a while ago - so I've created a bug report. https://bugzilla.mozilla.org/show_bug.cgi?id=1744107

Note: For each folder there is also an option Right click on folder > Properties > Retention Policy You have to uncheck 'Use my account settings' This offers access to selecting a delete option. If you select radio button 'Delete messages more than x days old' You get access to changing the number of days before you click on OK. Same with 'Delete all but the most recent x messages.'

So that method offers access to Retention Policy but only via one folder at a time.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (3)

more options

Isisombululo Esikhethiwe

Good question. Something has changed because I previously tested those areas, albeit a while ago - so I've created a bug report. https://bugzilla.mozilla.org/show_bug.cgi?id=1744107

Note: For each folder there is also an option Right click on folder > Properties > Retention Policy You have to uncheck 'Use my account settings' This offers access to selecting a delete option. If you select radio button 'Delete messages more than x days old' You get access to changing the number of days before you click on OK. Same with 'Delete all but the most recent x messages.'

So that method offers access to Retention Policy but only via one folder at a time.

more options

Toad-Hall said

Good question. Something has changed because I previously tested those areas, albeit a while ago - so I've created a bug report. https://bugzilla.mozilla.org/show_bug.cgi?id=1744107 Note: For each folder there is also an option Right click on folder > Properties > Retention Policy You have to uncheck 'Use my account settings' This offers access to selecting a delete option. If you select radio button 'Delete messages more than x days old' You get access to changing the number of days before you click on OK. Same with 'Delete all but the most recent x messages.' So that method offers access to Retention Policy but only via one folder at a time.
This is the solution for topic question, but there's another problem :) How to activate this policy? Messages won't delete even after thunderbird restart
more options

Right click on folder and select 'Compact'