Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox Developer Edition doesn't display screenshots correctly

  • 3 uphendule
  • 1 inale nkinga
  • 14 views
  • Igcine ukuphendulwa ngu cor-el

more options

After I take a screenshot of the whole screen or a part of the screen on Windows, it goes to the clipboard. But when i paste this screenshot in websites, it appears in a bunch of coloured stripes, like a broken TV screen. What's the problem?

After I take a screenshot of the whole screen or a part of the screen on Windows, it goes to the clipboard. But when i paste this screenshot in websites, it appears in a bunch of coloured stripes, like a broken TV screen. What's the problem?
Ama-screenshot ananyekiwe

Isisombululo esikhethiwe

This is characteristic of the privacy.resistFingerprinting feature that some users enable through about:config. One of its behaviors is to stripe out images extracted from an HTML canvas.

When this happens, there usually will be an additional permission icon at the left end of the address bar near the lock icon. Look for it on the site you are pasting to. Does it show up? If so, you can use that to give the site permission to extract images from a canvas without blurring.

If there's no icon for it, try the Page Info dialog. While you are on the relevant page, you can call that up using either:

  • Ctrl+i (for Mac, Command+i)
  • right-click a blank area of the page > View Page Info
  • (menu bar) Tools > Page Info

When the dialog comes up, click the Permission icon at the top to show that panel.

Near the top, you'll find "Extract Canvas Data" and you can uncheck the "Use default" box and select the Allow permission. (Note: this permission only appears if privacy.resistFingerprinting has been enabled.)

That change is saved immediately. You can close Page Info and it should be effective on your next upload.

Was that it?

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (3)

more options

Isisombululo Esikhethiwe

This is characteristic of the privacy.resistFingerprinting feature that some users enable through about:config. One of its behaviors is to stripe out images extracted from an HTML canvas.

When this happens, there usually will be an additional permission icon at the left end of the address bar near the lock icon. Look for it on the site you are pasting to. Does it show up? If so, you can use that to give the site permission to extract images from a canvas without blurring.

If there's no icon for it, try the Page Info dialog. While you are on the relevant page, you can call that up using either:

  • Ctrl+i (for Mac, Command+i)
  • right-click a blank area of the page > View Page Info
  • (menu bar) Tools > Page Info

When the dialog comes up, click the Permission icon at the top to show that panel.

Near the top, you'll find "Extract Canvas Data" and you can uncheck the "Use default" box and select the Allow permission. (Note: this permission only appears if privacy.resistFingerprinting has been enabled.)

That change is saved immediately. You can close Page Info and it should be effective on your next upload.

Was that it?

more options

Yes, man, it really helped. Thank you very much!

more options

See also:

  • about:config => privacy.resistFingerprinting.autoDeclineNoUserInputCanvasPrompts