Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

urlbar search with empty query

  • 2 uphendule
  • 1 inale nkinga
  • 11 views
  • Igcine ukuphendulwa ngu maiphi

more options

With Firefox 86 it is no more possible to use a search keyword in the urlbar with an empty query string to open the corresponing web page. E.g. I type "g" for Google followed by <space> and the urlbar notices I want to perform a Google search. But pressing <enter> has no effect until I actually enter a string (other than whitespace) to search for. In previous version it was possible to just search for nothing to open the search page (like a shortcut to the search web page).

In Firefox 83, the old behaviour could still be restored by setting browser.urlbar.update2=false. This doesn't work anymore since version 86.

Is there a possibility to get the old behaviour back?

All Replies (2)

more options

For me both "g" and "g " opens the Google search page if i press the Enter key.

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or userChrome.css is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window

Try the Firefox version from the official Mozilla server if you currently use a version from the repositories of your Linux distribution.

more options

Thanks for your reply, but this is not a configuration problem and it is neither caused by an add-on, nor by a modified userChome.css. It happens with a completely new profile (I deleted ~/.mozilla to test it). The only difference is that the default keyword for Google is "@google". If Google is your default search engine and "g" is not set as search keyword, of course entering "g" will open Google and serach for the letter "g".

Let's e.g. use DuckDuckGo instead with the default keyword "@ddg". Type in "@ddg " (note the trailing space space). You'll get a blue box in the url bar with "DuckDuckGo" written in it. At that point, pressing enter has no effect. You must type in a non-whitespace string to open the DuckDuckGo web page.