Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why does Firefox have an enlarged URL window at the top now?

  • 5 uphendule
  • 2 zinale nkinga
  • 20 views
  • Igcine ukuphendulwa ngu jscher2000

more options

Opening a new tap in Firefox now has the URL window exaggerated. It is intrustive. How do I change a setting to eliminate this annoyance?

Isisombululo esikhethiwe

gogators1 said

Opening a new tap in Firefox now has the URL window exaggerated. It is intrustive. How do I change a setting to eliminate this annoyance?

Hello gogators1,

I hope that I'm not misconstruing your question, but I think that you're talking about the "new address bar behavior".

If that's the case, and you want the "old address bar behavior" back :

This is a temporary fix (so I'm told), but I am optimistically hoping that they will give us the opportunity to permanently disable this feature.

Would you do this please :

Type in the address bar about:config and press Enter. (ignore the warning)

Type in the search bar and look for the preference :

browser.urlbar.openViewOnFocus

and set its value to false

Do the same with these preferences :

browser.urlbar.update1

browser.urlbar.update1.interventions

browser.urlbar.update1.searchTips

Then close and restart Firefox.

(if it's only the Top Sites suggestions that you want to get rid of :
setting the value of first preference to "false" will do that)

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (5)

more options

Isisombululo Esikhethiwe

gogators1 said

Opening a new tap in Firefox now has the URL window exaggerated. It is intrustive. How do I change a setting to eliminate this annoyance?

Hello gogators1,

I hope that I'm not misconstruing your question, but I think that you're talking about the "new address bar behavior".

If that's the case, and you want the "old address bar behavior" back :

This is a temporary fix (so I'm told), but I am optimistically hoping that they will give us the opportunity to permanently disable this feature.

Would you do this please :

Type in the address bar about:config and press Enter. (ignore the warning)

Type in the search bar and look for the preference :

browser.urlbar.openViewOnFocus

and set its value to false

Do the same with these preferences :

browser.urlbar.update1

browser.urlbar.update1.interventions

browser.urlbar.update1.searchTips

Then close and restart Firefox.

(if it's only the Top Sites suggestions that you want to get rid of :
setting the value of first preference to "false" will do that)

Okulungisiwe ngu McCoy

Helpful?

more options

Thanks. Works perfectly! PS: My original question should have said "tab" not "tap."

Helpful?

more options

gogators1 said

Thanks. Works perfectly!

My pleasure ! Keeping my fingers crossed that they will give us the choice to permanently disable this 'new feature'.

PS: My original question should have said "tab" not "tap."
Typos   -   I make them all the time !

Helpful?

more options

Well, that no longer works. Why doesn't Mozilla give relief to many who have posted about this? If you could change the auto:config switch before, it's cowardly behavior to eliminate it and force the issue. So, Mozilla, why not answer directly?

Helpful?

more options

Hi gogators1, we support forum volunteers can't always explain design decisions. Have you already found the new approach to taming the enlargement?

It involves creating a userChrome.css file to modify the appearance of the user interface area. Your first time, please set aside 10 quiet minutes to go through it since there are several steps.

(For anyone who already has a working userChrome.css file set up, you just need to add the rules you downloaded under (A) to your file.)

(A) Download a rules file

https://www.userchrome.org/samples/userChrome-ZeroEnlargement.css

Use the downloads list on the toolbar to open the downloads folder directly to the new userChrome.css file. (See attached screenshot)

Minimize that file browser window for later reference.

(B) Create a new chrome folder in your profile folder

The following article has the detailed steps for that (#1, #2, and I recommend #3)

https://www.userchrome.org/how-create-userchrome-css.html

I have videos for both Windows and Mac in case the text is not clear.

(C) Move the userChrome-ZeroEnlargement.css file you downloaded in Step A into the chrome folder you created in Step B

(D) If you do not already have a userChrome.css file, Rename the userChrome-ZeroEnlargement.css file

Highlight userChrome-ZeroEnlargement.css and choose Rename (using whatever method Finder offers). Carefully remove -ZeroEnlargement and press Enter to save your change. The final file name needs to be userChrome.css or Firefox will never find it.

(E) Set Firefox to look for userChrome.css at startup -- see step #6 in the above article.

The next time you exit Firefox and start it up again, it should discover that file and apply the rules.

Success?

Once you start tweaking the interface this way, you'll probably find more and more things you want to do. I suggest bookmarking the pages where you get the code for future reference because changes to Firefox may break them and it's easier to request an update if you can find the source.

Helpful?

Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.