X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.
Scheduled maintenance: Thursday, April 2, between 3pm and 5pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @firefox on Twitter

Isithangami Sabeseki

Recently added bookmarks won't have favicons

Kuphostiwe

Hello everyone!

I'm having a pretty weird problem here. Whenever I add a new site, it will show that grey globe instead of it's favicon on the bookmarks. If I go to my bookmarks and click on the recently added site, it will then load the favicon normaly, but that's the only way of "forcing" it to load.

Any idea of why this may be happening?

Hello everyone! I'm having a pretty weird problem here. Whenever I add a new site, it will show that grey globe instead of it's favicon on the bookmarks. If I go to my bookmarks and click on the recently added site, it will then load the favicon normaly, but that's the only way of "forcing" it to load. Any idea of why this may be happening?
Isicaphuno

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Shockwave Flash 32.0 r0

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:71.0) Gecko/20100101 Firefox/71.0

Eminye Imininingwane

NoahSUMO
  • Moderator
99 izisombululo 639 izimpendulo
Kuphostiwe

Impendulo Ewusizo

That is strange. I'm wondering if the .sqlite file for the bookmark favicons got corrupted causing it to need you to visit the site manually to make the favicon appear.

You could try moving or renaming the favicons.sqlite file [don't delete it] in the Firefox profile folder while Firefox is not running. Then start Firefox & allow it to reload all the favicons from scratch. It will rebuild a new favicons.sqlite file on startup if it can't find a file with that name & hopefully that should fix the issue. If not, it may be a new bug we'll have to report.

If the favicons situation gets worse somehow, you can always just close down Firefox again & place the original favicons.sqlite file back in the Firefox profile folder. And it will be back to the previous state.

That is strange. I'm wondering if the .sqlite file for the bookmark favicons got corrupted causing it to need you to visit the site manually to make the favicon appear. You could try moving or renaming the favicons.sqlite file [don't delete it] in the [https://support.mozilla.org/en-US/kb/profiles-where-firefox-stores-user-data#w_how-do-i-find-my-profile Firefox profile folder] while Firefox is not running. Then start Firefox & allow it to reload all the favicons from scratch. It will rebuild a new favicons.sqlite file on startup if it can't find a file with that name & hopefully that should fix the issue. If not, it may be a new bug we'll have to report. If the favicons situation gets worse somehow, you can always just close down Firefox again & place the original favicons.sqlite file back in the Firefox profile folder. And it will be back to the previous state.
Ingabe lokhu kube usizo kuwena? 1
Isicaphuno

Umnikazi wombuzo

Thank you so much for the quick answer!

Unfortunately, doing as described didn't solve the problem. It would still behave in the same way.

By the way, this only seems to happen here on my Windows 10 PC. I have a notebook running on Windows 7 with it's Firefox in Sync, and it don't have any problem with the favicons (although I will double check there as soon as I can just to be 100% sure).

Thank you so much for the quick answer! Unfortunately, doing as described didn't solve the problem. It would still behave in the same way. By the way, this only seems to happen here on my Windows 10 PC. I have a notebook running on Windows 7 with it's Firefox in Sync, and it don't have any problem with the favicons (although I will double check there as soon as I can just to be 100% sure).
Ingabe lokhu kube usizo kuwena?
Isicaphuno
cor-el
  • Top 10 Contributor
  • Moderator
17857 izisombululo 161589 izimpendulo
Kuphostiwe

How are you creating the new bookmark ?

If you click the star in the location/address bar then Firefox should add the favicon automatically. If you create the new bookmark manually then you need to open the bookmark in a tab to make Firefox add the favicon.

How are you creating the new bookmark ? If you click the star in the location/address bar then Firefox should add the favicon automatically. If you create the new bookmark manually then you need to open the bookmark in a tab to make Firefox add the favicon.
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

I'm using the star to create all my bookmarks. Actually, I never created one manually.

A little update regarding my notebook: Tried to bookmark something there, and it worked perfectly, favicon and all. Came to my PC and Firefox didn't even synchronized the site I bookmarked there. Definitely something is very wrong here.

I'm using the star to create all my bookmarks. Actually, I never created one manually. A little update regarding my notebook: Tried to bookmark something there, and it worked perfectly, favicon and all. Came to my PC and Firefox didn't even synchronized the site I bookmarked there. Definitely something is very wrong here.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
macciofe 0 izisombululo 13 izimpendulo
Kuphostiwe

I'm having the same problem with favicons that were installed via syncing with firefox on my other computers. Some of the favicons were corrected when I visited the site. Others were not.

I'm having the same problem with favicons that were installed via syncing with firefox on my other computers. Some of the favicons were corrected when I visited the site. Others were not.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.