X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Browser does not launch for https

Kuphostiwe

After an upgrade, a browser is not launched for https links. http links do work.

Per documentation, I have set
     network.protocol-handler.warn-external.https = true

When a link is clicked, a menu should open to allow selection of a browser, but it does not. When an https link is clicked, nothing happens.

According to documentation, setting network.protocol-handler.app.https directly no longer works. I tried setting it anyway, but as expected it has no effect.

FYI I am running Thunderbird 60.80.0 on Debian 10 (Buster).

Reinstalling thunderbird had no effect. Of course I did not delete my profile.

Any suggestion would be appreciated.

After an upgrade, a browser is not launched for https links. http links do work. Per documentation, I have set network.protocol-handler.warn-external.https = true When a link is clicked, a menu should open to allow selection of a browser, but it does not. When an https link is clicked, nothing happens. According to documentation, setting network.protocol-handler.app.https directly no longer works. I tried setting it anyway, but as expected it has no effect. FYI I am running Thunderbird 60.80.0 on Debian 10 (Buster). Reinstalling thunderbird had no effect. Of course I did not delete my profile. Any suggestion would be appreciated.
Isicaphuno

Eminye Imininingwane Yohlelo

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Firefox/68.0

Eminye Imininingwane

День сумо 10 izisombululo 273 izimpendulo
Kuphostiwe

Hello there Bdwgen.


(Scannend for virus) Unix/Linux.


Just A moment please!


Open up Thunderbird.

Thunderbird running on Linux Select Edit from the top menu. Then, choose Preferences from the Edit options.

Thunderbird Edit menu The Preferences window will pop open. Select the Advanced tab.

Thunderbird advanced preferences In the bottom right of the window, press Config Editor...



Another window will open, warning you that you can potentially break Thunderbird in the Config Editor. Press I accept the risk! to move forward.

Thunderbird config editor warning Use the search at the top of the Config Editor window to look for:

network.protocol-handler.warn-external.http Thunderbird config editor Double-click both:

network.protocol-handler.warn-external.http and

network.protocol-handler.warn-external.https to set their value to True.

Thunderbird config editor search results Now, close the Config Editor.

Thunderbird config editor with options changed Back on the Preferences window, select the Attachments tab.

Look for http (http) in the Content Type column. Select on the value in the Action column in the same row to see a list of choices that includes all of the web browsers currently installed on your computer. Chooset the new action you'd like Thunderbird to take when it encounters a URL that starts with "http."

Thunderbird attachment preferences Now, do the exact same thing for https (https) in the Content Type column. This will cover every time Thunderbird opens a URL that begins with "https."

Press Close to exit the Preferences window.

Restart Thunderbird.

If everything worked, Thunderbird should now send clicks on URLs to whatever browser you selected in steps 5 and 6 above.



Let me hear from you



Greetings Firefox volunteer.

Hello there Bdwgen. (Scannend for virus) Unix/Linux. Just A moment please! Open up Thunderbird. Thunderbird running on Linux Select Edit from the top menu. Then, choose Preferences from the Edit options. Thunderbird Edit menu The Preferences window will pop open. Select the Advanced tab. Thunderbird advanced preferences In the bottom right of the window, press Config Editor...  Another window will open, warning you that you can potentially break Thunderbird in the Config Editor. Press I accept the risk! to move forward. Thunderbird config editor warning Use the search at the top of the Config Editor window to look for: network.protocol-handler.warn-external.http Thunderbird config editor Double-click both: network.protocol-handler.warn-external.http and network.protocol-handler.warn-external.https to set their value to True. Thunderbird config editor search results Now, close the Config Editor. Thunderbird config editor with options changed Back on the Preferences window, select the Attachments tab. Look for http (http) in the Content Type column. Select on the value in the Action column in the same row to see a list of choices that includes all of the web browsers currently installed on your computer. Chooset the new action you'd like Thunderbird to take when it encounters a URL that starts with "http." Thunderbird attachment preferences Now, do the exact same thing for https (https) in the Content Type column. This will cover every time Thunderbird opens a URL that begins with "https." Press Close to exit the Preferences window. Restart Thunderbird. If everything worked, Thunderbird should now send clicks on URLs to whatever browser you selected in steps 5 and 6 above. Let me hear from you Greetings Firefox volunteer.

Okulungisiwe ngu День сумо

Ingabe lokhu kube usizo kuwena? 0
Isicaphuno

Umnikazi wombuzo

I already tried to do this, but my Preferences -> Attachments window does not have 'Content Type' entries for http (or https). There is an 'Html document' content type set to firefox.

There does not appear to be any way to add content types. If there is, please let me know.

I already tried to do this, but my Preferences -> Attachments window does '''not''' have 'Content Type' entries for http (or https). There is an 'Html document' content type set to firefox. There does not appear to be any way to add content types. If there is, please let me know.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
sfhowes
  • Top 10 Contributor
1545 izisombululo 7380 izimpendulo
Kuphostiwe

There should not be any entries for http or https in Pref./Attachments, and when a link is clicked, TB will open it in the system default browser. I recommend you set all preferences beginning with network.protocol-handler to their defaults (right-click, Reset), OK to close Preferences, restart TB.

There should not be any entries for http or https in Pref./Attachments, and when a link is clicked, TB will open it in the system default browser. I recommend you set all preferences beginning with network.protocol-handler to their defaults (right-click, Reset), OK to close Preferences, restart TB.
Ingabe lokhu kube usizo kuwena? 0
Isicaphuno

Umnikazi wombuzo

I've already tried this but I tried it again. It has no effect. http links still open, https links do not.

PS FYI this version of thunderbird (60.80.0 on Debian 10) does not have an 'OK' button to close Preferences. It does have a 'Close' button which presumably is the same thing.

I've already tried this but I tried it again. It has no effect. http links still open, https links do not. PS FYI this version of thunderbird (60.80.0 on Debian 10) does not have an 'OK' button to close Preferences. It does have a 'Close' button which presumably is the same thing.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
sfhowes
  • Top 10 Contributor
1545 izisombululo 7380 izimpendulo
Kuphostiwe

It looks like you tried everything in the support article, but did you also try safe mode (Help/Restart with Add-ons Disabled)?

It looks like you tried everything in the [https://support.mozilla.org/en-US/kb/hyperlinks-in-messages-not-working support article], but did you also try safe mode (Help/Restart with Add-ons Disabled)?
Ingabe lokhu kube usizo kuwena? 0
Isicaphuno

Umnikazi wombuzo

I hadn't but just did. Running in safe mode Add-ons disabled has no effect.

I hadn't but just did. Running in safe mode Add-ons disabled has no effect.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
День сумо 10 izisombululo 273 izimpendulo
Kuphostiwe

Hello there again Bdwgen.



Hi there. we were wondering about the security of your operating system?


Have you entered a complete input field somewhere before going online for this or not at all it is Debian 10 here.


Do you know more about this yourself? So that we have more insight into that subject?


https://linuxconfig.org/how-to-connect-to-wifi-from-the-cli-on-debian-10-buster

https://www.linux.com/tutorials/how-use-linux-command-line-basics-cli/

https://www.debian.org/doc/manuals/securing-debian-howto/ch4.en.html

https://www.debian.org/doc/manuals/securing-debian-howto/ch-sec-services.en.html (Scanned for virus)



Greetings Firefox Volunteer.

Hello there again Bdwgen. Hi there. we were wondering about the security of your operating system? Have you entered a complete input field somewhere before going online for this or not at all it is Debian 10 here. Do you know more about this yourself? So that we have more insight into that subject? https://linuxconfig.org/how-to-connect-to-wifi-from-the-cli-on-debian-10-buster https://www.linux.com/tutorials/how-use-linux-command-line-basics-cli/ https://www.debian.org/doc/manuals/securing-debian-howto/ch4.en.html https://www.debian.org/doc/manuals/securing-debian-howto/ch-sec-services.en.html (Scanned for virus) Greetings Firefox Volunteer.

Okulungisiwe ngu День сумо

Ingabe lokhu kube usizo kuwena? 0
Isicaphuno

Umnikazi wombuzo

"we were wondering about the security of your operating system?"

^ I'm don't see how this is relevant. I'm running Debian 10 and all security related upgrades have been installed.

"Have you entered a complete input field somewhere before going online for this or not at all it is Debian 10 here."

^ I don't know what you mean by 'a complete input field for this'.

thanks

"we were wondering about the security of your operating system?" ^ I'm don't see how this is relevant. I'm running Debian 10 and all security related upgrades have been installed. "Have you entered a complete input field somewhere before going online for this or not at all it is Debian 10 here." ^ I don't know what you mean by 'a complete input field for this'. thanks
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

PS Since a browser gets correctly launched for http links but not for https links, it's likely that something is incorrectly set somewhere.

Is there a settings file I can delete to return the system to default setting?

I have tried reinstalling thunderbird but that has no effect. However, reinstalling thunderbird does not replace the profile. I don't want to wipe out the profile entirely, but is there a file in ~.thunderbird/* that might be relevant?

PS Since a browser gets correctly launched for http links but not for https links, it's likely that something is incorrectly set somewhere. Is there a settings file I can delete to return the system to default setting? I have tried reinstalling thunderbird but that has no effect. However, reinstalling thunderbird does not replace the profile. I don't want to wipe out the profile entirely, but is there a file in ~.thunderbird/* that might be relevant?
Ingabe lokhu kube usizo kuwena?
Isicaphuno
sfhowes
  • Top 10 Contributor
1545 izisombululo 7380 izimpendulo
Kuphostiwe

It might be faster and easier to create a new profile with Profile Manager, add an account, and see if the links open. If it works, you can transfer data from the old profile to the new one.

http://kb.mozillazine.org/Profile_manager#Linux

It might be faster and easier to create a new profile with Profile Manager, add an account, and see if the links open. If it works, you can transfer data from the old profile to the new one. http://kb.mozillazine.org/Profile_manager#Linux
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

That sounds like a feasible last resort. But before I go that route (which may take a lot of work - I don't know how much configuration is actually transferable), I'd still like to find a more direct fix.

Do you know what file stores the browser selection setting?

That sounds like a feasible last resort. But before I go that route (which may take a lot of work - I don't know how much configuration is actually transferable), I'd still like to find a more direct fix. Do you know what file stores the browser selection setting?
Ingabe lokhu kube usizo kuwena?
Isicaphuno
sfhowes
  • Top 10 Contributor
1545 izisombululo 7380 izimpendulo
Kuphostiwe

I don't think there is a setting in TB's prefs.js that refers to a browser; links are launched in whatever is defined as the system default browser.

Transferring data to a new profile

I don't think there is a setting in TB's prefs.js that refers to a browser; links are launched in whatever is defined as the system default browser. [http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Thunderbird Transferring data to a new profile]
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

There must be a setting somewhere. With

network.protocol-handler.warn-external.https = true

the user is supposed to prompted for a browser and that choice is supposed to be used from then on.

How thunderbird determine the default browser on linux? On linux, there are actually several different mechanisms for this.

There must be a setting somewhere. With network.protocol-handler.warn-external.https = true the user is supposed to prompted for a browser and that choice is supposed to be used from then on. How thunderbird determine the default browser on linux? On linux, there are actually several different mechanisms for this.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
sfhowes
  • Top 10 Contributor
1545 izisombululo 7380 izimpendulo
Kuphostiwe

There's a detailed description of the default browser for Linux here:

http://kb.mozillazine.org/Setting_Your_Default_Browser#Linux

There's a detailed description of the default browser for Linux here: http://kb.mozillazine.org/Setting_Your_Default_Browser#Linux
Ingabe lokhu kube usizo kuwena? 0
Isicaphuno

Umnikazi wombuzo

It appears that thunderbird is not using the default browser, at least not as specified in http://kb.mozillazine.org/Setting_Your_Default_Browser#Linux

My default browser is set, but is used for http only, not for https.

Somewhere, thunderbird is storing information that associates these protocols with browsers. It must be in one of the files in the profile directory (./thunderbird/*.default).

Does anyone know which file has this information?

thanks

It appears that thunderbird is ''not'' using the default browser, at least not as specified in [http://kb.mozillazine.org/Setting_Your_Default_Browser#Linux http://kb.mozillazine.org/Setting_Your_Default_Browser#Linux] My default browser is set, but is used for http only, ''not'' for https. Somewhere, thunderbird is storing information that associates these protocols with browsers. It must be in one of the files in the profile directory (./thunderbird/*.default). Does anyone know which file has this information? thanks
Ingabe lokhu kube usizo kuwena?
Isicaphuno
sfhowes
  • Top 10 Contributor
1545 izisombululo 7380 izimpendulo
Kuphostiwe

The same article states that the browser selection can be added to the user.js file:

http://kb.mozillazine.org/Setting_Your_Default_Browser#Setting_the_browser_that_opens_in_Thunderbird_-_Linux

If the user.js file doesn't already exist in the profile folder, create one with a text editor. Note that the article refers to mimeTypes.rdf, which has been replaced by handlers.json in recent versions of TB.

The same article states that the browser selection can be added to the user.js file: http://kb.mozillazine.org/Setting_Your_Default_Browser#Setting_the_browser_that_opens_in_Thunderbird_-_Linux If the user.js file doesn't already exist in the profile folder, create one with a text editor. Note that the article refers to mimeTypes.rdf, which has been replaced by handlers.json in recent versions of TB.
Ingabe lokhu kube usizo kuwena? 0
Isicaphuno

Umnikazi wombuzo

Creating user.js had no effect. My handlers.json did contain one invalid browser path. However, fixing it had no effect.

Is there any other file that specifies how https links are handled?

Creating user.js had no effect. My handlers.json did contain one invalid browser path. However, fixing it had no effect. Is there any other file that specifies how https links are handled?
Ingabe lokhu kube usizo kuwena?
Isicaphuno
Johnk860 3 izisombululo 21 izimpendulo
Kuphostiwe

I'm not going to get too deep into this because I don't know what questions to ask yet. That said, not all sites have HTTPS alternatives. I've found that EFF's HTTPS Everywhere add-on solved my issues automatically. My suggestion? Stop. Uninstall and reinstall Firefox (it'll pick up your old profile and put you back at ground zero. Then look for HTTPS Everywhere in add-ons and install it. Once in place, the app will look for secure access automatically, regardless of whether you use the "s" in your entry. The only unsecured sites that show up will be those that haven't implemented security as yet. I'd be interested in hearing back as to whether this works for you. I've had no trouble with FF (currently v69.0) and secure site access.

Good luck and best regards

I'm not going to get too deep into this because I don't know what questions to ask yet. That said, not all sites have HTTPS alternatives. I've found that EFF's HTTPS Everywhere add-on solved my issues automatically. My suggestion? Stop. Uninstall and reinstall Firefox (it'll pick up your old profile and put you back at ground zero. Then look for HTTPS Everywhere in add-ons and install it. Once in place, the app will look for secure access automatically, regardless of whether you use the "s" in your entry. The only unsecured sites that show up will be those that haven't implemented security as yet. I'd be interested in hearing back as to whether this works for you. I've had no trouble with FF (currently v69.0) and secure site access. Good luck and best regards
Ingabe lokhu kube usizo kuwena? 0
Isicaphuno

Umnikazi wombuzo

The problem I'm having is not related to Firefox. Thunderbird is failing to launch a browser for https urls, but is launching a browser for http urls.

The browser itself has no problems handling https urls and other apps (e.g. Zotero) have no problem launching Firefox for https and http.

thanks

The problem I'm having is not related to Firefox. Thunderbird is failing to launch a browser for https urls, but is launching a browser for http urls. The browser itself has no problems handling https urls and other apps (e.g. Zotero) have no problem launching Firefox for https and http. thanks
Ingabe lokhu kube usizo kuwena?
Isicaphuno
Johnk860 3 izisombululo 21 izimpendulo
Kuphostiwe

I'll offer this excerpt from Mozilla's troubleshooting guide. Note that it mentions a problem where http/https links operate incorrectly. Good luck:

https://support.mozilla.org/en-US/kb/hyperlinks-in-messages-not-working

Check that the operating system's default browser is specified

Every operating system allows the specification of a default browser that will be launched (for example) when a hyperlink in a message is clicked. Internet Explorer, Firefox, and other browsers check this setting by default when they start up and prompt you to set them as the default. Sometimes, however, this setting goes awry and your computer forgets which browser is the default. To fix this problem, you need to reset the default browser on your system. [The instructions for Firefox and other browsers is included at this point]

Check that no application is specified for the HTTP content type

In Thunderbird, you can specify an action that occurs when you click on various types of attachments and inline content. If the action for the HTTP / HTTPS content type is set incorrectly, this will prevent links from opening correctly.

If the operating system's default browser is specified correctly as described above, it is not necessary to specify an action for the HTTP / HTTPS content type. To check this setting, select Tools > Options and click on the Attachments panel. If HTTP and/or HTTPS are listed in the Content Type column, either delete the action or ensure the specified action is correct.

I'll offer this excerpt from Mozilla's troubleshooting guide. Note that it mentions a problem where http/https links operate incorrectly. Good luck: https://support.mozilla.org/en-US/kb/hyperlinks-in-messages-not-working Check that the operating system's default browser is specified Every operating system allows the specification of a default browser that will be launched (for example) when a hyperlink in a message is clicked. Internet Explorer, Firefox, and other browsers check this setting by default when they start up and prompt you to set them as the default. Sometimes, however, this setting goes awry and your computer forgets which browser is the default. To fix this problem, you need to reset the default browser on your system. [The instructions for Firefox and other browsers is included at this point] Check that no application is specified for the HTTP content type In Thunderbird, you can specify an action that occurs when you click on various types of attachments and inline content. If the action for the HTTP / HTTPS content type is set incorrectly, this will prevent links from opening correctly. If the operating system's default browser is specified correctly as described above, it is not necessary to specify an action for the HTTP / HTTPS content type. To check this setting, select Tools > Options and click on the Attachments panel. If HTTP and/or HTTPS are listed in the Content Type column, either delete the action or ensure the specified action is correct.

Okulungisiwe ngu Johnk860

Ingabe lokhu kube usizo kuwena? 0
Isicaphuno
Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.