X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Enabling studies didn't help!

Kuphostiwe

I have Windows Firefox 66.03.

Enabled Studies, and had "hotfix-reset-xpi-verification-timestamp-1548973" in "active" status. But I didn't have the second study! Nothing happened for few hours! So I tried to disable Studies and enable them again. After that the first Study became "completed" and no "active". The second is still absent. What should I do?? How to get the required Study and fix the problem? Can you help me please??

I have Windows Firefox 66.03. Enabled Studies, and had "hotfix-reset-xpi-verification-timestamp-1548973" in "active" status. But I didn't have the second study! Nothing happened for few hours! So I tried to disable Studies and enable them again. After that the first Study became "completed" and no "active". The second is still absent. What should I do?? How to get the required Study and fix the problem? Can you help me please??

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Shockwave Flash 32.0 r0

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

Eminye Imininingwane

Pj 42 izisombululo 869 izimpendulo
Kuphostiwe

Andrey1404 said

I have Windows Firefox 66.03. Enabled Studies, and had "hotfix-reset-xpi-verification-timestamp-1548973" in "active" status. But I didn't have the second study! Nothing happened for few hours! So I tried to disable Studies and enable them again. After that the first Study became "completed" and no "active". The second is still absent. What should I do?? How to get the required Study and fix the problem? Can you help me please??

It can take 6 hours or so to reach you. It doesn't happen real quick. 2 hours is still a 'short' wait.

~Pj

''Andrey1404 [[#question-1258257|said]]'' <blockquote> I have Windows Firefox 66.03. Enabled Studies, and had "hotfix-reset-xpi-verification-timestamp-1548973" in "active" status. But I didn't have the second study! Nothing happened for few hours! So I tried to disable Studies and enable them again. After that the first Study became "completed" and no "active". The second is still absent. What should I do?? How to get the required Study and fix the problem? Can you help me please?? </blockquote> It can take 6 hours or so to reach you. It doesn't happen real quick. 2 hours is still a 'short' wait. ~Pj

Impendulo Ewusizo

Thak you for your answer. But WTF?? Why is it so slow? And why I cannot purposely "participate" in necessary study??

Thak you for your answer. But WTF?? Why is it so slow? And why I cannot purposely "participate" in necessary study??

Umnikazi wombuzo

I saw messages frow a lot of user who wrote that they obtained the fix in few minutes...it looks strange in compare with my situation.

I saw messages frow a lot of user who wrote that they obtained the fix in few minutes...it looks strange in compare with my situation.
Jer 1 izisombululo 34 izimpendulo
Kuphostiwe

I changed the studies options, but so far nothing and been a long time, should I restart FF or reboot system?

I changed the studies options, but so far nothing and been a long time, should I restart FF or reboot system?
cor-el
  • Top 10 Contributor
  • Moderator
17519 izisombululo 158412 izimpendulo
Kuphostiwe

Impendulo Ewusizo

You can temporarily set app.normandy.run_interval_seconds to a lower value (21600 => 100) to see whether that gives the hotfix. Close and restart Firefox and check about:studies. You may have to refresh the about:studies page a few times. Do not forget to reset app.normandy.run_interval_seconds when about:studies shows that the hotfix has been applied.

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

You can temporarily set <b>app.normandy.run_interval_seconds</b> to a lower value (21600 => 100) to see whether that gives the hotfix. Close and restart Firefox and check <b>about:studies</b>. You may have to refresh the about:studies page a few times. Do not forget to reset <b>app.normandy.run_interval_seconds</b> when <b>about:studies</b> shows that the hotfix has been applied. You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue. *http://kb.mozillazine.org/about:config

Umnikazi wombuzo

I would also like to ask why you broke something that worked stably? You constantly change something, update and as a result break. Who and why made changes to the system of certification of additions? You shouldn't have touched anything if it worked.

I would also like to ask why you broke something that worked stably? You constantly change something, update and as a result break. Who and why made changes to the system of certification of additions? You shouldn't have touched anything if it worked.
Pj 42 izisombululo 869 izimpendulo
Kuphostiwe

Andrey1404 said

I would also like to ask why you broke something that worked stably? You constantly change something, update and as a result break. Who and why made changes to the system of certification of additions? You shouldn't have touched anything if it worked.

It was a Intermediate Certificate Date Expiration bug-a-boo. We're FF users like you here on this Forum. Mozilla normally isn't here.

See:

https://blog.mozilla.org/addons/2019/05/04/update-regarding-add-ons-in-firefox/


~Pj

''Andrey1404 [[#answer-1218945|said]]'' <blockquote> I would also like to ask why you broke something that worked stably? You constantly change something, update and as a result break. Who and why made changes to the system of certification of additions? You shouldn't have touched anything if it worked. </blockquote> It was a Intermediate Certificate Date Expiration bug-a-boo. We're FF users like you here on this Forum. Mozilla normally isn't here. See: https://blog.mozilla.org/addons/2019/05/04/update-regarding-add-ons-in-firefox/ ~Pj
Jer 1 izisombululo 34 izimpendulo
Kuphostiwe

It would be helpful if they had done some type of notify, like when they check if there is a new update also check to see if a system wide notify would be appropriate (like what is going on now). Then post the message instead of an update notice.

I did a restore from image and then restored an old profile to find out what was going on. Then I finely did a google search and got the news, could have saved me some time doing restores. But FF will never know or more than like care what I suggest.

It would be helpful if they had done some type of notify, like when they check if there is a new update also check to see if a system wide notify would be appropriate (like what is going on now). Then post the message instead of an update notice. I did a restore from image and then restored an old profile to find out what was going on. Then I finely did a google search and got the news, could have saved me some time doing restores. But FF will never know or more than like care what I suggest.
Jer 1 izisombululo 34 izimpendulo
Kuphostiwe

cor-el said

You can temporarily set app.normandy.run_interval_seconds to a lower value (21600 => 100) to see whether that gives the hotfix. Close and restart Firefox and check about:studies. You may have to refresh the about:studies page a few times. Do not forget to reset app.normandy.run_interval_seconds when about:studies shows that the hotfix has been applied. You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

Thanks, that worked I got the updates, now to see if the updates work. I also set interval back to 21600.

''cor-el [[#answer-1218944|said]]'' <blockquote> You can temporarily set <b>app.normandy.run_interval_seconds</b> to a lower value (21600 => 100) to see whether that gives the hotfix. Close and restart Firefox and check <b>about:studies</b>. You may have to refresh the about:studies page a few times. Do not forget to reset <b>app.normandy.run_interval_seconds</b> when <b>about:studies</b> shows that the hotfix has been applied. You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue. *http://kb.mozillazine.org/about:config </blockquote> Thanks, that worked I got the updates, now to see if the updates work. I also set interval back to 21600.
Jer 1 izisombululo 34 izimpendulo
Kuphostiwe

Should a person leave studies checked, I show 3 studies active and admit I don't understand them, I am guessing they are much like a beta test and if I uncheck they will go inactive?

Should a person leave studies checked, I show 3 studies active and admit I don't understand them, I am guessing they are much like a beta test and if I uncheck they will go inactive?
cor-el
  • Top 10 Contributor
  • Moderator
17519 izisombululo 158412 izimpendulo
Kuphostiwe

There are other fixes applied via a shield study (Normandy), so you may consider to leave it enabled. A recent hotfix was about blocking auto-play by default (media.autoplay.default = 1)

  • app.normandy.startupRolloutPrefs.media.autoplay.default = 1
There are other fixes applied via a shield study (Normandy), so you may consider to leave it enabled. A recent hotfix was about blocking auto-play by default (media.autoplay.default = 1) *app.normandy.startupRolloutPrefs.media.autoplay.default = 1

Umnikazi wombuzo

I guess the problem with the study setup is due to the fact that at the moment a huge number of users have enabled this feature. Since the studies are distributed randomly, with so many applicants it will be less likely and take longer.

I guess the problem with the study setup is due to the fact that at the moment a huge number of users have enabled this feature. Since the studies are distributed randomly, with so many applicants it will be less likely and take longer.
Jer 1 izisombululo 34 izimpendulo
Kuphostiwe

I had 2 pushed down that are active. I think the first is because I checked studies under tools/options......

dom.push.alwaysConnect to true.

app.update.lastUpdateTime.xpi-signature-verification to 1556945257.


So far addons are working.

I had 2 pushed down that are active. I think the first is because I checked studies under tools/options...... dom.push.alwaysConnect to true. app.update.lastUpdateTime.xpi-signature-verification to 1556945257. So far addons are working.

Okulungisiwe ngu Jer

Umnikazi wombuzo

Why can't you apply a simple solution as a temporary measure until a full patch is released? Disable certificate verification or roll back the date/certificate on your own servers? Just to make it work right now in some kind of temporary way.

Why can't you apply a simple solution as a temporary measure until a full patch is released? Disable certificate verification or roll back the date/certificate on your own servers? Just to make it work right now in some kind of temporary way.
philipp
  • Top 25 Contributor
  • Moderator
5315 izisombululo 23462 izimpendulo
Kuphostiwe

hi Andrey1404, the signature verification (and the expired certificate that's depending on) are happening locally in your firefox installation, so there is no shortcut or anything to be changed on the server side that could rectify this unfortunately. an update containing the fixed certificate will need to reach all affected installations...

at this point users who the hotfix hasn't reached yet are commonly on systems with security software thats mitm/intercepting secure web traffic (like avast/avg, kaspersky, bitdefender, eset) which is interfering with the proper application of the fix. a general new version 66.0.4 of firefox containing a fix is in the making and currently undergoing testing and will hopefully be released soon.

hi Andrey1404, the signature verification (and the expired certificate that's depending on) are happening locally in your firefox installation, so there is no shortcut or anything to be changed on the server side that could rectify this unfortunately. an update containing the fixed certificate will need to reach all affected installations... at this point users who the hotfix hasn't reached yet are commonly on systems with security software thats mitm/intercepting secure web traffic (like avast/avg, kaspersky, bitdefender, eset) which is interfering with the proper application of the fix. a general new version 66.0.4 of firefox containing a fix is in the making and currently undergoing testing and will hopefully be released soon.
NothingSyncs 1 izisombululo 23 izimpendulo
Kuphostiwe

I activated studies approx 16h ago ... and nothing happened 'till now! - So what's next?

I activated studies approx 16h ago ... and nothing happened 'till now! - So what's next?

Umnikazi wombuzo

philipp said

hi Andrey1404, the signature verification (and the expired certificate that's depending on) are happening locally in your firefox installation, so there is no shortcut or anything to be changed on the server side that could rectify this unfortunately. an update containing the fixed certificate will need to reach all affected installations... at this point users who the hotfix hasn't reached yet are commonly on systems with security software thats mitm/intercepting secure web traffic (like avast/avg, kaspersky, bitdefender, eset) which is interfering with the proper application of the fix. a general new version 66.0.4 of firefox containing a fix is in the making and currently undergoing testing and will hopefully be released soon.

Yes, I use Kaspersky Internet Security.

However, in order to break everything, you did not need a lot of time and a lot of efforts...you just decided to make changes to something that worked consistently and well...although you could just not touch anything

''philipp [[#answer-1219237|said]]'' <blockquote> hi Andrey1404, the signature verification (and the expired certificate that's depending on) are happening locally in your firefox installation, so there is no shortcut or anything to be changed on the server side that could rectify this unfortunately. an update containing the fixed certificate will need to reach all affected installations... at this point users who the hotfix hasn't reached yet are commonly on systems with security software thats mitm/intercepting secure web traffic (like avast/avg, kaspersky, bitdefender, eset) which is interfering with the proper application of the fix. a general new version 66.0.4 of firefox containing a fix is in the making and currently undergoing testing and will hopefully be released soon. </blockquote> Yes, I use Kaspersky Internet Security. However, in order to break everything, you did not need a lot of time and a lot of efforts...you just decided to make changes to something that worked consistently and well...although you could just not touch anything
McCoy
  • Top 10 Contributor
545 izisombululo 5139 izimpendulo
Kuphostiwe

Andrey1404 said

However, in order to break everything, you did not need a lot of time and a lot of efforts...you just decided to make changes to something that worked consistently and well...although you could just not touch anything

Hello Andreay1404,

It's very understandable that you're not "happy" with the situation, but :

This was caused by an unforeseen technical problem .......

''Andrey1404 [[#answer-1219239|said]]'' <blockquote> However, in order to break everything, you did not need a lot of time and a lot of efforts...you just decided to make changes to something that worked consistently and well...although you could just not touch anything </blockquote> Hello Andreay1404, It's very understandable that you're not "happy" with the situation, but : This was caused by an unforeseen technical problem .......
Pj 42 izisombululo 869 izimpendulo
Kuphostiwe

philipp said

The signature verification (and the expired certificate that's depending on) are happening locally in your Firefox installation, so there is no shortcut or anything to be changed on the server side that could rectify this, unfortunately. An update, containing the fixed certificate, will need to reach all affected installations.

At this point, users who the HotFix hasn't reached yet are commonly on systems with security software that's MITM/intercepting secure web traffic (like Avast/AVG, Kaspersky, BitDefender, ESET) which is interfering with the proper application of the fix.

A general new version 66.0.4 of Firefox containing a fix is in the making and currently undergoing testing and will hopefully be released soon.

Hmm. I have Avast Anti-Virus and 'The Fix' reached my browser ok.


~Pj

''philipp [[#answer-1219237|said]]'' <blockquote> The signature verification (and the expired certificate that's depending on) are happening locally in your Firefox installation, so there is no shortcut or anything to be changed on the server side that could rectify this, unfortunately. An update, containing the fixed certificate, will need to reach all affected installations. <Br><Br> At this point, '''users who the HotFix hasn't reached yet are commonly on systems with security software that's [https://en.wikipedia.org/wiki/Man-in-the-middle_attack MITM]/intercepting secure web traffic (like Avast/AVG, Kaspersky, BitDefender, ESET) which is interfering with the proper application of the fix.''' <Br><Br> A general '''''<u>new version 66.0.4 of Firefox containing a fix is in the making</u>''''' and currently undergoing testing and will hopefully be released soon. </blockquote> Hmm. I have Avast Anti-Virus and 'The Fix' reached my browser ok. ~Pj

Okulungisiwe ngu Pj

philipp
  • Top 25 Contributor
  • Moderator
5315 izisombululo 23462 izimpendulo
Kuphostiwe
a man-in-the-middled connection: https://en.wikipedia.org/wiki/Man-in-the-middle_attack