Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox websites displaying incorrect times

  • 13 uphendule
  • 1 inale nkinga
  • 16 views
  • Igcine ukuphendulwa ngu cor-el

more options

Hello. I just got a new computer, and when I installing Firefox, I went to gmail, and all the times were so early. like three or four hours earlier than the time I have on my computer. It happens on every website, not just on gmail. Can you help? Thanks

All Replies (13)

more options

How are you confirming the times other then through gmail for both Browser and computer?

more options

I look at my time on the bottom right, windows 10

more options

Also, thanks for the fast reply! I've been wanting to fix this since last week

more options

did you flip the privacy.resistFingerprinting preference? that will make firefox report your timezone as utc...

more options

How do I do that?

more options

philipp said

did you flip the privacy.resistFingerprinting preference? that will make firefox report your timezone as utc...

how do I do that?

more options

enter about:config into the firefox address bar (confirm the info message in case it shows up) & search for the preference named privacy.resistFingerprinting. double-click it and change its value to false.

more options

Hello SullyBully,

Would you please try this :

Type in the address bar about:config and press Enter (promise to be careful, if asked)

Type in the search bar privacy.resist

Look for the preference privacy.resistFingerprinting

and make sure that its value is set to false (= default)

If you had to change the value, then close and restart Firefox in order for the change to take effect.

Does that work  ?

more options

McCoy said

Hello SullyBully, Would you please try this : Type in the address bar about:config and press Enter (promise to be careful, if asked) Type in the search bar privacy.resist Look for the preference privacy.resistFingerprinting and make sure that its value is set to false (= default) If you had to change the value, then close and restart Firefox in order for the change to take effect. Does that work  ?

It was already false:

more options

That setting was already false

more options

Stab in the dark, but would you please take a look at the Chosen Solution in this thread :

https://support.mozilla.org/en-US/questions/1188735

Worth a try ......

more options
more options

You can check the date and time and time zone in the clock on your computer: (double) click the clock icon on the Windows Taskbar.

You can see the current time and time zone if you paste this code in the command line of the Web Console (Web Developer > Web Console; Ctrl+Shift+K). Paste each of these one at the time in the command line and press Enter to see the result.

  • "3-bar" menu button or Tools -> Web Developer
  • (new Date());
  • (new Date()).toString();
  • (new Date()).toLocaleString("en-US",{weekday:"long",day:"numeric",month:"long",year:"numeric",hour:"numeric",minute:"numeric",second:"numeric",hour12:false,timeZoneName:"long"});