X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

How do I disable all video entirely in Firefox?

Kuphostiwe

Hi there,

Firefox no longer stops autoplay videos, and many news sites use them. Since I do not really watch video on the web, I would like to disable all video playback on Firefox entirely. Is there a way to do this?

Thanks,

Brett

Hi there, Firefox no longer stops autoplay videos, and many news sites use them. Since I do not really watch video on the web, I would like to disable all video playback on Firefox entirely. Is there a way to do this? Thanks, Brett

Isisombululo esikhethiwe

Thanks, JScher2000. Although I'd like to disable all video, this seems to shut down the worst of the news sites for now. At some point, I'd like to know how to strip out video function entirely simply to avoid this entire portion of the web.

Funda le mpendulo ngokuhambisana nalesi sihloko 0

Eminye Imininingwane Yohlelo

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:63.0) Gecko/20100101 Firefox/63.0

Eminye Imininingwane

jscher2000
  • Top 10 Contributor
8632 izisombululo 70597 izimpendulo
Kuphostiwe

Impendulo Ewusizo

Users have reported problems with Yahoo News videos, but for most sites:

For Firefox 63

The old media.autoplay.enabled preference is obsolete. Mozilla is planning to add a media autoplay permissions section to the Options/Preferences page once the settings have completed full testing and interface design. For now, you can use what's available in this "work in progress."

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste autop and pause while the list is filtered

To set your preferred behavior:

Block autoplay by default

  • Double-click the media.autoplay.default preference and set it to 1
  • Double-click the media.autoplay.allow-muted preference to switch the value from true to false

=> Does that work for you?

Ask on a site-by-site basis (default for "Nightly")

  • Double-click the media.autoplay.default preference and set it to 2
  • Double-click the media.autoplay.ask-permission preference to switch the value from false to true
  • Double-click the media.autoplay.enabled.user-gestures-needed preference to switch the value from false to true

Allow autoplay by default (default for 63)

  • Double-click the media.autoplay.default preference and set it to 0 (or right-click > Reset)
Users have reported problems with Yahoo News videos, but for most sites: '''''For Firefox 63''''' The old '''media.autoplay.enabled''' preference is obsolete. Mozilla is planning to add a media autoplay permissions section to the Options/Preferences page once the settings have completed full testing and interface design. For now, you can use what's available in this "work in progress." (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste '''autop''' and pause while the list is filtered To set your preferred behavior: '''''Block autoplay by default''''' * Double-click the '''media.autoplay.default''' preference and set it to '''1''' * Double-click the '''media.autoplay.allow-muted''' preference to switch the value from true to false => ''Does that work for you?'' '''''Ask on a site-by-site basis''''' (default for "Nightly") * Double-click the '''media.autoplay.default''' preference and set it to '''2''' * Double-click the '''media.autoplay.ask-permission''' preference to switch the value from false to true * Double-click the '''media.autoplay.enabled.user-gestures-needed''' preference to switch the value from false to true '''''Allow autoplay by default''''' (default for 63) * Double-click the '''media.autoplay.default''' preference and set it to '''0''' (or right-click > Reset)
jscher2000
  • Top 10 Contributor
8632 izisombululo 70597 izimpendulo
Kuphostiwe

To block ALL video, you probably could change a bunch of media settings but I've never tested it. What about audio? Disabling MP4 playback could affect audio on some sites...

To block ALL video, you probably could change a bunch of media settings but I've never tested it. What about audio? Disabling MP4 playback could affect audio on some sites...

Isisombululo Esikhethiwe

Thanks, JScher2000. Although I'd like to disable all video, this seems to shut down the worst of the news sites for now. At some point, I'd like to know how to strip out video function entirely simply to avoid this entire portion of the web.

Thanks, JScher2000. Although I'd like to disable all video, this seems to shut down the worst of the news sites for now. At some point, I'd like to know how to strip out video function entirely simply to avoid this entire portion of the web.
cor-el
  • Top 10 Contributor
  • Moderator
17407 izisombululo 157253 izimpendulo
Kuphostiwe

Impendulo Ewusizo

See also: Disable HTML5 Autoplay https://addons.mozilla.org/firefox/addon/disable-autoplay/
seacleer 0 izisombululo 5 izimpendulo
Kuphostiwe

As noted above, the configurations suggested don't work on Yahoo videos, the most annoying of all!

So far, the Disable HTML5 Autoplay extension looks to be doing the trick, though!


Update: 2/26/19 - this extension does NOT disable autoplay on Yahoo videos!

As noted above, the configurations suggested don't work on Yahoo videos, the most annoying of all! So far, the Disable HTML5 Autoplay extension looks to be doing the trick, though! ---- Update: 2/26/19 - this extension does NOT disable autoplay on Yahoo videos!

Okulungisiwe ngu seacleer