X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

HTML5 on FF 62.0 Win 10

Kuphostiwe

I have 62.0 FF on a win 10 machine and youtube says "your browser does not support any of the video formats. Click here to visit our FAQ about HTML5 video. So is my system using 32 bit now the problem?

I have 62.0 FF on a win 10 machine and youtube says "your browser does not support any of the video formats. Click here to visit our FAQ about HTML5 video. So is my system using 32 bit now the problem?

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • DRM Netscape Network Object
  • DRM Store Netscape Plugin
  • VLC media player Web Plugin
  • Npdsplay dll
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 5.1; rv:51.0) Gecko/20100101 Firefox/51.0

Eminye Imininingwane

Shadow110 1072 izisombululo 14836 izimpendulo
Kuphostiwe

Hi, you are running a Version that is not Supported by XP/VISTA as of this week. The last compatible browser for XP is 52.9.0esr Save your stuff as backwards forwards is not compatible:

Pick your version 32/64 then your language and download : https://ftp.mozilla.org/pub/firefox/releases/52.9.0esr/

Yes your showing up as 32 bit here.

Please consider moving to Linux or BSD

Hi, you are running a Version that is not Supported by XP/VISTA as of this week. The last compatible browser for XP is 52.9.0esr Save your stuff as backwards forwards is not compatible: *https://support.mozilla.org/en-US/kb/export-firefox-bookmarks-to-backup-or-transfer *https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles Pick your version 32/64 then your language and download : https://ftp.mozilla.org/pub/firefox/releases/52.9.0esr/ Yes your showing up as 32 bit here. Please consider moving to Linux or BSD
jscher2000
  • Top 10 Contributor
8695 izisombululo 71074 izimpendulo
Kuphostiwe

Hmm, Windows 10, but your Firefox reported itself to be version 51 running on Windows XP.

Are you ready to upgrade to Quantum? If so:

Find the icon you use the start Firefox, and either:

  • Right-click a desktop shortcut, then click Properties
  • Right-click a Firefox icon pinned to the Taskbar then right-click Mozilla Firefox, then click Properties

You should clear all the boxes on the Compatibility tab for best results (giant screenshot below).

What this will change is Firefox's understanding of your OS, and that should trigger it to use Media Foundation for MP4 decoding.

Any difference the next time you start Firefox?

See also: Fix video and audio playback problems on Firefox for Windows

Hmm, Windows 10, but your Firefox reported itself to be version 51 running on Windows XP. Are you ready to upgrade to Quantum? If so: Find the icon you use the start Firefox, and either: * Right-click a desktop shortcut, then click Properties * Right-click a Firefox icon pinned to the Taskbar then right-click Mozilla Firefox, then click Properties You should clear all the boxes on the Compatibility tab for best results (giant screenshot below). <img src="https://prod-cdn.sumo.mozilla.net/uploads/images/2018-07-25-13-24-46-baad8f.png"> What this will change is Firefox's understanding of your OS, and that should trigger it to use Media Foundation for MP4 decoding. Any difference the next time you start Firefox? See also: [[Fix video and audio playback problems on Firefox for Windows]]
Shadow110 1072 izisombululo 14836 izimpendulo
Kuphostiwe

So you have XP showing as your browser OS here, something is wrong then.

So you have XP showing as your browser OS here, something is wrong then.
jscher2000
  • Top 10 Contributor
8695 izisombululo 71074 izimpendulo
Kuphostiwe

Oh, this might also be relevant: How to reset the default user agent on Firefox.

Oh, this might also be relevant: [[How to reset the default user agent on Firefox]].

Umnikazi wombuzo

Email on XP computer. FF on Win 10 computer Seperate computers. Don't want email on the win 10.

Email on XP computer. FF on Win 10 computer Seperate computers. Don't want email on the win 10.

Okulungisiwe ngu DavidSorge

James
  • Moderator
1596 izisombululo 11250 izimpendulo
Kuphostiwe

Another thing that can change the useragent is privacy.resistFingerprinting in about:config however that makes the UA look like 60 ESR and not 51.0 on WinXP.

Pkshadow said

Hi, you are running a Version that is not Supported by XP/VISTA

Pkshadow said

So you have XP showing as your browser OS here, something is wrong then.

You missed the "62.0 on Win 10" mention in both subject and post. Also with WinXP/Vista you can only run the 32-bit Firefox even if OS is 64-bit.

Another thing that can change the useragent is privacy.resistFingerprinting in about:config however that makes the UA look like 60 ESR and not 51.0 on WinXP. ''Pkshadow [[#answer-1151229|said]]'' <blockquote> Hi, you are running a Version that is not Supported by XP/VISTA</blockquote> ''Pkshadow [[#answer-1151232|said]]'' <blockquote> So you have XP showing as your browser OS here, something is wrong then. </blockquote> You missed the "62.0 on Win 10" mention in both subject and post. Also with WinXP/Vista you can only run the 32-bit Firefox even if OS is 64-bit.

Okulungisiwe ngu James

jscher2000
  • Top 10 Contributor
8695 izisombululo 71074 izimpendulo
Kuphostiwe

Okay, thanks for clarifying the OS/Version.

Could you check your settings here:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste webm and pause while the list is filtered

(3) If the media.webm.enabled preference is bolded and "modified" or "user set" to false, double-click it to restore the default value of true

(4) In the search box above the list, type or paste wmf and pause while the list is filtered

(5) If the media.wmf.enabled preference is bolded and "modified" or "user set" to false, double-click it to restore the default value of true

(6) In the search box above the list, type or paste mp4 and pause while the list is filtered

(7) If the media.mediasource.mp4.enabled preference is bolded and "modified" or "user set" to false, double-click it to restore the default value of true

(8) If the media.mp4.enabled preference is bolded and "modified" or "user set" to false, double-click it to restore the default value of true

(9) In the search box above the list, type or paste mediaso and pause while the list is filtered

(10) If the media.mediasource.enabled preference is bolded and "modified" or "user set" to false, double-click it to restore the default value of true

Then check the following page:

https://www.youtube.com/html5

What's the pattern? For example, if the two H.264 boxes are red, that often indicates a Media Foundation problem. See: Fix video and audio playback problems on Firefox for Windows.

Okay, thanks for clarifying the OS/Version. Could you check your settings here: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste '''webm''' and pause while the list is filtered (3) If the '''media.webm.enabled''' preference is bolded and "modified" or "user set" to false, double-click it to restore the default value of true (4) In the search box above the list, type or paste '''wmf''' and pause while the list is filtered (5) If the '''media.wmf.enabled''' preference is bolded and "modified" or "user set" to false, double-click it to restore the default value of true (6) In the search box above the list, type or paste '''mp4''' and pause while the list is filtered (7) If the '''media.mediasource.mp4.enabled''' preference is bolded and "modified" or "user set" to false, double-click it to restore the default value of true (8) If the '''media.mp4.enabled''' preference is bolded and "modified" or "user set" to false, double-click it to restore the default value of true (9) In the search box above the list, type or paste '''mediaso''' and pause while the list is filtered (10) If the '''media.mediasource.enabled''' preference is bolded and "modified" or "user set" to false, double-click it to restore the default value of true Then check the following page: https://www.youtube.com/html5 What's the pattern? For example, if the two '''H.264''' boxes are red, that often indicates a Media Foundation problem. See: [[Fix video and audio playback problems on Firefox for Windows]].

Umnikazi wombuzo

Letters in upper case For ease of reading.

(2) In the search box above the list, type or paste webm

(3) If the media.webm.enabled preference is bolded and "modified" or "user set" to false, double-click it to restore the default value of true TRUE

(4) In the search box above the list, type or paste wmf

(5) If the media.wmf.enabled preference is bolded and "modified" or "user set" to false, double-click it to restore the default value of true TRUE

(6) In the search box above the list, type or paste mp4

(7) If the media.mediasource.mp4.enabled preference is bolded and "modified" or "user set" to false, double-click it to restore the default value of true TRUE

(8) If the media.mp4.enabled preference is bolded and "modified" or "user set" to false, double-click it to restore the default value of true TRUE

(9) In the search box above the list, type or paste mediaso

(10) If the media.mediasource.enabled preference is bolded and "modified" or "user set" to false, double-click it to restore the default value of true TRUE

They were all set to true.

https://www.youtube.com/html5

What's the pattern? For example, if the two H.264 boxes are red, that often indicates a Media Foundation problem. See: Fix video and audio playback problems on Firefox for Windows. All the boxes are BLUE

Letters in upper case For ease of reading. (2) In the search box above the list, type or paste webm (3) If the media.webm.enabled preference is bolded and "modified" or "user set" to false, double-click it to restore the default value of true '''TRUE''' (4) In the search box above the list, type or paste wmf (5) If the media.wmf.enabled preference is bolded and "modified" or "user set" to false, double-click it to restore the default value of true '''TRUE''' (6) In the search box above the list, type or paste mp4 (7) If the media.mediasource.mp4.enabled preference is bolded and "modified" or "user set" to false, double-click it to restore the default value of true '''TRUE''' (8) If the media.mp4.enabled preference is bolded and "modified" or "user set" to false, double-click it to restore the default value of true '''TRUE''' (9) In the search box above the list, type or paste mediaso (10) If the media.mediasource.enabled preference is bolded and "modified" or "user set" to false, double-click it to restore the default value of true '''TRUE''' They were all set to true. https://www.youtube.com/html5 What's the pattern? For example, if the two H.264 boxes are red, that often indicates a Media Foundation problem. See: Fix video and audio playback problems on Firefox for Windows. All the boxes are '''BLUE'''
jscher2000
  • Top 10 Contributor
8695 izisombululo 71074 izimpendulo
Kuphostiwe

Hmm, everything check out. That's good. Next theory: do you use any video-related extensions that may be mucking with the page? Definitely if you have any of the old "YouTube-Flash" extensions, you can remove those because YouTube no longer uses Flash. Any interceptors (recorders, downloaders) that might be interfering?

You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions.

Then cast a critical eye over the list on the right side. Any extensions Firefox installs for built-in features are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Anything video-related, or that you do not remember installing or why? If in doubt, disable (or remove).

Any improvement?

Hmm, everything check out. That's good. Next theory: do you use any video-related extensions that may be mucking with the page? Definitely if you have any of the old "YouTube-Flash" extensions, you can remove those because YouTube no longer uses Flash. Any interceptors (recorders, downloaders) that might be interfering? You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either: * Ctrl+Shift+a (Mac: Command+Shift+a) * "3-bar" menu button (or Tools menu) > Add-ons * type or paste '''about:addons''' in the address bar and press Enter/Return In the left column of the Add-ons page, click Extensions. Then cast a critical eye over the list on the right side. Any extensions Firefox installs for built-in features are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Anything video-related, or that you do not remember installing or why? If in doubt, disable (or remove). Any improvement?