X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Instructions for turning off cache are wrong. Do not have network.http.use-cache

Kuphostiwe

I am trying to turn off my cache settings.

The instructiuons given tell us to set 'network.http.use-cache in about:config.

I have tried that, and that Preference name no longer exists.

How is this achieved?

I need this for Automation Testing. Currently, cached data casuses tests to fail.

I am trying to turn off my cache settings. The instructiuons given tell us to set 'network.http.use-cache in about:config. I have tried that, and that Preference name no longer exists. How is this achieved? I need this for Automation Testing. Currently, cached data casuses tests to fail.

Isisombululo esikhethiwe

Would you do this please :

Type in the address bar about:config and press Enter (promise to be careful, if asked)

Type in the search bar : browser.cache

And look for the preferences :

browser.cache.disk.enable and browser.cache.memory.enable

Change their values to false

Then close and restart Firefox.

Note : It's best not to set "browser.cache.memory.enable" to "false" when you use Private Browsing mode, as this might cause performance issues.

Funda le mpendulo ngokuhambisana nalesi sihloko 0

Eminye Imininingwane Yohlelo

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0

Eminye Imininingwane

McCoy
  • Top 10 Contributor
519 izisombululo 4868 izimpendulo
Kuphostiwe

Isisombululo Esikhethiwe

Would you do this please :

Type in the address bar about:config and press Enter (promise to be careful, if asked)

Type in the search bar : browser.cache

And look for the preferences :

browser.cache.disk.enable and browser.cache.memory.enable

Change their values to false

Then close and restart Firefox.

Note : It's best not to set "browser.cache.memory.enable" to "false" when you use Private Browsing mode, as this might cause performance issues.

Would you do this please : Type in the address bar '''about:config''' and press Enter (promise to be careful, if asked) Type in the search bar : '''browser.cache''' And look for the preferences : '''browser.cache.disk.enable''' and '''browser.cache.memory.enable''' Change their values to '''false''' Then close and restart Firefox. Note : It's best not to set "browser.cache.memory.enable" to "false" when you use Private Browsing mode, as this might cause performance issues.
the-edmeister
  • Top 25 Contributor
  • Moderator
5395 izisombululo 40083 izimpendulo
Kuphostiwe

network.http.use-cache is a pref in older versions of Firefox. So that article is incorrect or not written for the Quantum version of Firefox 57+.

'''network.http.use-cache''' is a pref in older versions of Firefox. So that article is incorrect or not written for the Quantum version of Firefox 57+.
cor-el
  • Top 10 Contributor
  • Moderator
17409 izisombululo 157269 izimpendulo
Kuphostiwe

You should leave the memory cache enabled. Firefox needs some caches in order to work properly. If you want to disable the disk cache then you can consider to use Private Browsing mode. Otherwise you can set the disk cache to a low setting like 50 MB via browser.cache.disk.capacity. You can check the current cache usage on the about:cache page.

The network.http.use-cache pref was removed in Firefox 43 because disabling the cache broke things in Firefox.

You should leave the memory cache enabled. Firefox needs some caches in order to work properly. If you want to disable the disk cache then you can consider to use Private Browsing mode. Otherwise you can set the disk cache to a low setting like 50 MB via browser.cache.disk.capacity. You can check the current cache usage on the about:cache page. The network.http.use-cache pref was removed in Firefox 43 because disabling the cache broke things in Firefox.

Okulungisiwe ngu cor-el

Charles8 1 izisombululo 10 izimpendulo
Kuphostiwe

cor-el said

You should leave the memory cache enabled. Firefox needs some caches in order to work properly. If you want to disable the disk cache then you can consider to use Private Browsing mode. Otherwise you can set the disk cache to a low setting like 50 MB via browser.cache.disk.capacity. You can check the current cache usage on the about:cache page. The network.http.use-cache pref was removed in Firefox 43 because disabling the cache broke things in Firefox.

This is a rubbish suggestion, js etc is still cached in private browsing!!

''cor-el [[#answer-1149636|said]]'' <blockquote> You should leave the memory cache enabled. Firefox needs some caches in order to work properly. If you want to disable the disk cache then you can consider to use Private Browsing mode. Otherwise you can set the disk cache to a low setting like 50 MB via browser.cache.disk.capacity. You can check the current cache usage on the about:cache page. The network.http.use-cache pref was removed in Firefox 43 because disabling the cache broke things in Firefox. </blockquote> This is a rubbish suggestion, js etc is still cached in private browsing!!