Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Suggestions can't be disabled in search bar?

  • 8 uphendule
  • 1 inale nkinga
  • 10 views
  • Igcine ukuphendulwa ngu Blacknest

more options

I have disabled search suggestions in the Options->Search page. If I use the address bar for searching, suggestions are disabled. However, if I have the “Add search bar in tool bar” option selected, and type a letter in the search bar, I still get items from my search history displayed in a drop-down box.

In the attached screen shot you can see the relevant page from about:config and the drop-down box.

Is there a way to disable these suggestions?

(Firefox 59.0.3 / Windows 7 pro)

Ama-screenshot ananyekiwe

All Replies (8)

more options

Yes, disable remember history.

more options

Hi Pkshadow - OK, disabling remember history would be a blunt force approach, but that's what my mother would have called 'throwing the baby out with the bathwater'!

I don't want to disable history, because I still want access to the history when I go to the History tab. I just don't want to see history items as suggestions in a drop-down box whenever I type in the search bar.

It's quite simple really - the address bar behaves correctly when used as a search bar - there's no drop-down box when suggestions are disabled, but the history is still there under the History tab. The search bar doesn't behave in this way, which is probably an oversight, not a feature.

Perhaps I should be reporting this as a bug rather than looking for help on a forum!

more options

Hello Blacknest,

Would you try this please :

3-bar menu (or 'Tools') => Options => Privacy & Security

Under ' Address Bar' => 'When using the address bar, suggest' :

uncheck 'Browsing history'

That should do the trick .....

more options

Hi McCoy,

Actually, it doesn't do the trick! If you look at the about:config screenshot with the original post, you'll see that the two items starting 'browser.urlbar.suggest.history...' are marked as 'false'.

This shows that I had already done what you are suggesting before I made the original post. Indeed, that is why I included the screenshot - so that nobody need waste their time making that suggestion.

more options

Blacknest said

Hi McCoy, Actually, it doesn't do the trick! If you look at the about:config screenshot with the original post, you'll see that the two items starting 'browser.urlbar.suggest.history...' are marked as 'false'. This shows that I had already done what you are suggesting before I made the original post. Indeed, that is why I included the screenshot - so that nobody need waste their time making that suggestion.

I missed that - I apologize ......

more options

Blacknest said

If you look at the about:config screenshot with the original post, you'll see that the two items starting 'browser.urlbar.suggest.history...' are marked as 'false'.

Just to make sure : After you changed the values of those two prefs : did you then close and restart Firefox, in order for the change(s) to take effect  ?

more options

'Giving it one more shot :

Would you please take a look at this article, and scroll down to the section :

Turning off the web search in the address bar

more options

Hi McCoy - yes, I closed Firefox and restarted it many times... actually, I spent a couple of hours late last night searching the web and reading any articles I could find, before I posted my question on this site.

As far as about:config settings are concerned, I didn't actually change any of them directly - I selected options in the Options->Search and Options->Privacy&Security pages (which work immediately), and then checked on about:config to see what changes appeared in the config list.

I had seen the article you mentioned, and I read it again just now, but I couldn't find anything new that I haven't already tried. It's worth mentioning that this is an issue with search history rather than Autocompletion or Domain Guessing , since what appears in the drop-down box is a list of things I have typed into the search box (even single letters), rather than successful searches or domain names.

Anyway, many thanks for your persistence! This isn't a big problem - just an annoyance that I couldn't get to the bottom of.

I have to say that my gut feeling about this (based on 35+ years dealing with software development teams) is that it looks like an unintentional omission. The give-away would be that there are no entries listed in the config table for browser.searchbar - there's one for browser.search and lots for browser.urlbar - which suggests that the search bar should follow the preferences of the address bar, which it does mostly - though not completely.