Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

How do I disable the sidebar showing thumbnails in the pdf viewer?

  • 7 uphendule
  • 4 zinale nkinga
  • 1102 views
  • Igcine ukuphendulwa ngu teastin

more options

When I open a pdf file with the firefox viewer, there are page thumbnails in a sidebar on the left of the document. The sidebar overlays the document such that I have to close the sidebar in order to view the document. This had not been an issue for me previously, but I don't think I changed a setting, and can't find a solution that doesn't involve me doing something each time I open a file.

When I enlarge the window, the toolbar doesn't overlay the document, so if it is possible to change the default size of the window, that would work also.

I'm using firefox for mac in case that matters.

Thanks!

Isisombululo esikhethiwe

Firefox now will open the sidebar under the same circumstances as Adobe Acrobat/Reader (when specified by the PDF itself). For example: Firefox Search Bar Show Engine Names (Firefox 43)_20171004.pdf should open the Bookmarks list.

To suppress that behavior, could you try this:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste pdfjs and pause while the list is filtered

(3) Double-click the pdfjs.disablePageMode preference to switch the value from false to true

Now instead of the panel opening automatically, if the PDF specifies that it should be displayed a green dot will appear on the sidebar button. At least, that's what happens in my 15-second test in Firefox 56 using that above-linked PDF.

Let me know what happens for you.

Source: This preference was mentioned (more or less) here: https://github.com/mozilla/pdf.js/issues/8972#issuecomment-333058993

Edit: Fixed link to example PDF.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (7)

more options

I think I see the button you mean (attached screenshot).

Could you try this:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste pdfjs and pause while the list is filtered

(3) If the pdfjs.sidebarViewOnLoad preference is bolded and "modified" or "user set" to to some value other than zero, right-click it (on a one-button mouse Ctrl+click it) and choose Reset. Or you can double-click it and change the value to 0 (that's a zero).

Note: The values mean:

  • 0 = Do not display sidebar
  • 1 = Show thumbnails
  • 2 = Show outline
  • 3 = Show attachments

Does that work?

Also, does the change persist after you quit Firefox and start it up again?

more options

Thanks! Unfortunately, Step #3 above is already set to default. I did restart firefox to see if it would help, but the sidebar still appears. Happy to try other ideas.

more options

Maybe toggle pdfjs.showPreviousViewOnLoad to false.

more options

Unfortunately that didn't work either. Thanks, though.

more options

Did you close and restart Firefox after modifying these prefs?

  • Mac: Firefox -> Quit Firefox

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
more options

Isisombululo Esikhethiwe

Firefox now will open the sidebar under the same circumstances as Adobe Acrobat/Reader (when specified by the PDF itself). For example: Firefox Search Bar Show Engine Names (Firefox 43)_20171004.pdf should open the Bookmarks list.

To suppress that behavior, could you try this:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste pdfjs and pause while the list is filtered

(3) Double-click the pdfjs.disablePageMode preference to switch the value from false to true

Now instead of the panel opening automatically, if the PDF specifies that it should be displayed a green dot will appear on the sidebar button. At least, that's what happens in my 15-second test in Firefox 56 using that above-linked PDF.

Let me know what happens for you.

Source: This preference was mentioned (more or less) here: https://github.com/mozilla/pdf.js/issues/8972#issuecomment-333058993

Edit: Fixed link to example PDF.

Okulungisiwe ngu jscher2000

more options

Jackpot. Thanks, jscher2000!