X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

FF54 causes BEX error when closed

Kuphostiwe

Since the update to 54, Firefox causes a BEX error each time I close it.

The browser window closes correctly but then a pop up shows up: "Firefox stopped working" (in Dutch)

Probleemhandtekening:

 Gebeurtenisnaam van probleem:	BEX
 Naam van de toepassing:	firefox.exe
 Versie van toepassing:	54.0.0.6368
 Tijdstempel van toepassing:	59399e7c
 Naam van foutmodule:	StackHash_0a9e
 Versie van foutmodule:	0.0.0.0
 Tijdstempel van foutmodule:	00000000
 Uitzonderingsmarge:	000000b4
 Uitzonderingscode:	c0000005
 Uitzonderingsgegevens:	00000008
 Versie van besturingssysteem:	6.1.7601.2.1.0.256.48
 Landinstelling-id:	1043
 Aanvullende informatie 1:	0a9e
 Aanvullende informatie 2:	0a9e372d3b4ad19135b953a78882e789
 Aanvullende informatie 3:	0a9e
 Aanvullende informatie 4:	0a9e372d3b4ad19135b953a78882e789

Please advice. Thank you

Since the update to 54, Firefox causes a BEX error each time I close it. The browser window closes correctly but then a pop up shows up: "Firefox stopped working" (in Dutch) Probleemhandtekening: Gebeurtenisnaam van probleem: BEX Naam van de toepassing: firefox.exe Versie van toepassing: 54.0.0.6368 Tijdstempel van toepassing: 59399e7c Naam van foutmodule: StackHash_0a9e Versie van foutmodule: 0.0.0.0 Tijdstempel van foutmodule: 00000000 Uitzonderingsmarge: 000000b4 Uitzonderingscode: c0000005 Uitzonderingsgegevens: 00000008 Versie van besturingssysteem: 6.1.7601.2.1.0.256.48 Landinstelling-id: 1043 Aanvullende informatie 1: 0a9e Aanvullende informatie 2: 0a9e372d3b4ad19135b953a78882e789 Aanvullende informatie 3: 0a9e Aanvullende informatie 4: 0a9e372d3b4ad19135b953a78882e789 Please advice. Thank you

Okulungisiwe ngu wwwaste

Eminye Imininingwane Yohlelo

Fakela amapulagi

uBlock Origin Https Everywhere NoSquint Plus Duplicate in Tab

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:54.0) Gecko/20100101 Firefox/54.0

Eminye Imininingwane

jscher2000
  • Top 10 Contributor
8758 izisombululo 71663 izimpendulo
Kuphostiwe

Hmm, usually a BEX error (buffer overflow) is associated with malware. However, in another thread, a user mentioned that if Spybot Search & Destroy is running, Firefox 54 crashes on exit. So possibly it could be related to some security software.

If you use SSD, can you turn off any features that might modify Firefox in use?

Hmm, usually a BEX error (buffer overflow) is associated with malware. However, in another thread, a user mentioned that if Spybot Search & Destroy is running, Firefox 54 crashes on exit. So possibly it could be related to some security software. If you use SSD, can you turn off any features that might modify Firefox in use?

Umnikazi wombuzo

No malware, SpyBot not running in the bakcground, no SSD. Thanks anyway

No malware, SpyBot not running in the bakcground, no SSD. Thanks anyway
jscher2000
  • Top 10 Contributor
8758 izisombululo 71663 izimpendulo
Kuphostiwe

Do you exit Firefox using the menu or using the "X" button? If you don't normally used the menu, could you try it? Either:

  • "3-bar" menu button > power symbol
  • (menu bar) File > Exit

If that makes no difference, could you test whether the same problem occurs exiting from Firefox's Safe Mode?

In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement? (More info: Troubleshoot Firefox issues using Safe Mode)

Do you exit Firefox using the menu or using the "X" button? If you don't normally used the menu, could you try it? Either: * "3-bar" menu button > power symbol * (menu bar) File > Exit ---- If that makes no difference, could you test whether the same problem occurs exiting from Firefox's Safe Mode? In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem. ''If Firefox is not running:'' Hold down the Shift key when starting Firefox. ''If Firefox is running:'' You can restart Firefox in Safe Mode using either: * "3-bar" menu button > "?" button > Restart with Add-ons Disabled * Help menu > Restart with Add-ons Disabled and OK the restart. ''Both scenarios:'' A small dialog should appear. Click "Start in Safe Mode" (''not'' Refresh). Any improvement? (More info: [[Troubleshoot Firefox issues using Safe Mode]])

Umnikazi wombuzo

Thanks, I know how to Safe Mode. Same error.

Mind you: this problem MAY have the same root cause(s) as my previous one: Firefox 53 the cause of Windows freezing?

It is not clear if all this is really caused by FF itself, or by it not being handled well by Windows (7 x64 SP1).

Thanks, I know how to Safe Mode. Same error. Mind you: this problem '''MAY''' have the same root cause(s) as my previous one: [https://support.mozilla.org/en-US/questions/1158873|Is Firefox 53 the cause of Windows freezing?] It is not clear if all this is really caused by FF itself, or by it not being handled well by Windows (7 x64 SP1).

Okulungisiwe ngu wwwaste

Umnikazi wombuzo

jscher2000 said

Do you exit Firefox using the menu or using the "X" button? If you don't normally used the menu, could you try it?

Sorry, forgot that one. Tried it: same sad story.


0.51 AM Local: bed time. Will pick up tomorrow. Thanks for any input.

''jscher2000 [[#answer-977977|said]]'' <blockquote> Do you exit Firefox using the menu or using the "X" button? If you don't normally used the menu, could you try it? </blockquote> Sorry, forgot that one. Tried it: same sad story. ''0.51 AM Local: bed time. Will pick up tomorrow. Thanks for any input.''

Okulungisiwe ngu wwwaste

jscher2000
  • Top 10 Contributor
8758 izisombululo 71663 izimpendulo
Kuphostiwe

Oh, your other thread already has over 40 replies, so it probably makes sense to add this issue there.

Oh, your other thread already has over 40 replies, so it probably makes sense to add this issue there.
cor-el
  • Top 10 Contributor
  • Moderator
17526 izisombululo 158473 izimpendulo
Kuphostiwe

Do a malware check with several malware scanning programs on the Windows computer.

Please scan with all programs because each program detects different malware. All these programs have free versions.

Make sure you update each program to get the latest version of their databases before doing a scan.

You can also do a check for a rootkit infection with TDSSKiller.

See also:

Do a malware check with several malware scanning programs on the Windows computer. *https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-caused-malware Please scan with all programs because each program detects different malware. All these programs have free versions. Make sure you update each program to get the latest version of their databases before doing a scan. *Malwarebytes' Anti-Malware:<br>http://www.malwarebytes.org/mbam.php *AdwCleaner:<br>http://www.bleepingcomputer.com/download/adwcleaner/<br>http://www.softpedia.com/get/Antivirus/Removal-Tools/AdwCleaner.shtml *SuperAntispyware:<br>http://www.superantispyware.com/ *Microsoft Safety Scanner:<br>http://www.microsoft.com/security/scanner/en-us/default.aspx *Windows Defender:<br>http://windows.microsoft.com/en-us/windows/using-defender *Spybot Search & Destroy:<br>http://www.safer-networking.org/en/index.html *Kasperky Free Security Scan:<br>http://www.kaspersky.com/security-scan You can also do a check for a rootkit infection with TDSSKiller. *Anti-rootkit utility TDSSKiller:<br>http://support.kaspersky.com/5350?el=88446 See also: *"Spyware on Windows": http://kb.mozillazine.org/Popups_not_blocked

Umnikazi wombuzo

jscher2000 [[#answer-978053|said]

Oh, your other thread already has over 40 replies, so it probably makes sense to add this issue there.

I already did a few posts back, but here it is again: https://support.mozilla.org/questions/1158873

''jscher2000 [[#answer-978053|said]'' <blockquote> Oh, your other thread already has over 40 replies, so it probably makes sense to add this issue there. </blockquote> I already did a few posts back, but here it is again: [https://support.mozilla.org/questions/1158873]

Okulungisiwe ngu wwwaste

Umnikazi wombuzo

cor-el said

Do a malware check with several malware scanning programs on the Windows computer.

1. Because of WannaCry and other nsa-like crap, I recently deep scanned my well protected & up-to-date system with most of the tools you describe, but nothing found. I didn't know Microsoft Safety Scanner, but ran it and nothing found either. 2. The issue does not show any malware/virus-like behaviour. 3. The problem first occurred after updating to FF54.

''cor-el [[#answer-978075|said]]'' <blockquote> Do a malware check with several malware scanning programs on the Windows computer. </blockquote> 1. Because of WannaCry and other nsa-like crap, I recently deep scanned my well protected & up-to-date system with most of the tools you describe, but nothing found. I didn't know Microsoft Safety Scanner, but ran it and nothing found either. 2. The issue does not show any malware/virus-like behaviour. 3. The problem first occurred after updating to FF54.

Okulungisiwe ngu wwwaste

Umnikazi wombuzo

I reverted back to FF53.0.3 and guess what? No more BEX error!

As I tried to make clear: this has nothing to do with malware/viruses. FF54's new multiple processes ‘Electrolysis ’ (or E10s) is probably the cause.

I reverted back to FF53.0.3 and guess what? No more BEX error! As I tried to make clear: this has nothing to do with malware/viruses. FF54's new multiple processes ‘Electrolysis ’ (or E10s) is probably the cause.

Okulungisiwe ngu wwwaste

John99 971 izisombululo 13138 izimpendulo
Kuphostiwe

If you try in Firefox's safe mode AND in Windows 7 safe mode at the same time do you still get the same issue ?

Also is this issue associated with any specific website ?

Please try this:

  1. For instance if you open Firefox with only its default homepage open, and then close Firefox without doing any browsing and use the Menu button {3 bar icon) ==> Quit {Standby icon) do you still get the BEX crash ?
  2. If that is problem free then what happens if you browse but only on this support forum before closing Firefox ?
  3. I don't think we ever tried a clean reinstall of Firefox. That is not something that is guaranteed to help but it certainly should be tried. It involves removing the Firefox program folder (NOT the Firefox Profile folder & files)

Clean Reinstall

Certain Firefox problems can be solved by performing a Clean reinstall. This means you remove your Firefox program files and then reinstall Firefox. This process does not remove your Firefox profile data (such as bookmarks and passwords), since that information is stored in a different location.

To do a clean reinstall of Firefox, please follow these steps: Note: You might want to print these steps or view them in another browser.

  1. Download the latest Desktop version of Firefox from mozilla.org (or choose the download for your operating system and language from this page) and save the setup file to your computer.
  2. After the download finishes, close all Firefox windows (or open the Firefox menu New Fx Menu and click the close button Close 29 ).
  3. Delete the Firefox installation folder, which is located in one of these locations, by default:
    • Windows:
      • C:\Program Files\Mozilla Firefox
      • C:\Program Files (x86)\Mozilla Firefox
    • Mac: Delete Firefox from the Applications folder.
    • Linux: If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it - see Install Firefox on Linux. If you downloaded and installed the binary package from the Firefox download page, simply remove the folder firefox in your home directory.
  4. Now, go ahead and reinstall Firefox:
    1. Double-click the downloaded installation file and go through the steps of the installation wizard.
    2. Once the wizard is finished, choose to directly open Firefox after clicking the Finish button.

More information about reinstalling Firefox can be found here.

WARNING: Do not use a third party uninstaller as part of this process. Doing so could permanently delete your Firefox profile data, including but not limited to, extensions, cache, cookies, bookmarks, personal settings and saved passwords. These cannot be easily recovered unless they have been backed up to an external device! See Back up and restore information in Firefox profiles.

If you try in Firefox's safe mode AND in Windows 7 safe mode at the same time do you still get the same issue ? Also is this issue associated with any specific website ? Please try this: # For instance if you open Firefox with only its default homepage open, and then close Firefox without doing any browsing and use the Menu button {3 bar icon) ==> Quit {Standby icon) do you still get the BEX crash ? # If that is problem free then what happens if you browse but only on this support forum before closing Firefox ? # I don't think we ever tried a clean reinstall of Firefox. That is not something that is guaranteed to help but it certainly should be tried. It involves removing the Firefox program folder (NOT the Firefox Profile folder & files) ------ === Clean Reinstall === Certain Firefox problems can be solved by performing a ''Clean reinstall''. This means you remove your Firefox program files and then reinstall Firefox. This process does not remove your [[Profiles - Where Firefox stores your bookmarks, passwords and other user data|Firefox profile]] data (such as bookmarks and passwords), since that information is stored in a different location. To do a clean reinstall of Firefox, please follow these steps: '''Note:''' You might want to print these steps or view them in another browser. #Download the latest Desktop version of Firefox from [https://www.mozilla.org mozilla.org] (or choose the download for your operating system and language from [https://www.mozilla.org/firefox/all/ this page]) and save the setup file to your computer. #After the download finishes, close all Firefox windows (or open the Firefox menu [[Image:New Fx Menu]] and click the close button [[Image:Close 29]]). #Delete the Firefox installation folder, which is located in one of these locations, by default: #*'''Windows:''' #**C:\Program Files\Mozilla Firefox #**C:\Program Files (x86)\Mozilla Firefox #*'''Mac:''' Delete Firefox from the Applications folder. #*'''Linux:''' If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it - see [[Installing Firefox on Linux]]. If you downloaded and installed the binary package from the [http://www.mozilla.org/firefox#desktop Firefox download page], simply remove the folder ''firefox'' in your home directory. #Now, go ahead and reinstall Firefox: ##Double-click the downloaded installation file and go through the steps of the installation wizard. ##Once the wizard is finished, choose to directly open Firefox after clicking the Finish button. More information about reinstalling Firefox can be found [[Troubleshoot and diagnose Firefox problems#w_5-reinstall-firefox|here]]. <b>WARNING:</b> Do not use a third party uninstaller as part of this process. Doing so could permanently delete your [[Profiles|Firefox profile]] data, including but not limited to, extensions, cache, cookies, bookmarks, personal settings and saved passwords. <u>These cannot be easily recovered unless they have been backed up to an external device!</u> See [[Back up and restore information in Firefox profiles]].
John99 971 izisombululo 13138 izimpendulo
Kuphostiwe

wwwaste said

I reverted back to FF53.0.3 and guess what? No more BEX error! As I tried to make clear: this has nothing to do with malware/viruses. FF54's new multiple processes ‘Electrolysis ’ (or E10s) is probably the cause.

Yes but the problems with downgrading are

  1. You have had problems in Fx53, are these now resolved ?
  2. Firefox 53 should now be considered not to be safe or secure. You should not now use it.
''wwwaste [[#answer-978188|said]]'' <blockquote> I reverted back to FF53.0.3 and guess what? No more BEX error! As I tried to make clear: this has nothing to do with malware/viruses. FF54's new multiple processes ‘Electrolysis ’ (or E10s) is probably the cause. </blockquote> Yes but the problems with downgrading are # You have had problems in Fx53, are these now resolved ? # Firefox 53 should now be considered not to be safe or secure. You should not now use it. #* See (Do Not) [[Install an older version of Firefox]]

Umnikazi wombuzo

John99 said

1. You have had problems in Fx53, are these now resolved ? 2. Firefox 53 should now be considered not to be safe or secure.

1. Yes after a cleanup 2. I'm aware of the implications, but I prefer not to get my os ruined by FF54's E10.

''John99 [[#answer-978209|said]]'' <blockquote> 1. You have had problems in Fx53, are these now resolved ? 2. Firefox 53 should now be considered not to be safe or secure. </blockquote> 1. Yes after a cleanup 2. I'm aware of the implications, but I prefer not to get my os ruined by FF54's E10.
John99 971 izisombululo 13138 izimpendulo
Kuphostiwe

I am not sure anyone is able to say the issue is soley down to E10s and if it was it is possible to disable that. (Unfortunately the easy methods of tweaking E10s may be in later versions of Firefox.)

I am not sure but are you saying you have turned off E10s on Fx54 and the BEX issue then goes away? or are you presuming any issue with Fx54 must be E10s related therefore your BEX issue is E10s related.

I am not sure anyone is able to say the issue is soley down to E10s and if it was it is possible to disable that. (Unfortunately the easy methods of tweaking E10s may be in later versions of Firefox.) I am not sure but are you saying you have turned off E10s on Fx54 and the BEX issue then goes away? or are you presuming any issue with Fx54 must be E10s related therefore your BEX issue is E10s related.

Umnikazi wombuzo

John99 said

I am not sure anyone is able to say the issue is soley down to E10s and if it was it is possible to disable that. (Unfortunately the easy methods of tweaking E10s may be in later versions of Firefox.) I am not sure but are you saying you have turned off E10s on Fx54 and the BEX issue then goes away? or are you presuming any issue with Fx54 must be E10s related therefore your BEX issue is E10s related.

I'm not sure either if FF54's E10s or the sandbox implementation as such is the cause, but I do know the BEX error only occured after updating from FF53 to FF54. Reverting to FF53 solves the problem.

No, I did not turn off/tweaked FF54's E10s (wouldn't know how to do that anyway).

''John99 [[#answer-978220|said]]'' <blockquote> I am not sure anyone is able to say the issue is soley down to E10s and if it was it is possible to disable that. (Unfortunately the easy methods of tweaking E10s may be in later versions of Firefox.) I am not sure but are you saying you have turned off E10s on Fx54 and the BEX issue then goes away? or are you presuming any issue with Fx54 must be E10s related therefore your BEX issue is E10s related. </blockquote> I'm not sure either if FF54's E10s or the sandbox implementation as such is the cause, but I do know the BEX error only occured after updating from FF53 to FF54. Reverting to FF53 solves the problem. No, I did not turn off/tweaked FF54's E10s (wouldn't know how to do that anyway).
John99 971 izisombululo 13138 izimpendulo
Kuphostiwe

Firefox 53 is now unsupported and must be considered unsafe. If you must use an older version of Firefox temporarily whilst sorting out problems with the current Release (Fx54) you should use Fx52 ESR because at least that has critical security fixes and so is safe to use.

Further as you are a Windows user the simplest method may be to install the third party build Firefox Portable ESR (Currently Fx52.2.0) as an additional browser.

Firefox 53 is now unsupported and must be considered unsafe. If you must use an older version of Firefox temporarily whilst sorting out problems with the current Release (Fx54) you should use Fx52 ESR because at least that has critical security fixes and so is safe to use. Further as you are a Windows user the simplest method may be to install the third party build Firefox Portable ESR (Currently Fx52.'''2'''.0) as an additional browser. * https://portableapps.com/apps/internet/firefox-portable-esr

Umnikazi wombuzo

Thanks.

Eagerly awaiting a follow up on solving the FF54 problem...

Thanks. Eagerly awaiting a follow up on solving the FF54 problem...
Happy112 561 izisombululo 5694 izimpendulo
Kuphostiwe

wwwaste said

No, I did not turn off/tweaked FF54's E10s (wouldn't know how to do that anyway).

If you're willing to give it a try :

You could turn it off as follows :

Type in the address bar about:config (promise to be careful, if asked) Type and search for the preferences : browser.tabs.remote.autostart and set it's value to false browser.tabs.remote.autostart.2 and set it's value to false

Note: the exact name of the preference may vary, but it will start with browser.tabs.remote.autostart

''wwwaste [[#answer-978237|said]]'' <blockquote> No, I did not turn off/tweaked FF54's E10s (wouldn't know how to do that anyway). </blockquote> If you're willing to give it a try : You could turn it off as follows : Type in the address bar '''about:config''' (promise to be careful, if asked) Type and search for the preferences : '''browser.tabs.remote.autostart''' and set it's value to '''false''' '''browser.tabs.remote.autostart.2''' and set it's value to ''' false''' Note: the exact name of the preference may vary, but it will start with browser.tabs.remote.autostart

Umnikazi wombuzo

Happy112 said

If you're willing to give it a try : You could turn it off as follows : Type in the address bar about:config (promise to be careful, if asked) Type and search for the preferences : browser.tabs.remote.autostart and set it's value to false browser.tabs.remote.autostart.2 and set it's value to false Note: the exact name of the preference may vary, but it will start with browser.tabs.remote.autostart

Thanks. Did that already, but didn't solve the BEX error.

''Happy112 [[#answer-979247|said]]'' <blockquote> If you're willing to give it a try : You could turn it off as follows : Type in the address bar '''about:config''' (promise to be careful, if asked) Type and search for the preferences : '''browser.tabs.remote.autostart''' and set it's value to '''false''' '''browser.tabs.remote.autostart.2''' and set it's value to ''' false''' Note: the exact name of the preference may vary, but it will start with browser.tabs.remote.autostart </blockquote> Thanks. Did that already, but didn't solve the BEX error.

Okulungisiwe ngu wwwaste

Happy112 561 izisombululo 5694 izimpendulo
Kuphostiwe

Would you consider posting this on the Microsoft support forum   ? (It's pretty similar to this forum)

https://answers.microsoft.com/en-US/windows/forum/windows_10

Or the Dutch section :

https://answers.microsoft.com/nl-nl/site/startsignin

Would you consider posting this on the Microsoft support forum &nbsp; ? (It's pretty similar to this forum) https://answers.microsoft.com/en-US/windows/forum/windows_10 Or the Dutch section : https://answers.microsoft.com/nl-nl/site/startsignin