X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

I have tried all of the suggestions in my Vista system to solve the problem Yahoo Search Page without success. It just comes back on restart. What can I do?

Kuphostiwe

I have read and tried all of the suggestions I could find in help to get rid of the automatic Yahoo default search engine. I even went into about:config and deleted whatever I could find that had the word Yahoo in it without any success. What can I do to kill this search engine in Firefox? To me this was a frustrating search engine that was not very good in the first place before the changes in their company in my opinion.

I would appreciate any help at this point.

Sgt

I have read and tried all of the suggestions I could find in help to get rid of the automatic Yahoo default search engine. I even went into about:config and deleted whatever I could find that had the word Yahoo in it without any success. What can I do to kill this search engine in Firefox? To me this was a frustrating search engine that was not very good in the first place before the changes in their company in my opinion. I would appreciate any help at this point. Sgt

Isisombululo esikhethiwe

Everything is working fine again. You were correct, it was the RoboForm that was insisting on bringing up the Yahoo Search on the first tab when using the search box on the RoboForm Page. There may be a way to fix this in RoboForm, but I have not taken the time to research the software in that detail as of yet. I may someday if I have some extra time.

Anyway. I can continue to use the RoboForm as the Homepage and can avoid the Yahoo searching problem in one of two ways. 1. Use the top search bar. 2. Use AdBlocker Ultimate to remove the search box from the RoboForm Page. The best answer and least hassle for now, is just to go back to the Firefox or Google page as the default Home Page.

Fixing the Firefox graphic links problem. The Re-installation process to fix the graphics in FireFox as you recommended, just took the proper installation order. You need to uninstall all Internet Security and Malware Software first and then re-install FireFox. Then after the FireFox Installation reinstall the Internet Security and Malware Software to fixed the graphic problems in FireFox. This makes the page function normally as it should be.

Thanks for all of your help. I sincerely appreciate all that you have done.

Stan

Funda le mpendulo ngokuhambisana nalesi sihloko 0

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Adobe PDF Plug-In For Firefox and Netscape "9.5.5"
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 22.0 r0
  • 5.1.41212.0
  • NPWLPG

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 6.0; WOW64; rv:48.0) Gecko/20100101 Firefox/48.0

Eminye Imininingwane

FredMcD
  • Top 10 Contributor
4225 izisombululo 58988 izimpendulo
Kuphostiwe

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control>(Mac=<Command>)<Shift> A)

In the Add-ons Manager, on the left, select Extensions. Remove Yahoo Anything. Now do the same in the computers Programs Folder.

Windows: Start > Control Panel > Uninstall Programs. Mac: Open the "Applications" folder. Linux: Check your user manual.

Type '''about:addons'''<enter> in the address bar to open your Add-ons Manager. Hot key; '''<Control>''(Mac=<Command>)''<Shift> A)''' In the Add-ons Manager, on the left, select '''Extensions.''' Remove Yahoo '''Anything.''' Now do the same in the computers Programs Folder. '''Windows:''' Start > Control Panel > Uninstall Programs. '''Mac:''' Open the "Applications" folder. '''Linux:''' Check your user manual.
James
  • Moderator
1594 izisombululo 11232 izimpendulo
Kuphostiwe
Have you seen https://support.mozilla.org/en-US/kb/change-your-default-search-settings-firefox ?

Umnikazi wombuzo

These suggestions did not work. As a matter of fact, I did not even find the word Yahoo in any of these locations.

Thanks for your help.

Stan

These suggestions did not work. As a matter of fact, I did not even find the word Yahoo in any of these locations. Thanks for your help. Stan
FredMcD
  • Top 10 Contributor
4225 izisombululo 58988 izimpendulo
Kuphostiwe

After you try James suggestion,

You may have ad / mal-ware. Further information can be found in the Troubleshoot Firefox issues caused by malware article.

Run most or all of the listed malware scanners. Each works differently. If one program misses something, another may pick it up.

After you try James suggestion, You may have ad / mal-ware. Further information can be found in the [[Troubleshoot Firefox issues caused by malware]] article. Run most or all of the listed malware scanners. Each works differently. If one program misses something, another may pick it up.
jscher2000
  • Top 10 Contributor
8638 izisombululo 70667 izimpendulo
Kuphostiwe

sgtphd said

These suggestions did not work. As a matter of fact, I did not even find the word Yahoo in any of these locations.

Did you see an extension called "Searchme"? That is one of numerous extensions that trigger Yahoo results pages at various time. I suggest disabling ALL nonessential extensions and removing ALL unknown extensions on the Add-ons page. Either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then cast a critical eye over the list on the right side. All extensions are optional. If in doubt, disable.

Often a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step.

Any improvement?

''sgtphd [[#answer-908026|said]]'' <blockquote> These suggestions did not work. As a matter of fact, I did not even find the word Yahoo in any of these locations.</blockquote> Did you see an extension called "Searchme"? That is one of numerous extensions that trigger Yahoo results pages at various time. I suggest disabling ALL nonessential extensions and removing ALL unknown extensions on the Add-ons page. Either: * Ctrl+Shift+a (Mac: Command+Shift+a) * "3-bar" menu button (or Tools menu) > Add-ons In the left column, click Extensions. Then cast a critical eye over the list on the right side. ''All extensions are optional. If in doubt, disable.'' Often a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step. Any improvement?

Umnikazi wombuzo

I have run three malware programs and if fact have one running all the time. Do I need to uninstall and reinstall the program at this point.

Any information will be appreciated.

Thanks for your help.

Stan

I have run three malware programs and if fact have one running all the time. Do I need to uninstall and reinstall the program at this point. Any information will be appreciated. Thanks for your help. Stan

Umnikazi wombuzo

No Help or location for the Searchme recommendation.

Thanks,

Stan

No Help or location for the Searchme recommendation. Thanks, Stan

Umnikazi wombuzo

I have tried everything recommendation now with no change. I have also noticed that when I start Firefox and search a little plus icon appears on the search magnifying glass at the top of the page. Upon clicking it yahoo is there when it is not even on the system. I have removed it from the search list.

Thanks for your help.

Stan

Again is it time to uninstall and reinstall Firefox or at least return everything to default settings?

I have tried everything recommendation now with no change. I have also noticed that when I start Firefox and search a little plus icon appears on the search magnifying glass at the top of the page. Upon clicking it yahoo is there when it is not even on the system. I have removed it from the search list. Thanks for your help. Stan Again is it time to uninstall and reinstall Firefox or at least return everything to default settings?
jscher2000
  • Top 10 Contributor
8638 izisombululo 70667 izimpendulo
Kuphostiwe

A green plus symbol appears on the magnifying glass in the search bar if the current site has an option to install a site search plugin. This site has one, for example.

Let's review the details of the problem:

(1) Can you select your preferred default search engine and does it "stick" for the duration of your session (i.e., until you exit/quit Firefox)?

If relevant: Change your default search settings in Firefox

(2) Does Firefox use your default search engine, or are your searches diverted to a different site?

(3) Does Firefox display your currently set home page at startup, or a different page?

If it displays a different page:

(A) Did that page replace your home page in Options? See: Startup, home page, tabs, and download settings.

(B) Can you change your home page and have it stick for the duration of your session?

(C) If startup gives you a different page than Ctrl+n (new window), your desktop shortcut might be hacked, see steps to check that below the line.

(4) If your settings are lost when you exit/quit Firefox, please see this article: How to fix preferences that won't save.


The Firefox icon can be set up to launch specific pages at startup (or more specifically, when you use the icon). To check whether that is set:

First, open the shortcut as follows:

  • Desktop shortcut: right-click the icon, choose Properties
  • Pinned taskbar icon: right-click the icon, right-click Mozilla Firefox, choose Properties

Windows normally will select the Shortcut tab. If not, go ahead and click the Shortcut tab.

You'll see the Target highlighted. On 64-bit Windows, that usually is no more and no less than the following:

"C:\Program Files (x86)\Mozilla Firefox\firefox.exe"

If anything follows after that, try clearing it out.

After OK'ing the Properties dialog, you can test right away to confirm that Firefox now launches only your home page. Either:

  • double-click desktop shortcut
  • right-click pinned taskbar icon, click Mozilla Firefox

Success?

A green plus symbol appears on the magnifying glass in the search bar if the current site has an option to install a site search plugin. This site has one, for example. Let's review the details of the problem: (1) Can you select your preferred default search engine and does it "stick" for the duration of your session (i.e., until you exit/quit Firefox)? ''If relevant:'' [[Change your default search settings in Firefox]] (2) Does Firefox use your default search engine, or are your searches diverted to a different site? (3) Does Firefox display your currently set home page at startup, or a different page? ''If it displays a different page:'' (A) Did that page replace your home page in Options? See: [[Startup, home page, tabs, and download settings]]. (B) Can you change your home page and have it stick for the duration of your session? (C) If startup gives you a different page than Ctrl+n (new window), your desktop shortcut might be hacked, see steps to check that below the line. (4) If your settings are lost when you exit/quit Firefox, please see this article: [[How to fix preferences that won't save]]. ---- The Firefox icon can be set up to launch specific pages at startup (or more specifically, when you use the icon). To check whether that is set: First, open the shortcut as follows: * Desktop shortcut: right-click the icon, choose Properties * Pinned taskbar icon: right-click the icon, right-click Mozilla Firefox, choose Properties Windows normally will select the Shortcut tab. If not, go ahead and click the Shortcut tab. You'll see the Target highlighted. On 64-bit Windows, that usually is no more and no less than the following: "C:\Program Files (x86)\Mozilla Firefox\firefox.exe" If anything follows after that, try clearing it out. After OK'ing the Properties dialog, you can test right away to confirm that Firefox now launches only your home page. Either: * double-click desktop shortcut * right-click pinned taskbar icon, click Mozilla Firefox Success?

Umnikazi wombuzo

Answers to questions:

(1) Can you select your preferred default search engine and does it "stick" for the duration of your session (i.e., until you exit/quit Firefox)?

- - It always searches Yahoo on the first tab. Then when I Right Click on Yahoo at the top left and left click “Search Google for Yahoo” it will change for the session on every other tab, but the first one stays on Yahoo. I can also click on the plus sign and then click Google Search. This does the same thing. It only changes starting the second tab.

If relevant: Change your default search settings in Firefox

- - That has always been set to Google or Bing, never Yahoo.

(2) Does Firefox use your default search engine, or are your searches diverted to a different site?

- - It is diverted to Yahoo at the start of each use of tab one during the entire session.

(3) Does Firefox display your currently set home page at startup, or a different page?

- - No! Always Roboform as I set for my home page.

If it displays a different page:

- - No - Se answer above.

(A) Did that page replace your home page in Options? See: Startup, home page, tabs, and download settings.

(B) Can you change your home page and have it stick for the duration of your session?

(C) If startup gives you a different page than Ctrl+n (new window), your desktop shortcut might be hacked, see steps to check that below the line.

(4) If your settings are lost when you exit/quit Firefox, please see this article: How to fix preferences that won't save.


The Firefox icon can be set up to launch specific pages at startup (or more specifically, when you use the icon). To check whether that is set:

First, open the shortcut as follows:

   Desktop shortcut: right-click the icon, choose Properties
   Pinned taskbar icon: right-click the icon, right-click Mozilla Firefox, choose Properties 

Windows normally will select the Shortcut tab. If not, go ahead and click the Shortcut tab.

You'll see the Target highlighted. On 64-bit Windows, that usually is no more and no less than the following:

"C:\Program Files (x86)\Mozilla Firefox\firefox.exe"

If anything follows after that, try clearing it out.

After OK'ing the Properties dialog, you can test right away to confirm that Firefox now launches only your home page. Either:

   double-click desktop shortcut
   right-click pinned taskbar icon, click Mozilla Firefox 

++++++++++++++++++++++++++++++++++++++++++++++++++++

- - Not an issue, it always opens to Roboform, my set page. I set it to that to get away from Google, Microsoft and Yahoo.

I hope this answers your Questions.

Stan

Answers to questions: (1) Can you select your preferred default search engine and does it "stick" for the duration of your session (i.e., until you exit/quit Firefox)? - - It always searches Yahoo on the first tab. Then when I Right Click on Yahoo at the top left and left click “Search Google for Yahoo” it will change for the session on every other tab, but the first one stays on Yahoo. I can also click on the plus sign and then click Google Search. This does the same thing. It only changes starting the second tab. If relevant: Change your default search settings in Firefox - - That has always been set to Google or Bing, never Yahoo. (2) Does Firefox use your default search engine, or are your searches diverted to a different site? - - It is diverted to Yahoo at the start of each use of tab one during the entire session. (3) Does Firefox display your currently set home page at startup, or a different page? - - No! Always Roboform as I set for my home page. If it displays a different page: - - No - Se answer above. (A) Did that page replace your home page in Options? See: Startup, home page, tabs, and download settings. (B) Can you change your home page and have it stick for the duration of your session? (C) If startup gives you a different page than Ctrl+n (new window), your desktop shortcut might be hacked, see steps to check that below the line. (4) If your settings are lost when you exit/quit Firefox, please see this article: How to fix preferences that won't save. --------- The Firefox icon can be set up to launch specific pages at startup (or more specifically, when you use the icon). To check whether that is set: First, open the shortcut as follows: Desktop shortcut: right-click the icon, choose Properties Pinned taskbar icon: right-click the icon, right-click Mozilla Firefox, choose Properties Windows normally will select the Shortcut tab. If not, go ahead and click the Shortcut tab. You'll see the Target highlighted. On 64-bit Windows, that usually is no more and no less than the following: "C:\Program Files (x86)\Mozilla Firefox\firefox.exe" If anything follows after that, try clearing it out. After OK'ing the Properties dialog, you can test right away to confirm that Firefox now launches only your home page. Either: double-click desktop shortcut right-click pinned taskbar icon, click Mozilla Firefox ++++++++++++++++++++++++++++++++++++++++++++++++++++ - - Not an issue, it always opens to Roboform, my set page. I set it to that to get away from Google, Microsoft and Yahoo. I hope this answers your Questions. Stan
jscher2000
  • Top 10 Contributor
8638 izisombululo 70667 izimpendulo
Kuphostiwe

Hi Stan, this part is a little hard to understand:

It always searches Yahoo on the first tab. Then when I Right Click on Yahoo at the top left and left click “Search Google for Yahoo” it will change for the session on every other tab, but the first one stays on Yahoo.

I'm trying to figure out what leads up to Yahoo being in the address bar.

So you start Firefox, and you get your correct home page, a Roboform page. At that point, does the address bar have the address of that page -- or has the word Yahoo mysteriously appeared there for no apparent reason??

If unexpected text has appeared in the address bar and you click in there and press Esc to clear the entry back to the page address, does the address bar show the correct page address?

Hi Stan, this part is a little hard to understand: <blockquote> It always searches Yahoo on the first tab. Then when I Right Click on Yahoo at the top left and left click “Search Google for Yahoo” it will change for the session on every other tab, but the first one stays on Yahoo.</blockquote> I'm trying to figure out what leads up to Yahoo being in the address bar. So you start Firefox, and you get your correct home page, a Roboform page. At that point, does the address bar have the address of that page -- or has the word Yahoo mysteriously appeared there for no apparent reason?? If unexpected text has appeared in the address bar and you click in there and press Esc to clear the entry back to the page address, does the address bar show the correct page address?

Umnikazi wombuzo

Explanation files attached.

Stan

Explanation files attached. Stan
jscher2000
  • Top 10 Contributor
8638 izisombululo 70667 izimpendulo
Kuphostiwe

Hi Stan, how did you get to that first search result page? Did you run your search in:

  • Firefox's search bar (the one pictured in your second screen shot)
  • Firefox's address bar
  • A search bar in your Roboform home page

I have a suspicion about that third one because I noticed the address of that results page contains fr=robo which sounds like "from Roboform" which makes me think you might have typed into a search box in their page which they've conveniently wired up to Yahoo regardless of your default search engine.


By the way, right-clicking a link in a web page always gives you the option to search for the link's display text in your default search engine. You don't need to do that to get to Google, you can search the text of your choice using either Firefox's search bar or Firefox's address bar.

Hi Stan, how did you get to that first search result page? Did you run your search in: * Firefox's search bar (the one pictured in your second screen shot) * Firefox's address bar * A search bar ''in your Roboform home page'' I have a suspicion about that third one because I noticed the address of that results page contains '''fr=robo''' which sounds like "from Roboform" which makes me think you might have typed into a search box in their page which they've conveniently wired up to Yahoo regardless of your default search engine. ---- By the way, right-clicking a link in a web page always gives you the option to search for the link's display text in your default search engine. You don't need to do that to get to Google, you can search the text of your choice using either Firefox's search bar or Firefox's address bar.

Umnikazi wombuzo

I finally uninstalled the Firefox program to get rid of the Yahoo Bug we have been working on without success. Now I am having trouble finding a download that is the correct secure one to reinstall the program. I either get that the notice that it will not work with anything but Windows 7 or I get a warning that the Software has been structured by someone so it is not secure and will not accept the add ons.

What a hassle this has been. I probably should have not uninstalled out of frustration, but can I get some help to reinstall the correct version for Windows Vista Home Premium.

Any help will be appreciated.

Stan

I finally uninstalled the Firefox program to get rid of the Yahoo Bug we have been working on without success. Now I am having trouble finding a download that is the correct secure one to reinstall the program. I either get that the notice that it will not work with anything but Windows 7 or I get a warning that the Software has been structured by someone so it is not secure and will not accept the add ons. What a hassle this has been. I probably should have not uninstalled out of frustration, but can I get some help to reinstall the correct version for Windows Vista Home Premium. Any help will be appreciated. Stan

Umnikazi wombuzo

Incidentally as an aside, when I have been able to get the FireFox installed, I get all text when I click on addons or options and not any graphics, Just wanted to add that to my note above.

Thanks,

Stan

Incidentally as an aside, when I have been able to get the FireFox installed, I get all text when I click on addons or options and not any graphics, Just wanted to add that to my note above. Thanks, Stan
jscher2000
  • Top 10 Contributor
8638 izisombululo 70667 izimpendulo
Kuphostiwe

For Vista, it's a two-step process to install Firefox.

(1) Choose your preferred language here:

https://www.mozilla.org/firefox/all/

For maximum plugin compatibility, choose the regular Windows version, not the Windows 64-bit version.

(2) Since that will install version 43.0.1, use the internal updater to get Firefox 48.0.1: Update Firefox to the latest release

For Vista, it's a two-step process to install Firefox. (1) Choose your preferred language here: https://www.mozilla.org/firefox/all/ For maximum plugin compatibility, choose the regular Windows version, not the Windows 64-bit version. (2) Since that will install version 43.0.1, use the internal updater to get Firefox 48.0.1: [[Update Firefox to the latest version]]

Umnikazi wombuzo

I have reinstalled FireFox as instructed and ended up with a normal home page, but as seen in the attached files, just pages of links for the remainder of the programs and the links do not work, I had to go to IE Explorer and search Mozilla Support to get to this page.

You have been terrific in your suggestions and recommendations, but please help me here or make a reinstall suggestion. Hopefully, I can get back up running soon.

Thanks again,

Stan

I have reinstalled FireFox as instructed and ended up with a normal home page, but as seen in the attached files, just pages of links for the remainder of the programs and the links do not work, I had to go to IE Explorer and search Mozilla Support to get to this page. You have been terrific in your suggestions and recommendations, but please help me here or make a reinstall suggestion. Hopefully, I can get back up running soon. Thanks again, Stan

Umnikazi wombuzo

Incidentally, I took off the RoboForm and made the home page default before I uninstalled the program. It did not help. I also took the extentions off one by one with the same results. When I was back to the basic program I uninstalled and rebooted. Now I have tried every thing I can to reinstall the program without normal results.

Please see my other descriptions a couple of replies above this one. I also tried several other Firefox install downloads and this is all I am able to get so far. I cannot get back to my normal program, extentions, themes or anything. Also, when I finally do I cannot reinstall them. I just get returned to the list of links or get an error saying the designer of the page is not using the correct security?

I look forward to hearing from you.

Thanks,

Stan

Incidentally, I took off the RoboForm and made the home page default before I uninstalled the program. It did not help. I also took the extentions off one by one with the same results. When I was back to the basic program I uninstalled and rebooted. Now I have tried every thing I can to reinstall the program without normal results. Please see my other descriptions a couple of replies above this one. I also tried several other Firefox install downloads and this is all I am able to get so far. I cannot get back to my normal program, extentions, themes or anything. Also, when I finally do I cannot reinstall them. I just get returned to the list of links or get an error saying the designer of the page is not using the correct security? I look forward to hearing from you. Thanks, Stan
jscher2000
  • Top 10 Contributor
8638 izisombululo 70667 izimpendulo
Kuphostiwe

Hi Stan, secure connection errors and unstyled pages often have the same root cause: Firefox lost trust in some intermediary software on your system that intercepts your browser connections. Typically this is security software, but sometimes is malware.

Do you have any of these products: Avast, BitDefender, Bullguard, ESET / nod32, and Kaspersky; AVG LinkScanner / SurfShield.

If you have any of those products: This support article will walk you through checking for this problem: How to troubleshoot security error codes on secure websites.

If not, we'll need to ask a few more questions to investigate the source of the problem.

Hi Stan, secure connection errors and unstyled pages often have the same root cause: Firefox lost trust in some intermediary software on your system that intercepts your browser connections. Typically this is security software, but sometimes is malware. Do you have any of these products: Avast, BitDefender, Bullguard, ESET / nod32, and Kaspersky; AVG LinkScanner / SurfShield. ''If you have any of those products:'' This support article will walk you through checking for this problem: [[How to troubleshoot the error code "SEC_ERROR_UNKNOWN_ISSUER" on secure websites]]. If not, we'll need to ask a few more questions to investigate the source of the problem.

Umnikazi wombuzo

So far I uninstalled 1. Malwarebytes, 2. Cloudmark, 3. Eset as you recommended. I then uninstalled and reinstalled FireFox again. Finally, I reinstalled each of the other programs in the same order I have in the past. So far, FireFox is working normally again. All of the graphics are back and the Add in programs as well as the themes have installed properly. The re installation of the three programs listed above did not corrupt anything, FireFox is still running properly.I am out of time for tonight. I will complete the process and let you know the final result including the Yahoo Issue tomorrow when I have more time.

Thanks for your help.

Stan

So far I uninstalled 1. Malwarebytes, 2. Cloudmark, 3. Eset as you recommended. I then uninstalled and reinstalled FireFox again. Finally, I reinstalled each of the other programs in the same order I have in the past. So far, FireFox is working normally again. All of the graphics are back and the Add in programs as well as the themes have installed properly. The re installation of the three programs listed above did not corrupt anything, FireFox is still running properly.I am out of time for tonight. I will complete the process and let you know the final result including the Yahoo Issue tomorrow when I have more time. Thanks for your help. Stan