X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

back/forward button does not work

Kuphostiwe

a colleague of mine is running FF 45.2.0 on his desktop and experiences the following problem. normally, when you left klick on the back/forward button (to the left of the location bar) and keep the left mouse button pressed for a short while (or simply right klick the button) a drop down will appear showing the previously visited locations which then can be selected for revisiting. With my colleague the drop down does not appear! (On my computer it works fine). My colleague runs three extensions and one theme, but those do not seem to cause the problem. furthermore i made a strange observation: i used a copy of the user profile and i edited the prefs.js and just deleted the entry specifying the startup homepage ('browser.startup.homepage') - and it works ! As soon as i again specify a homepage, the problem will reoccur.

a colleague of mine is running FF 45.2.0 on his desktop and experiences the following problem. normally, when you left klick on the back/forward button (to the left of the location bar) and keep the left mouse button pressed for a short while (or simply right klick the button) a drop down will appear showing the previously visited locations which then can be selected for revisiting. With my colleague the drop down does not appear! (On my computer it works fine). My colleague runs three extensions and one theme, but those do not seem to cause the problem. furthermore i made a strange observation: i used a copy of the user profile and i edited the prefs.js and just deleted the entry specifying the startup homepage ('browser.startup.homepage') - and it works ! As soon as i again specify a homepage, the problem will reoccur.

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Adobe PDF Plug-In For Firefox and Netscape 10.1.14
  • Citrix Receiver Plugin (Win32)
  • Citrix URL-Redirection Helper Plugin
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 1.6.0_45 for Mozilla browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • Shockwave Flash 18.0 r0
  • 5.1.41212.0
  • VLC media player Web Plugin 2.1.3

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0

Eminye Imininingwane

Wesley Branton
  • Top 10 Contributor
695 izisombululo 5507 izimpendulo
Kuphostiwe

Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu , click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

SafeMode-Fx35

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

'''Try Firefox Safe Mode''' to see if the problem goes away. [[Troubleshoot Firefox issues using Safe Mode|Firefox Safe Mode]] is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes). '''If Firefox is open,''' you can restart in Firefox Safe Mode from the Help menu: * Click the menu button [[Image:New Fx Menu]], click Help [[Image:Help-29]] and select ''Restart with Add-ons Disabled''. '''If Firefox is not running,''' you can start Firefox in Safe Mode as follows: * On Windows: Hold the '''Shift''' key when you open the Firefox desktop or Start menu shortcut. * On Mac: Hold the '''option''' key while starting Firefox. * On Linux: Quit Firefox, go to your Terminal and run ''firefox -safe-mode'' <br>(you may need to specify the Firefox installation path e.g. /usr/lib/firefox) When the Firefox Safe Mode window appears, select "Start in Safe Mode". ;[[Image:SafeMode-Fx35]] '''''If the issue is not present in Firefox Safe Mode''''', your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]] article to find the cause. ''To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.'' When you figure out what's causing your issues, please let us know. It might help others with the same problem.
cor-el
  • Top 10 Contributor
  • Moderator
17693 izisombululo 160088 izimpendulo
Kuphostiwe

What home page setting do you use?

Does this happen with all tabs where you open multiple pages in a tab?

You can check for problems with the places.sqlite database (bookmarks and history) in the Firefox profile folder.

See also:

What home page setting do you use? Does this happen with all tabs where you open multiple pages in a tab? You can check for problems with the <b>places.sqlite</b> database (bookmarks and history) in the Firefox profile folder. *https://addons.mozilla.org/firefox/addon/places-maintenance/ See also: *http://kb.mozillazine.org/Bookmarks_history_and_toolbar_buttons_not_working_-_Firefox *https://support.mozilla.org/kb/Bookmarks+not+saved#w_fix-the-bookmarks-file

Umnikazi wombuzo

Thank you very much for your hints.

Safe mode does not change things.

Can you please state more specifically which 'homepage settings' you are asking for? Yes, it happens with all tabs with multiple pages.

After refreshing the profile the problem is removed. I have to correct the last statement in my question: the problem does not occur again after again specifying a homepage.

There is another user with the same incident who uses no extensions at all. I am under kind of pressure to deliver an 'explanation' for this behaviour. Would you agree under the circumstances described to call this a 'firefox bug'? Thank you very much again.

Thank you very much for your hints. Safe mode does not change things. Can you please state more specifically which 'homepage settings' you are asking for? Yes, it happens with all tabs with multiple pages. After refreshing the profile the problem is removed. I have to correct the last statement in my question: the problem does not occur again after again specifying a homepage. There is another user with the same incident who uses no extensions at all. I am under kind of pressure to deliver an 'explanation' for this behaviour. Would you agree under the circumstances described to call this a 'firefox bug'? Thank you very much again.

Umnikazi wombuzo

is it a bug? or is there a way to wantedly suppress the drop down?

is it a bug? or is there a way to wantedly suppress the drop down?
jscher2000
  • Top 10 Contributor
8838 izisombululo 72242 izimpendulo
Kuphostiwe

That's not normal.

One note that may or may not be relevant:

The last time I checked, the "new tab page" (the one that opens when you Ctrl+t or click the "+" button) has a unique behavior of not allowing back from the first navigation action. The button is grayed, so you can tell that no kind of clicking (regular or long-press or right-clicking) will let you go back to the initial new tab page. This is true whether you use the standard new tab page or a substitute page (e.g., home page on new tab page).

That's not normal. One note that may or may not be relevant: The last time I checked, the "new tab page" (the one that opens when you Ctrl+t or click the "+" button) has a '''unique''' behavior of not allowing back from the first navigation action. The button is grayed, so you can tell that no kind of clicking (regular or long-press or right-clicking) will let you go back to the initial new tab page. This is true whether you use the standard new tab page or a substitute page (e.g., home page on new tab page).
John99 971 izisombululo 13138 izimpendulo
Kuphostiwe

After refreshing the profile the problem is removed. (If you have no addons and plugins) If this problem goes away when the profile is Refreshed. Or probably more convenient for a knowledgeable user if you use a new additional profile. Then compare the changed preferences. The troubleshooting information page will help you determine that (key in to the addressbar about:support)

If you want a more detailed comparison look at the content of each profiles prefs.js file (Check there is no file user.js)

is it a bug? or is there a way to wantedly suppress the drop down?

I think for instance the classic theme restorer addon will change that. Many parts of Firefox may be changed one way or another.

''After refreshing the profile the problem is removed.'' (If you have no addons and plugins) If this problem goes away when the profile is Refreshed. Or probably more convenient for a knowledgeable user if you use a new additional profile. Then compare the changed preferences. The troubleshooting information page will help you determine that (key in to the addressbar about:support) * Also see [[Use the Troubleshooting Information page to help fix Firefox issues]] If you want a more detailed comparison look at the content of each profiles prefs.js file (Check there is no file user.js) * http://kb.mozillazine.org/Prefs.js_file * http://kb.mozillazine.org/User.js_file ''is it a bug? or is there a way to wantedly suppress the drop down?'' I think for instance the classic theme restorer addon will change that. Many parts of Firefox may be changed one way or another.