Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox 43.0.4 does not download images.

  • 1 baphendule
  • 1 inale nkinga
  • 8 views
  • Igcine ukuphendulwa ngu cor-el

more options

First problem I had was that my SB website would not respond. Turned on Javascript and that solved the problem. About 2 hours later I noticed that images were not loading from sites like Amazon, Newegg, Tigerdirect, Woot, etc. I have tried everything I have read about with no luck. I reinstalled Firefox w/o deleting any other folders or files.

I don't want to uninstall my profiles. I have it working like I want and have spent considerable time on it over the years.

All Replies (1)

more options

Firefox 42+ has a Tracking Protection feature that is enabled by default in Private Browsing mode. When you are in private browsing mode then Firefox can show a shield icon at the left end of the location/address bar that some content is affected.

You can disable this feature in "Options/Preferences > Privacy" or via the about:privatebrowsing page that get when you open a New Private Window.

  • Options/Preferences > Privacy: "Use Tracking Protection in Private Windows"

If images are missing then check that you do not block images from some domains. You can tap the Alt key or press F10 to show the Menu Bar Check the permissions for the domain in the currently selected tab in "Tools > Page Info > Permissions"

Check "Tools > Page Info > Media" for blocked images

  • Select the first image link and use the cursor Down key to scroll through the list.
  • If an image in the list is grayed and "Block Images from..." has a checkmark then remove this checkmark to unblock images from this domain.

Make sure that you do not block (third-party) images, permissions.default.image pref on the about:config page should be 1.


There are extensions like Adblock Plus (Firefox menu button/Tools > Add-ons > Extensions) and Anti-Virus software that can block images and other content.

See also: