Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

How to keep webpages from refreshing to a yahoo search

  • 1 baphendule
  • 1 inale nkinga
  • 7 views
  • Igcine ukuphendulwa ngu jscher2000

more options

Some webpages will redirect me to yahoo's search page, randomly. For example, while browsing forever21's website, I clicked on an image link and it redirected me to a yahoo page. Help?

Okulungisiwe ngu bthindi

All Replies (1)

more options

Unfortunately your image did not attach. You could reply to yourself and attach it that way: https://support.mozilla.org/questions/1086316#question-reply

But it sounds like a malware problem. On Macs, this most commonly seems to be caused by Spigot or Conduit add-ons, or something else that snuck in undetected with some other software you downloaded.

Please try disabling ALL nonessential or unrecognized extensions on the Add-ons page. Either:

  • Cmd+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then, if in doubt, disable (or remove). Especially if you find something called SearchMe. Bear in mind that all extensions are optional and none are included with Firefox when you first get it.

Often a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step.

Does that help you regain control?