Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

No 4K resulution on youtube

  • 7 uphendule
  • 17 zinale nkinga
  • 26253 views
  • Igcine ukuphendulwa ngu jscher2000

more options

Some videos on youtube don't show the 4k resolution option under firefox and the only go up to 1080P but on chrome they show all the resolutions:

example video https://youtu.be/WU-NrfB8Kd4

I have flash installed as well

Isisombululo esikhethiwe

About ten hours after I posted, I learned that Firefox has VP9 decoding but it is disabled by default, perhaps because the mediasource feature still has bugs. If you want to try it, you can toggle this setting:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste media and pause while the list is filtered

(3) Double-click the media.mediasource.webm.enabled preference to toggle it from false to true

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 6

All Replies (7)

more options

The option shows for me, it might be that youtube will provide the media based on your device's meta data and will only provide compatible qualities.

See also: https://support.google.com/youtube/an.../91449?hl=en

more options

guigs said

The option shows for me, it might be that youtube will provide the media based on your device's meta data and will only provide compatible qualities. See also: https://support.google.com/youtube/an.../91449?hl=en

The 4k option shows up on other videos but not on that video, so now I am really confused. what can be the cause of that

more options

It might be the availability of that quality of that video.

  • ": For example, if the video was recorded in standard definition, it will not be available in high definition."
more options

guigs said

It might be the availability of that quality of that video.
  • ": For example, if the video was recorded in standard definition, it will not be available in high definition."

yes but did you read that part when i state that this video on chrome has 4k resolution. I tried with addons disabled and same problem. Thank you anyway for trying to help

Okulungisiwe ngu Levan7

more options

When you are watching in 4K in Chrome, could you right-click the video and choose "Stats for nerds" and look at the "Mime Type"? Firefox does not yet support WebM VP9, and it may be that Google is only transcoding 4K video to that particular format/codec. There also are some MP4 codecs that Firefox does not support. (YouTube offers different resolution levels and various codecs in different container formats, which makes it hard to make general statements.)

more options

jscher2000 said

When you are watching in 4K in Chrome, could you right-click the video and choose "Stats for nerds" and look at the "Mime Type"? Firefox does not yet support WebM VP9, and it may be that Google is only transcoding 4K video to that particular format/codec. There also are some MP4 codecs that Firefox does not support. (YouTube offers different resolution levels and various codecs in different container formats, which makes it hard to make general statements.)

Well I looked at other pages that state that those videos are vp9 http://base-n.de/webm/VP9%20Sample.html So i thought vp9 was supported by firefox that is why i did not look into that but chrome versions of 4k videos are vp9

more options

Isisombululo Esikhethiwe

About ten hours after I posted, I learned that Firefox has VP9 decoding but it is disabled by default, perhaps because the mediasource feature still has bugs. If you want to try it, you can toggle this setting:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste media and pause while the list is filtered

(3) Double-click the media.mediasource.webm.enabled preference to toggle it from false to true