Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Why all of a sudden is my spell check no longer is working ?

  • 5 uphendule
  • 10 zinale nkinga
  • 1571 views
  • Igcine ukuphendulwa ngu FredMcD

more options

I just noticed a few days ago that when I misspell a word & get the red squiggly line under the word as usual, on You Tube & a couple other sites when I right click I don't get the drop down with the correct spelling. Also when I try to copy (it seems to work), but when I right click & hit "paste" it doesn't work. I have Windows 8.1, Firefox 39.0 recently installed. Is there a reason this is happening & can it be corrected? Thank You PT

Isisombululo esikhethiwe

Hello there,

By default, Firefox is configured to automatically check spelling. You can double check this feature by doing the following:

1. Click the menu button New Fx Menu and choose Preferences. 2. Select the Advanced panel. 3. Click the General tab. 4. Make sure the checkbox "Check my spelling as i type" is ticked

Close the about:preferences page. Any changes you've made will automatically be saved.

Hope this helps!

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 2

All Replies (5)

more options

Isisombululo Esikhethiwe

Hello there,

By default, Firefox is configured to automatically check spelling. You can double check this feature by doing the following:

1. Click the menu button New Fx Menu and choose Preferences. 2. Select the Advanced panel. 3. Click the General tab. 4. Make sure the checkbox "Check my spelling as i type" is ticked

Close the about:preferences page. Any changes you've made will automatically be saved.

Hope this helps!

more options

Type about:config<Enter> in the address bar. If a warning screen comes up, press the Be Careful button. This is where Firefox finds information it needs to run. At the top of the screen is a search bar.

Type: layout.spellcheckDefault Its values are; 0 Spell Checker Off, 1 Check Only Multi-Line Input Boxes. 2 Check Multi And Single Line Input Boxes.

Also, check the spellchecker.dictionary entry.

more options

layout.spellcheckDefault

should go to 3 so that rich text can be spell-checked, over-riding any stupid websites that choose to disable your spell-checker - ultimately it should be the user that controls the browser, not websites.

more options

Spell check is there but, but it is said not compatible, was working. Is Firefox failing?

more options

A post was flagged as Solved Problem. Please remove that flag. If you don’t, others that can help may not read this post.


Download Firefox For All languages And Systems {web link} Save the file. Then;

Using your file browser, open the Programs Folder on your computer.

Windows: C:\Program Files C:\Program Files (x86) Mac: Open the "Applications" folder. Linux: Check your user manual.


Look for, and rename any Mozilla or Firefox folders by adding .old to them.

After rebooting the computer, run a registry scanner. Then run the installer. If all goes well, remove the OLD folders when you are done.