Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox 39: How do I stop previously closed tabs from opening when firefox is started?

  • 2 uphendule
  • 1 inale nkinga
  • 6 views
  • Igcine ukuphendulwa ngu rhaewynsmom

more options

I've been through all of the support questions on this--fair warning. I recently got the firefox 39 update. Since then I've had this issue. I close my browser and tabs. If I open the browser, the old tabs come back. I have renamed user.js and even deleted it at one point. I have changed settings as mentioned in posts on about:config. The issue seems to be under preferences though in privacy. If I set it not to remember my history, I just get a blank page. If I set it to remember history, the previous tabs closed load up when I open firefox. I'm thinking this is some kind of a bug. I have also uninstalled and reinstalled firefox which did not help the matter. I also tried booting in safe mode to change the settings as mentioned in some of the posts. If I change the options under "when firefox starts" to show my homepage, show my tabs from the last time or a blank page, it still loads the closed tabs. Nothing seems to change it except for changing privacy to not save my history. The problem with this is that I then need to constantly re-login to websites over and over again because it doesn't save my information. I have tried to set it to just save some history, but again same issue. Old tabs reappear. Is there any other fix for this?

I am now disconnecting my account and seeing if this makes a difference after I post this.

I've been through all of the support questions on this--fair warning. I recently got the firefox 39 update. Since then I've had this issue. I close my browser and tabs. If I open the browser, the old tabs come back. I have renamed user.js and even deleted it at one point. I have changed settings as mentioned in posts on about:config. The issue seems to be under preferences though in privacy. If I set it not to remember my history, I just get a blank page. If I set it to remember history, the previous tabs closed load up when I open firefox. I'm thinking this is some kind of a bug. I have also uninstalled and reinstalled firefox which did not help the matter. I also tried booting in safe mode to change the settings as mentioned in some of the posts. If I change the options under "when firefox starts" to show my homepage, show my tabs from the last time or a blank page, it still loads the closed tabs. Nothing seems to change it except for changing privacy to not save my history. The problem with this is that I then need to constantly re-login to websites over and over again because it doesn't save my information. I have tried to set it to just save some history, but again same issue. Old tabs reappear. Is there any other fix for this? I am now disconnecting my account and seeing if this makes a difference after I post this.

All Replies (2)

more options

You can check if you have a user.js file in the Firefox profile folder that sets the browser.sessionstore.resume_session_once pref to true.

Your System Details list shows that you have a user.js file in the profile folder to initialize prefs each time Firefox starts. The user.js file will only be present if you or other software has created this file and normally won't be present.

You can check its content with a plain text editor (right-click: "Open with"; do not double-click). The user.js file is read each time Firefox is started and initializes preferences to the value specified in this file, so preferences set via user.js can only be changed temporarily for the current session.

You can delete the user.js file if you didn't create this file yourself.

You can use this button to go to the current Firefox profile folder:

Windows hides some file extensions by default. Among them .html and .ini and .js and .txt, so you may only see a file name without file extension. You can see the real file type (file extension) in the properties of the file via the right-click context menu in Windows Explorer.

more options

Okay, so here is what I did. I uninstalled firefox. I have Windows 8 in case anyone else has this issue...

Then I went into C:Users/(My Profile Name)/

At the top of the browser/explorer, I clicked on view. I clicked the check box for Hidden Items so that it was checked off.

Then I navigated here: C:Users/(My Profile Name/AppData/Roaming/Mozilla/Firefox/Profiles/ There was only one folder in this subdirectory named 7qx05nre.default so this may be named differently on other systems. I opened that folder and scrolled down to find user.js. I deleted it. Then I shut down my computer and restarted it. I went to the mozilla website using IE (I hate IE) and downloaded Firefox. I installed it.

Problem solved. For some reason deleting the user.js file did not work on it's own. Neither did uninstalling and reinstalling firefox on it's on. The combination of deleting firefox and user.js together seemed to fix the problem.