Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

When Firefox restarts the pages do not reload they just display history, i then have to refresh to get new data Explorer always reloads and Firefox used to

  • 7 uphendule
  • 1 inale nkinga
  • 1897 views
  • Igcine ukuphendulwa ngu jmparret

more options

This should be an easy fix because all other browsers and Firefox used to do this. When Firefox is restarted the pages do not reload they just display history. I have to hit the reload current page button to get the new data. This has been driving me crazy for a few weeks. I thought I had if fixed a couple of times but only a couple of pages would reload and now it is all history again.

Joe

Isisombululo esikhethiwe

Oh, you use Session Manager. What happens if you check the box in Session Manager options, under Saving & Restoring, to "Reload All Restored Windows"?

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (7)

more options

What do you mean by all history ?

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac Options)
key, and then starting Firefox. Is the problem still there?

more options

By default, when you resume a previous session, Firefox only reloads the currently active tab, and the others load when you click to display them. I can't think of a scenario where they just sit there and do NOT reload.

If it possible that one of your extensions is responsible for this change? You can review and disable your extensions, and often find a settings dialog for them, on the Add-ons page. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then on the right side look for anything tab or session related that might influence this.

more options

safe mode did not work as I could not access my bookmarks and if i reloaded them they would only have current information so history would not be displayed.

I disabled on my add-ons and no current pages were displayed only history. This is true on two computers running firefox. I use session manager and all pages start up but they are all old information.

I have never had this problem before with any browser. I prefer running firefox for most of my browser applications but showing old pages on restart is not good. Does anyone have the same problem as me? I have to hit the reload current page to get the new information even when the computer has been shut down for weeks.

Thank you for your help so far but it is not working.

Add-ons used are: Session Manager 0.8.1.6.1 LastPass 3.1.1.1 Adblock plus 2.6.9.1

more options

Isisombululo Esikhethiwe

Oh, you use Session Manager. What happens if you check the box in Session Manager options, under Saving & Restoring, to "Reload All Restored Windows"?

more options

Or, if the dialog looks like the following page, it's called "Bypass cache when restoring sessions"

http://sessionmanager.mozdev.org/options.html#saving

Okulungisiwe ngu jscher2000

more options

I think that this is about loading a fresh copy from the server and not using a version in the cache from the previous session. A website would have to instruct the browser not to cache pages to make this work.

more options

Session Manager looks like the culprit. I had not changed anything on that add-on and the problem happened on two computers. I had disabled Session Manager and the problem was still occurring, even after reboot.

I want to thank all of you for your help because without your support Firefox would not be the browser so many people like and use everyday.

Joe