X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

I can't print anymore, the "help" button doesn't work, and Firefox always sets to "Never Remember History" even if I change it

Kuphostiwe

SO many issues with Firefox now! For one, it crashes quite a bit. I submit the crash report, and go from there. Keeps happening. But the main thing is this:

I go to "Options" and under "Privacy" it has "Never remember history" - I change it to "use custom settings for history", hit "ok" and then when I go back to it, it's back on "never remember history" already. What gives?

The issues I'm having right now is that I used to click on Print in my email (Yahoo) and pop-up blocker would stop it, but a dialog would pop up saying "try again", and I would hit that, and a separate window would open where I could print the email. Now, when I click on print, NOTHING happens. No box, no changes whatsoever. No pop-ups blocked, nothing at all. I mean, the button for "print" doesn't even react like I clicked on it. Nothing happens.

The other issue is that when there's a text box, if I start to type my email address, it suggests my email address. It never used to do this! I don't want this, either. How can I stop the suggesting of my email address. I don't want it to remember what I typed!

Another issue with Firefox is that when I click on the "menu" button in the top right, there's a question mark that says "open help menu" at the bottom. When I click on that, the help menu is EMPTY. I included a picture so you can see.

I've "reloaded Firefox", as well as downloaded another copy and actually reinstalled it. All these errors keep happening. How can I get them to stop or function correctly? What's causing them to work all wonky?

SO many issues with Firefox now! For one, it crashes quite a bit. I submit the crash report, and go from there. Keeps happening. But the main thing is this: I go to "Options" and under "Privacy" it has "Never remember history" - I change it to "use custom settings for history", hit "ok" and then when I go back to it, it's back on "never remember history" already. What gives? The issues I'm having right now is that I used to click on Print in my email (Yahoo) and pop-up blocker would stop it, but a dialog would pop up saying "try again", and I would hit that, and a separate window would open where I could print the email. Now, when I click on print, NOTHING happens. No box, no changes whatsoever. No pop-ups blocked, nothing at all. I mean, the button for "print" doesn't even react like I clicked on it. Nothing happens. The other issue is that when there's a text box, if I start to type my email address, it suggests my email address. It never used to do this! I don't want this, either. How can I stop the suggesting of my email address. I don't want it to remember what I typed! Another issue with Firefox is that when I click on the "menu" button in the top right, there's a question mark that says "open help menu" at the bottom. When I click on that, the help menu is EMPTY. I included a picture so you can see. I've "reloaded Firefox", as well as downloaded another copy and actually reinstalled it. All these errors keep happening. How can I get them to stop or function correctly? What's causing them to work all wonky?
Ama-screenshot ananyekiwe

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.10
  • A plugin to detect whether the Adobe Application Manager is installed on this machine.
  • Amazon MP3 Downloader Plugin 1.0.17
  • DivX Web Player version 3.1.1.9
  • DivX VOD Helper Plug-in
  • GEPlugin
  • Google Update
  • Inte IPT Web API
  • Intel WebAPI Updater - Installs and updates Intel WebAPIs
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.31.2 for Mozilla browsers
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 17.0 r0
  • Adobe Shockwave for Director Netscape plug-in, version 12.1.7.157
  • 5.1.30514.0
  • Website Logon Plugin
  • NPWLPG
  • iTunes Detector Plug-in

Isisebenziso

  • Firefox 37.0.2
  • Umsebenzisi oyi-ejenti: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:37.0) Gecko/20100101 Firefox/37.0
  • I-URL Yokweseka: https://support.mozilla.org/1/firefox/37.0.2/WINNT/en-US/

Izandiso

  • HP Smart Web Printing 4.60 (smartwebprinting@hp.com) (Akusebenzi)
  • Norton Toolbar 2014.7.12.7 ({2D3F3651-74B9-4795-BDEC-6DA2F431CB62}) (Akusebenzi)
  • Skype Click to Call 6.13.0.13771 ({82AF8DCA-6DE9-405D-BD5E-43525BDAD38A}) (Akusebenzi)

I-Javascript

  • incrementalGCEnabled: True

Imidwebo

  • adapterDescription: Intel(R) HD Graphics Family
  • adapterDescription2:
  • adapterDeviceID: 0x0116
  • adapterDeviceID2:
  • adapterDrivers: igdumd64 igd10umd64 igd10umd64 igdumdx32 igd10umd32 igd10umd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterSubsysID: 185e103c
  • adapterSubsysID2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'blockedDriver']
  • directWriteEnabled: False
  • directWriteVersion: 6.2.9200.16571
  • driverDate: 9-30-2011
  • driverDate2:
  • driverVersion: 8.882.2.3000
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'blockedDriver']
  • numTotalWindows: 5
  • webglRendererMessage: [u'blockedDriver']
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic

Okuthandwayo Okulungisiwe

Misc

  • Umsebenzisi JS: Cha
  • Ukufinyeleleka: Cha
cor-el
  • Top 10 Contributor
  • Moderator
17573 izisombululo 158948 izimpendulo
Kuphostiwe

Impendulo Ewusizo

The "Use custom settings for history" selection allows to see the current history and cookie settings, but selecting this doesn't make any changes to history and cookie settings. Firefox shows "Use custom settings for history" as an indication that at least one of the history and cookie settings is not the default to make you aware that changes were made. If all History settings are default then the custom settings are hidden and you see "Firefox will: (Never) Remember History". "Never Remember History" means that Private Browsing is active and "Always use private browsing mode" gets a checkmark. You need to remove the checkmark on "Always use private browsing mode" to leave Private Browsing mode or chose the "Remember History" setting.

The "Use custom settings for history" selection allows to see the current history and cookie settings, but selecting this doesn't make any changes to history and cookie settings. Firefox shows "Use custom settings for history" as an indication that at least one of the history and cookie settings is not the default to make you aware that changes were made. If all History settings are default then the custom settings are hidden and you see "Firefox will: (Never) Remember History". "Never Remember History" means that Private Browsing is active and "Always use private browsing mode" gets a checkmark. You need to remove the checkmark on "Always use private browsing mode" to leave Private Browsing mode or chose the "Remember History" setting. *https://support.mozilla.org/kb/Private+Browsing

Umnikazi wombuzo

cor-el said

The "Use custom settings for history" selection allows to see the current history and cookie settings, but selecting this doesn't make any changes to history and cookie settings. Firefox shows "Use custom settings for history" as an indication that at least one of the history and cookie settings is not the default to make you aware that changes were made. If all History settings are default then the custom settings are hidden and you see "Firefox will: (Never) Remember History". "Never Remember History" means that Private Browsing is active and "Always use private browsing mode" gets a checkmark. You need to remove the checkmark on "Always use private browsing mode" to leave Private Browsing mode or chose the "Remember History" setting.

Well, I would check it out, but now when I click on the "Open Menu" in the top right hand corner and click on "Options" nothing even opens up. I uninstalled Firefox, downloaded and reinstalled it, and now the "Options" isn't even clickable.

''cor-el [[#answer-723219|said]]'' <blockquote> The "Use custom settings for history" selection allows to see the current history and cookie settings, but selecting this doesn't make any changes to history and cookie settings. Firefox shows "Use custom settings for history" as an indication that at least one of the history and cookie settings is not the default to make you aware that changes were made. If all History settings are default then the custom settings are hidden and you see "Firefox will: (Never) Remember History". "Never Remember History" means that Private Browsing is active and "Always use private browsing mode" gets a checkmark. You need to remove the checkmark on "Always use private browsing mode" to leave Private Browsing mode or chose the "Remember History" setting. *https://support.mozilla.org/kb/Private+Browsing </blockquote> Well, I would check it out, but now when I click on the "Open Menu" in the top right hand corner and click on "Options" nothing even opens up. I uninstalled Firefox, downloaded and reinstalled it, and now the "Options" isn't even clickable.
jscher2000
  • Top 10 Contributor
8792 izisombululo 71890 izimpendulo
Kuphostiwe

In case Firefox's program files got scrambled in the update, could you try:

Clean Reinstall

We use this name, but it's not about removing your settings, it's about making sure the program files are clean. As set forth below, this process does not disturb your existing settings. Do NOT uninstall Firefox, that's not needed.

(1) Download a fresh installer for Firefox 37.0.2 from https://www.mozilla.org/firefox/all/ to a convenient location. (Scroll down to your preferred language.)

(2) Exit out of Firefox (if applicable).

(3) Rename the program folder

(64-bit Windows folder names)

C:\Program Files (x86)\Mozilla Firefox

to

C:\Program Files (x86)\OldFirefox

(32-bit Windows folder names)

C:\Program Files\Mozilla Firefox

to

C:\Program Files\OldFirefox

(4) Run the installer you downloaded in #1. It should automatically connect to your existing settings.

Any improvement?

Note: Some plugins may exist only in that OldFirefox folder. If something essential is missing, look in these folders:

  • \OldFirefox\Plugins
  • \OldFirefox\browser\plugins
In case Firefox's program files got scrambled in the update, could you try: '''Clean Reinstall''' We use this name, but it's not about removing your settings, it's about making sure the program files are clean. As set forth below, this process does not disturb your existing settings. Do NOT uninstall Firefox, that's not needed. (1) Download a fresh installer for Firefox 37.0.2 from https://www.mozilla.org/firefox/all/ to a convenient location. (Scroll down to your preferred language.) (2) Exit out of Firefox (if applicable). (3) Rename the program folder ''(64-bit Windows folder names)'' C:\Program Files (x86)\Mozilla Firefox to C:\Program Files (x86)\OldFirefox ''(32-bit Windows folder names)'' C:\Program Files\Mozilla Firefox to C:\Program Files\OldFirefox (4) Run the installer you downloaded in #1. It should automatically connect to your existing settings. Any improvement? Note: Some plugins may exist only in that OldFirefox folder. If something essential is missing, look in these folders: * \OldFirefox\Plugins * \OldFirefox\browser\plugins
jscher2000
  • Top 10 Contributor
8792 izisombululo 71890 izimpendulo
Kuphostiwe

Sometimes having plugins set to "Ask to Activate" can cause odd user interface issues in the initial window, but if you launch a new window using Ctrl+n, the problems are not manifested there. Either way, you might want to review your plugin permissions.

Open Firefox's Add-ons page using either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons
  • in the Windows "Run" dialog, type or paste
    firefox.exe "about:addons"

In the left column, click Plugins. This should display a list showing enabled plugins on top, and disabled plugins at the bottom. I suggest the following approach:

  • For media players like Shockwave Flash, Silverlight, and QuickTime, set the permission to "Ask to Activate"
  • For plugins that work in the background (e.g., password managers, security scanners) and which you actually use, set the permission to "Always Activate"
  • For all other plugins, set the permission to "Never Activate"

This change might not affect the current window, but should affect new windows (Ctrl+n) and all windows after exiting and starting Firefox up again.

Any improvement in the menus?

Sometimes having plugins set to "Ask to Activate" can cause odd user interface issues in the initial window, but if you launch a new window using Ctrl+n, the problems are not manifested there. Either way, you might want to review your plugin permissions. Open Firefox's Add-ons page using either: * Ctrl+Shift+a * "3-bar" menu button (or Tools menu) > Add-ons * in the Windows "Run" dialog, type or paste <br><code>firefox.exe "about:addons"</code> In the left column, click Plugins. This should display a list showing enabled plugins on top, and disabled plugins at the bottom. I suggest the following approach: * For media players like Shockwave Flash, Silverlight, and QuickTime, set the permission to "Ask to Activate" * For plugins that work in the background (e.g., password managers, security scanners) and which you actually use, set the permission to "Always Activate" * For all other plugins, set the permission to "Never Activate" This change might not affect the current window, but should affect new windows (Ctrl+n) and all windows after exiting and starting Firefox up again. Any improvement in the menus?

Umnikazi wombuzo

jscher2000 said

In case Firefox's program files got scrambled in the update, could you try: Clean Reinstall We use this name, but it's not about removing your settings, it's about making sure the program files are clean. As set forth below, this process does not disturb your existing settings. Do NOT uninstall Firefox, that's not needed. (1) Download a fresh installer for Firefox 37.0.2 from https://www.mozilla.org/firefox/all/ to a convenient location. (Scroll down to your preferred language.) (2) Exit out of Firefox (if applicable). (3) Rename the program folder (64-bit Windows folder names) C:\Program Files (x86)\Mozilla Firefox to C:\Program Files (x86)\OldFirefox (32-bit Windows folder names) C:\Program Files\Mozilla Firefox to C:\Program Files\OldFirefox (4) Run the installer you downloaded in #1. It should automatically connect to your existing settings. Any improvement? Note: Some plugins may exist only in that OldFirefox folder. If something essential is missing, look in these folders:
  • \OldFirefox\Plugins
  • \OldFirefox\browser\plugins

You're saying rename the program folder...what program folder? Pretend I'm inept at computers here. I just uninstalled Firefox completely and reinstalled it completely. Everything seems to be fine for now...but I haven't tried to do everything I was doing before. Netflix needs me to use Silverlight, for example. Things like that. I'll try now...

''jscher2000 [[#answer-723428|said]]'' <blockquote> In case Firefox's program files got scrambled in the update, could you try: '''Clean Reinstall''' We use this name, but it's not about removing your settings, it's about making sure the program files are clean. As set forth below, this process does not disturb your existing settings. Do NOT uninstall Firefox, that's not needed. (1) Download a fresh installer for Firefox 37.0.2 from https://www.mozilla.org/firefox/all/ to a convenient location. (Scroll down to your preferred language.) (2) Exit out of Firefox (if applicable). (3) Rename the program folder ''(64-bit Windows folder names)'' C:\Program Files (x86)\Mozilla Firefox to C:\Program Files (x86)\OldFirefox ''(32-bit Windows folder names)'' C:\Program Files\Mozilla Firefox to C:\Program Files\OldFirefox (4) Run the installer you downloaded in #1. It should automatically connect to your existing settings. Any improvement? Note: Some plugins may exist only in that OldFirefox folder. If something essential is missing, look in these folders: * \OldFirefox\Plugins * \OldFirefox\browser\plugins </blockquote> You're saying rename the program folder...what program folder? Pretend I'm inept at computers here. I just uninstalled Firefox completely and reinstalled it completely. Everything seems to be fine for now...but I haven't tried to do everything I was doing before. Netflix needs me to use Silverlight, for example. Things like that. I'll try now...
jscher2000
  • Top 10 Contributor
8792 izisombululo 71890 izimpendulo
Kuphostiwe

undies78 said

You're saying rename the program folder...what program folder?

It was the next line:

C:\Program Files (x86)\Mozilla Firefox

to

C:\Program Files (x86)\OldFirefox
''undies78 [[#answer-723433|said]]'' <blockquote> You're saying rename the program folder...what program folder? </blockquote> It was the next line: C:\Program Files (x86)\Mozilla Firefox to C:\Program Files (x86)\OldFirefox

Umnikazi wombuzo

jscher2000 said

undies78 said
You're saying rename the program folder...what program folder?

It was the next line:

C:\Program Files (x86)\Mozilla Firefox

Ok I did it that way, and I'm still having the same issues. And another thing I've noticed, when I close Firefox, it doesn't actually shut down. I have to go into Task Manager and select Firefox and then "end process"...

But when, in my email, I used to select "print" - a notice would pop up and say it couldn't print because the pop up window was blocked. But then you could "allow" it and try again, and it would open a separate window where you could print. Now, when I try to click on some things that used to open a separate window, there's NOTHING that comes up.

to

C:\Program Files (x86)\OldFirefox
''jscher2000 [[#answer-723452|said]]'' <blockquote> ''undies78 [[#answer-723433|said]]'' <blockquote> You're saying rename the program folder...what program folder? </blockquote> It was the next line: C:\Program Files (x86)\Mozilla Firefox Ok I did it that way, and I'm still having the same issues. And another thing I've noticed, when I close Firefox, it doesn't actually shut down. I have to go into Task Manager and select Firefox and then "end process"... But when, in my email, I used to select "print" - a notice would pop up and say it couldn't print because the pop up window was blocked. But then you could "allow" it and try again, and it would open a separate window where you could print. Now, when I try to click on some things that used to open a separate window, there's NOTHING that comes up. to C:\Program Files (x86)\OldFirefox </blockquote>
jscher2000
  • Top 10 Contributor
8792 izisombululo 71890 izimpendulo
Kuphostiwe

undies78 said

But when, in my email, I used to select "print" - a notice would pop up and say it couldn't print because the pop up window was blocked. But then you could "allow" it and try again, and it would open a separate window where you could print. Now, when I try to click on some things that used to open a separate window, there's NOTHING that comes up.

You can allow popups for Yahoo using the Page Info dialog. While viewing the message you want to print, you can open that using any of these methods:

  • right-click the page and choose View Page Info > Permissions
  • (menu bar) Tools > Page Info > Permissions
  • click the padlock or globe icon in the address bar > More Information > Permissions

Scroll down to the Open Pop-up Windows permission and uncheck the "Use default" checkbox and select Allow. Then you can close the dialog.

Can you get the print-formatted message window now?

undies78 said

And another thing I've noticed, when I close Firefox, it doesn't actually shut down. I have to go into Task Manager and select Firefox and then "end process"...

Firefox does take some time to update files. How long are you waiting? In recent versions of Firefox, if the program does not shut down in a reasonable amount of time, you should see the Mozilla Crash Reporter and you can report the "shutdown hang" to Mozilla. Have you ever seen that? This data is used to spot trends and prioritize fixes, and you should not expect a response to a crash report.

''undies78 [[#answer-723634|said]]'' <blockquote> But when, in my email, I used to select "print" - a notice would pop up and say it couldn't print because the pop up window was blocked. But then you could "allow" it and try again, and it would open a separate window where you could print. Now, when I try to click on some things that used to open a separate window, there's NOTHING that comes up.</blockquote> You can allow popups for Yahoo using the Page Info dialog. While viewing the message you want to print, you can open that using any of these methods: * right-click the page and choose View Page Info > Permissions * (menu bar) Tools > Page Info > Permissions * click the padlock or globe icon in the address bar > More Information > Permissions Scroll down to the Open Pop-up Windows permission and uncheck the "Use default" checkbox and select Allow. Then you can close the dialog. Can you get the print-formatted message window now? ''undies78 [[#answer-723634|said]]'' <blockquote> And another thing I've noticed, when I close Firefox, it doesn't actually shut down. I have to go into Task Manager and select Firefox and then "end process"...</blockquote> Firefox does take some time to update files. How long are you waiting? In recent versions of Firefox, if the program does not shut down in a reasonable amount of time, you should see the Mozilla Crash Reporter and you can report the "shutdown hang" to Mozilla. Have you ever seen that? This data is used to spot trends and prioritize fixes, and you should not expect a response to a crash report.

Umnikazi wombuzo

jscher2000 said

undies78 said
But when, in my email, I used to select "print" - a notice would pop up and say it couldn't print because the pop up window was blocked. But then you could "allow" it and try again, and it would open a separate window where you could print. Now, when I try to click on some things that used to open a separate window, there's NOTHING that comes up.

You can allow popups for Yahoo using the Page Info dialog. While viewing the message you want to print, you can open that using any of these methods:

  • right-click the page and choose View Page Info > Permissions
  • (menu bar) Tools > Page Info > Permissions
  • click the padlock or globe icon in the address bar > More Information > Permissions

Scroll down to the Open Pop-up Windows permission and uncheck the "Use default" checkbox and select Allow. Then you can close the dialog.

Can you get the print-formatted message window now?

undies78 said

And another thing I've noticed, when I close Firefox, it doesn't actually shut down. I have to go into Task Manager and select Firefox and then "end process"...

Firefox does take some time to update files. How long are you waiting? In recent versions of Firefox, if the program does not shut down in a reasonable amount of time, you should see the Mozilla Crash Reporter and you can report the "shutdown hang" to Mozilla. Have you ever seen that? This data is used to spot trends and prioritize fixes, and you should not expect a response to a crash report.

For the first part, I tried ALL THREE options, and the "open pop-up windows" thing was already ON "allow". It still does nothing when I select PRINT.

And for the second part, yes, it's an unreasonable time. I've gotten MANY crash messages in the past, for all different things. Sometimes I go days without them, sometimes I get 3/4 a day. It's just when I close Firefox (X out of the top right) and then go to open it 5-10 minutes later, nothing happens when I double-click the icon on the desktop or in the start menu. I have to go into Task Manager, find the "firefox.exe" process, and select "end process now". Then I can open Firefox again.

Any other options? Everything used to work fine, and now it seems like nothing does...

''jscher2000 [[#answer-723640|said]]'' <blockquote> ''undies78 [[#answer-723634|said]]'' <blockquote> But when, in my email, I used to select "print" - a notice would pop up and say it couldn't print because the pop up window was blocked. But then you could "allow" it and try again, and it would open a separate window where you could print. Now, when I try to click on some things that used to open a separate window, there's NOTHING that comes up.</blockquote> You can allow popups for Yahoo using the Page Info dialog. While viewing the message you want to print, you can open that using any of these methods: * right-click the page and choose View Page Info > Permissions * (menu bar) Tools > Page Info > Permissions * click the padlock or globe icon in the address bar > More Information > Permissions Scroll down to the Open Pop-up Windows permission and uncheck the "Use default" checkbox and select Allow. Then you can close the dialog. Can you get the print-formatted message window now? ''undies78 [[#answer-723634|said]]'' <blockquote> And another thing I've noticed, when I close Firefox, it doesn't actually shut down. I have to go into Task Manager and select Firefox and then "end process"...</blockquote> Firefox does take some time to update files. How long are you waiting? In recent versions of Firefox, if the program does not shut down in a reasonable amount of time, you should see the Mozilla Crash Reporter and you can report the "shutdown hang" to Mozilla. Have you ever seen that? This data is used to spot trends and prioritize fixes, and you should not expect a response to a crash report. </blockquote> For the first part, I tried ALL THREE options, and the "open pop-up windows" thing was already ON "allow". It still does nothing when I select PRINT. And for the second part, yes, it's an unreasonable time. I've gotten MANY crash messages in the past, for all different things. Sometimes I go days without them, sometimes I get 3/4 a day. It's just when I close Firefox (X out of the top right) and then go to open it 5-10 minutes later, nothing happens when I double-click the icon on the desktop or in the start menu. I have to go into Task Manager, find the "firefox.exe" process, and select "end process now". Then I can open Firefox again. Any other options? Everything used to work fine, and now it seems like nothing does...
jscher2000
  • Top 10 Contributor
8792 izisombululo 71890 izimpendulo
Kuphostiwe

Impendulo Ewusizo

Hi undies78, for the Flash crash in your screen shot, I'll list some common Flash troubleshooting suggestions further down in this reply.

For the Yahoo! print problem, it sounds as though the built-in popup blocker is not the problem. Next potential issues would be:

(1) Add-on popup blocker (2) Something else blocking the new or the window.open() script command on Yahoo (3) Other brokenness

For #1, I didn't see any in your original "More System Details" but if anything has changed, you may want to check on that.

For #2, could you do a plugin permission review? Some plugins that work in the background may not work well with the default permission of "Ask to Activate". Could you modify your plugin permission settings as follows:

Open the Add-ons page using either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or page about:addons in the address bar and press Enter

In the left column, click Plugins. On the right side:

For any unknown plugins, or ones that you do not commonly use, change the setting to "Never Activate".

For in-page content players that you use regularly, set to "Ask to Activate". For example:

  • Silverlight
  • Shockwave Flash

For global plugins that work in the background, such as security-related plugins, set to "Always Activate".

If in doubt, set to "Never Activate".

This change may not affect the current window, but should affect new windows (you can use Ctrl+n to launch a new window).

For #3, I would have you look for error messages in the Browser Console, but more on that in a later reply if needed.


This is some standard guidance that addresses the most common issues with the Flash Player plugin. I'm sure you've seen some of it before, but just in case:

(1) If you have any recorders/downloaders that interact with Flash media make sure they are as up-to-date as possible, or disable them temporarily.

(2) Disable hardware acceleration in Firefox and in Flash

(A) In Firefox, un-check the box here:

"3-bar" menu button (or Tools menu) > Options > Advanced > General > "Use hardware acceleration when available"

That takes effect the next time you exit and start Firefox up again.

(B) In Flash, right-click the media and choose Settings, then the first mini-tab and uncheck the box to use hardware acceleration. More information in this support article from Adobe: http://helpx.adobe.com/flash-player/kb/video-playback-issues.html#main_Solve_video_playback_issues

(3) Disable protected mode (Windows Vista and higher)

The protected mode feature of the Flash player plugin has security benefits, but seems to have compatibility issues on some systems. There is a new hidden setting for this:

(A) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(B) In the search box above the list, type or paste flash and pause while the list is filtered

(C) Double-click the dom.ipc.plugins.flash.disable-protected-mode preference to switch its value from false to true.

This might not take effect until all Flash has been unloaded for a few minutes, or you close Firefox.

Any improvement in the frequency of Flash crashes?

Hi undies78, for the Flash crash in your screen shot, I'll list some common Flash troubleshooting suggestions further down in this reply. For the Yahoo! print problem, it sounds as though the built-in popup blocker is not the problem. Next potential issues would be: (1) Add-on popup blocker (2) Something else blocking the new or the window.open() script command on Yahoo (3) Other brokenness For #1, I didn't see any in your original "More System Details" but if anything has changed, you may want to check on that. For #2, could you do a plugin permission review? Some plugins that work in the background may not work well with the default permission of "Ask to Activate". Could you modify your plugin permission settings as follows: Open the Add-ons page using either: * Ctrl+Shift+a * "3-bar" menu button (or Tools menu) > Add-ons * type or page about:addons in the address bar and press Enter In the left column, click Plugins. On the right side: For any unknown plugins, or ones that you do not commonly use, change the setting to "Never Activate". For in-page content players that you use regularly, set to "Ask to Activate". For example: * Silverlight * Shockwave Flash For global plugins that work in the background, such as security-related plugins, set to "Always Activate". If in doubt, set to "Never Activate". This change may not affect the current window, but should affect new windows (you can use Ctrl+n to launch a new window). For #3, I would have you look for error messages in the Browser Console, but more on that in a later reply if needed. ---- This is some standard guidance that addresses the most common issues with the Flash Player plugin. I'm sure you've seen some of it before, but just in case: (1) If you have any recorders/downloaders that interact with Flash media make sure they are as up-to-date as possible, or disable them temporarily. (2) Disable hardware acceleration in Firefox and in Flash (A) In Firefox, un-check the box here: "3-bar" menu button (or Tools menu) > Options > Advanced > General > "Use hardware acceleration when available" That takes effect the next time you exit and start Firefox up again. (B) In Flash, right-click the media and choose Settings, then the first mini-tab and uncheck the box to use hardware acceleration. More information in this support article from Adobe: http://helpx.adobe.com/flash-player/kb/video-playback-issues.html#main_Solve_video_playback_issues (3) Disable protected mode (Windows Vista and higher) The protected mode feature of the Flash player plugin has security benefits, but seems to have compatibility issues on some systems. There is a new hidden setting for this: (A) In a new tab, type or paste '''about:config''' in the address bar and press Enter. Click the button promising to be careful. (B) In the search box above the list, type or paste '''flash''' and pause while the list is filtered (C) Double-click the '''dom.ipc.plugins.flash.disable-protected-mode''' preference to switch its value from false to true. This might not take effect until all Flash has been unloaded for a few minutes, or you close Firefox. Any improvement in the frequency of Flash crashes?

Umnikazi wombuzo

No Flash crashes in a while...but if it happens again, I'll try the steps you mentioned.

As for the Plug-Ins, I recognize pretty much all of them. I took a screenshot of them so you could see what might be causing an issue - one of them says it "may be vulnerable" or something...?

No Flash crashes in a while...but if it happens again, I'll try the steps you mentioned. As for the Plug-Ins, I recognize pretty much all of them. I took a screenshot of them so you could see what might be causing an issue - one of them says it "may be vulnerable" or something...?
jscher2000
  • Top 10 Contributor
8792 izisombululo 71890 izimpendulo
Kuphostiwe

Hi undies78, plugins like SimplePass will work best when set to "Always Activate" since they work in the background and do not interact well with Firefox's plugin notification system (the icon on the address bar that looks like a Lego block). I don't know what Intel Identity Protection is, but that one also probably should not be set to "Ask to Activate" for the same reason. If there are plugins you don't normally use in a week, you can set those to "Never Activate" to see whether that has any effect.

Hi undies78, plugins like SimplePass will work best when set to "Always Activate" since they work in the background and do not interact well with Firefox's plugin notification system (the icon on the address bar that looks like a Lego block). I don't know what Intel Identity Protection is, but that one also probably should not be set to "Ask to Activate" for the same reason. If there are plugins you don't normally use in a week, you can set those to "Never Activate" to see whether that has any effect.

Umnikazi wombuzo

jscher2000 said

Hi undies78, plugins like SimplePass will work best when set to "Always Activate" since they work in the background and do not interact well with Firefox's plugin notification system (the icon on the address bar that looks like a Lego block). I don't know what Intel Identity Protection is, but that one also probably should not be set to "Ask to Activate" for the same reason. If there are plugins you don't normally use in a week, you can set those to "Never Activate" to see whether that has any effect.

I will try some of those. The main thing is that I can't click ANY things that open other windows. NONE open. My bank website, I used to click this thing that would open my statement in another window - that link does nothing. Even if I'm watching a Youtube video, the button in the bottom right of the video that would allow you to view the video in full screen, that doesn't work anymore either. Everything for Pop Up Blocker is set to allow, etc. I don't know what else to do! How can I get Firefox working normally again - why would it just stop working like this? I'm thinking I'll need to change to Chrome or something now, which is annoying but Firefox has been great for years and now...idk what's wrong.

''jscher2000 [[#answer-726121|said]]'' <blockquote> Hi undies78, plugins like SimplePass will work best when set to "Always Activate" since they work in the background and do not interact well with Firefox's plugin notification system (the icon on the address bar that looks like a Lego block). I don't know what Intel Identity Protection is, but that one also probably should not be set to "Ask to Activate" for the same reason. If there are plugins you don't normally use in a week, you can set those to "Never Activate" to see whether that has any effect. </blockquote> I will try some of those. The main thing is that I can't click ANY things that open other windows. NONE open. My bank website, I used to click this thing that would open my statement in another window - that link does nothing. Even if I'm watching a Youtube video, the button in the bottom right of the video that would allow you to view the video in full screen, that doesn't work anymore either. Everything for Pop Up Blocker is set to allow, etc. I don't know what else to do! How can I get Firefox working normally again - why would it just stop working like this? I'm thinking I'll need to change to Chrome or something now, which is annoying but Firefox has been great for years and now...idk what's wrong.
jscher2000
  • Top 10 Contributor
8792 izisombululo 71890 izimpendulo
Kuphostiwe

Could you test the links on this page to see which, if any, work for you:

http://jeffersonscher.com/res/popit.html

The comments about default behavior assume that the top checkbox on the Tabs panel of the Options dialog is checked.


I noticed your original system information shows your three extensions are all disabled. Was that posted using Firefox's Safe Mode? If not, I suggest trying that to rule out some additional issues. Here's how:

Firefox's Safe Mode is a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: Troubleshoot Firefox issues using Safe Mode.

If Firefox is not running: Hold down the Shift key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Do pop-up windows launch as expected in Safe Mode?

Could you test the links on this page to see which, if any, work for you: http://jeffersonscher.com/res/popit.html The comments about default behavior assume that the top checkbox on the Tabs panel of the Options dialog is checked. ---- I noticed your original system information shows your three extensions are all disabled. Was that posted using Firefox's Safe Mode? If not, I suggest trying that to rule out some additional issues. Here's how: Firefox's Safe Mode is a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: [[Troubleshoot Firefox issues using Safe Mode]]. ''If Firefox is not running:'' Hold down the Shift key when starting Firefox. ''If Firefox is running:'' You can restart Firefox in Safe Mode using either: * "3-bar" menu button > "?" button > Restart with Add-ons Disabled * Help menu > Restart with Add-ons Disabled and OK the restart. ''Both scenarios:'' A small dialog should appear. Click "Start in Safe Mode" (''not'' Refresh). Do pop-up windows launch as expected in Safe Mode?

Umnikazi wombuzo

jscher2000 said

Could you test the links on this page to see which, if any, work for you: http://jeffersonscher.com/res/popit.html The comments about default behavior assume that the top checkbox on the Tabs panel of the Options dialog is checked.

I noticed your original system information shows your three extensions are all disabled. Was that posted using Firefox's Safe Mode? If not, I suggest trying that to rule out some additional issues. Here's how:

Firefox's Safe Mode is a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: Troubleshoot Firefox issues using Safe Mode.

If Firefox is not running: Hold down the Shift key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Do pop-up windows launch as expected in Safe Mode?

Ok, so a few things. For one, on those 3 links that you gave me to try out, the first two opened in a separate tab, as they stated. The third one, which was supposed to open in a new window, did nothing. Click on it, nothing happens.

Second, when I go to "3-bar" menu button > "?" button > Restart with Add-ons Disabled" - once I click on the 3 bar menu button, and then click on the ? - that entire menu is blank. It's just empty, and there's nothing to click on. It's like a white sheet of paper slides out. So I'll try holding down shift and opening Firefox again, and let you know what happens...

EDIT >>>>>

Restarted in safe mode, went into email, pulled down to "Print" and again - nothing happens.

Side note, when I X out of Firefox, I still have to go into Task Manager to "end process" so it will actually close down. Then when I open it, it always tries to restore the last pages I had open. Took a screenshot when I restarted in normal mode, after the safe mode didn't work. This is what it said when I had to "end process" then tried to reopen Firefox:

''jscher2000 [[#answer-726318|said]]'' <blockquote> Could you test the links on this page to see which, if any, work for you: http://jeffersonscher.com/res/popit.html The comments about default behavior assume that the top checkbox on the Tabs panel of the Options dialog is checked. ---- I noticed your original system information shows your three extensions are all disabled. Was that posted using Firefox's Safe Mode? If not, I suggest trying that to rule out some additional issues. Here's how: Firefox's Safe Mode is a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: [[Troubleshoot Firefox issues using Safe Mode]]. ''If Firefox is not running:'' Hold down the Shift key when starting Firefox. ''If Firefox is running:'' You can restart Firefox in Safe Mode using either: * "3-bar" menu button > "?" button > Restart with Add-ons Disabled * Help menu > Restart with Add-ons Disabled and OK the restart. ''Both scenarios:'' A small dialog should appear. Click "Start in Safe Mode" (''not'' Refresh). Do pop-up windows launch as expected in Safe Mode? </blockquote> Ok, so a few things. For one, on those 3 links that you gave me to try out, the first two opened in a separate tab, as they stated. The third one, which was supposed to open in a new window, did nothing. Click on it, nothing happens. Second, when I go to "3-bar" menu button > "?" button > Restart with Add-ons Disabled" - once I click on the 3 bar menu button, and then click on the ? - that entire menu is blank. It's just empty, and there's nothing to click on. It's like a white sheet of paper slides out. So I'll try holding down shift and opening Firefox again, and let you know what happens... EDIT >>>>> Restarted in safe mode, went into email, pulled down to "Print" and again - nothing happens. Side note, when I X out of Firefox, I still have to go into Task Manager to "end process" so it will actually close down. Then when I open it, it always tries to restore the last pages I had open. Took a screenshot when I restarted in normal mode, after the safe mode didn't work. This is what it said when I had to "end process" then tried to reopen Firefox:

Okulungisiwe ngu undies78

cor-el
  • Top 10 Contributor
  • Moderator
17573 izisombululo 158948 izimpendulo
Kuphostiwe

Do a clean reinstall and delete the Firefox program folder before (re)installing a fresh copy of the current Firefox release.

If possible uninstall your current Firefox version to cleanup the Windows registry and settings in security software.

  • Do NOT remove "personal data" when you uninstall your current Firefox version, because this will remove all profile folders and you lose personal data like bookmarks and passwords including data in profiles created by other Firefox versions.

Remove the Firefox program folder before installing that newly downloaded copy of the Firefox installer.

  • (32 bit Windows) "C:\Program Files\Mozilla Firefox\"
  • (64 bit Windows) "C:\Program Files (x86)\Mozilla Firefox\"

Your bookmarks and other personal data are stored in the Firefox profile folder and won't be affected by an uninstall and (re)install, but make sure NOT to remove personal data when you uninstall Firefox as that will remove all Firefox profile folders and you lose your personal data.

If you keep having problems then also create a new profile.


Do a clean reinstall and delete the Firefox program folder before (re)installing a fresh copy of the current Firefox release. *Download the Firefox installer and save the file to the desktop<br>https://www.mozilla.org/en-US/firefox/all/ If possible uninstall your current Firefox version to cleanup the Windows registry and settings in security software. *Do NOT remove "personal data" when you uninstall your current Firefox version, because this will remove all profile folders and you lose personal data like bookmarks and passwords including data in profiles created by other Firefox versions. Remove the Firefox program folder before installing that newly downloaded copy of the Firefox installer. *(32 bit Windows) "C:\Program Files\Mozilla Firefox\" *(64 bit Windows) "C:\Program Files (x86)\Mozilla Firefox\" *It is important to delete the Firefox program folder to remove all the files and make sure that there are no problems with files that were leftover after uninstalling. *http://kb.mozillazine.org/Uninstalling_Firefox Your bookmarks and other personal data are stored in the Firefox profile folder and won't be affected by an uninstall and (re)install, but make sure NOT to remove personal data when you uninstall Firefox as that will remove all Firefox profile folders and you lose your personal data. If you keep having problems then also create a new profile. ---- *http://kb.mozillazine.org/Profile_folder_-_Firefox *http://kb.mozillazine.org/Profile_backup *http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Clean_reinstall

Umnikazi wombuzo

cor-el said

Do a clean reinstall and delete the Firefox program folder before (re)installing a fresh copy of the current Firefox release. If possible uninstall your current Firefox version to cleanup the Windows registry and settings in security software.
  • Do NOT remove "personal data" when you uninstall your current Firefox version, because this will remove all profile folders and you lose personal data like bookmarks and passwords including data in profiles created by other Firefox versions.
Remove the Firefox program folder before installing that newly downloaded copy of the Firefox installer.
  • (32 bit Windows) "C:\Program Files\Mozilla Firefox\"
  • (64 bit Windows) "C:\Program Files (x86)\Mozilla Firefox\"
Your bookmarks and other personal data are stored in the Firefox profile folder and won't be affected by an uninstall and (re)install, but make sure NOT to remove personal data when you uninstall Firefox as that will remove all Firefox profile folders and you lose your personal data. If you keep having problems then also create a new profile.

So I tried that, and YAY! I can print! But now, I can't open a new tab. I can click on something and select "open link in new tab" and that will open a new tab, but if I go up to the top and click on the "+" symbol, nothing happens now - no tabs open.

Also, when I go into the 3-bar menu now and select "Options", nothing happens/opens. In addition, the "?" does nothing, either. So I can't go into options and I can't go to help.

So...I've traded one problem for two new ones by doing a complete reinstall.

''cor-el [[#answer-726394|said]]'' <blockquote> Do a clean reinstall and delete the Firefox program folder before (re)installing a fresh copy of the current Firefox release. *Download the Firefox installer and save the file to the desktop<br>https://www.mozilla.org/en-US/firefox/all/ If possible uninstall your current Firefox version to cleanup the Windows registry and settings in security software. *Do NOT remove "personal data" when you uninstall your current Firefox version, because this will remove all profile folders and you lose personal data like bookmarks and passwords including data in profiles created by other Firefox versions. Remove the Firefox program folder before installing that newly downloaded copy of the Firefox installer. *(32 bit Windows) "C:\Program Files\Mozilla Firefox\" *(64 bit Windows) "C:\Program Files (x86)\Mozilla Firefox\" *It is important to delete the Firefox program folder to remove all the files and make sure that there are no problems with files that were leftover after uninstalling. *http://kb.mozillazine.org/Uninstalling_Firefox Your bookmarks and other personal data are stored in the Firefox profile folder and won't be affected by an uninstall and (re)install, but make sure NOT to remove personal data when you uninstall Firefox as that will remove all Firefox profile folders and you lose your personal data. If you keep having problems then also create a new profile. ---- *http://kb.mozillazine.org/Profile_folder_-_Firefox *http://kb.mozillazine.org/Profile_backup *http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Clean_reinstall </blockquote> So I tried that, and YAY! I can print! But now, I can't open a new tab. I can click on something and select "open link in new tab" and that will open a new tab, but if I go up to the top and click on the "+" symbol, nothing happens now - no tabs open. Also, when I go into the 3-bar menu now and select "Options", nothing happens/opens. In addition, the "?" does nothing, either. So I can't go into options and I can't go to help. So...I've traded one problem for two new ones by doing a complete reinstall.

Okulungisiwe ngu undies78

cor-el
  • Top 10 Contributor
  • Moderator
17573 izisombululo 158948 izimpendulo
Kuphostiwe

Do you still have extensions installed and enabled?

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
Do you still have extensions installed and enabled? Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem. *Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance *Do NOT click the Reset button on the Safe Mode start window *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes

Umnikazi wombuzo

I restarted in Safe Mode.

I can open a new tab.

I CAN'T print again.

I CAN'T open the "help" section of the 3-Bar Menu - it's blank.

And again, when I close down Firefox (X out of it) it doesn't shut down. I had to go back into Task Manager, select Firefox and "end process" in order to shut down Firefox fully.

Does Firefox/Mozilla not have their own tech support team? I'm getting kinda frustrated here...

I restarted in Safe Mode. I can open a new tab. I CAN'T print again. I CAN'T open the "help" section of the 3-Bar Menu - it's blank. And again, when I close down Firefox (X out of it) it doesn't shut down. I had to go back into Task Manager, select Firefox and "end process" in order to shut down Firefox fully. Does Firefox/Mozilla not have their own tech support team? I'm getting kinda frustrated here...

Okulungisiwe ngu undies78

jscher2000
  • Top 10 Contributor
8792 izisombululo 71890 izimpendulo
Kuphostiwe

It's a volunteer support team!

If Firefox crashes, it is normal that it tries to restore the previous session.

Do you often see that Windows crash dialog referring to Plugin Container? The most commonly used plugin is Flash, so if you see that more than once or twice a month, here is some standard guidance that addresses the most common issues with the Flash Player plugin. I'm sure you've seen some of it before, but just in case:

(1) If you have any recorders/downloaders that interact with Flash media make sure they are as up-to-date as possible, or disable them temporarily.

(2) Disable hardware acceleration in Firefox and in Flash

(A) In Firefox, un-check the box here:

"3-bar" menu button (or Tools menu) > Options > Advanced > General > "Use hardware acceleration when available"

That takes effect the next time you exit and start Firefox up again.

(B) In Flash, right-click the media and choose Settings, then the first mini-tab and uncheck the box to use hardware acceleration. More information in this support article from Adobe: http://helpx.adobe.com/flash-player/kb/video-playback-issues.html#main_Solve_video_playback_issues

(3) Disable protected mode (Windows Vista and higher)

The protected mode feature of the Flash player plugin has security benefits, but seems to have compatibility issues on some systems. There is a new hidden setting for this:

(A) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(B) In the search box above the list, type or paste flash and pause while the list is filtered

(C) Double-click the dom.ipc.plugins.flash.disable-protected-mode preference to switch its value from false to true.

This might not take effect until all Flash has been unloaded for a few minutes, or you close Firefox.


The clean reinstall strips alien and inconsistent files from Firefox's program folders. The fact that this was partially successful at first suggests that some process might be tampering with that folder. Have you considered running some supplemental malware scans? Our support article lists tools other Firefox users have found helpful: Troubleshoot Firefox issues caused by malware. Those programs are generally free and take considerable time to run. If they seem to finish quickly and especially if they indicate you need to pay for cleaning, your computer may have a serious infection. The specialized forums listed in the article would be a good next step in that case.

It's a volunteer support team! If Firefox crashes, it is normal that it tries to restore the previous session. Do you often see that Windows crash dialog referring to Plugin Container? The most commonly used plugin is Flash, so if you see that more than once or twice a month, here is some standard guidance that addresses the most common issues with the Flash Player plugin. I'm sure you've seen some of it before, but just in case: (1) If you have any recorders/downloaders that interact with Flash media make sure they are as up-to-date as possible, or disable them temporarily. (2) Disable hardware acceleration in Firefox and in Flash (A) In Firefox, un-check the box here: "3-bar" menu button (or Tools menu) > Options > Advanced > General > "Use hardware acceleration when available" That takes effect the next time you exit and start Firefox up again. (B) In Flash, right-click the media and choose Settings, then the first mini-tab and uncheck the box to use hardware acceleration. More information in this support article from Adobe: http://helpx.adobe.com/flash-player/kb/video-playback-issues.html#main_Solve_video_playback_issues (3) Disable protected mode (Windows Vista and higher) The protected mode feature of the Flash player plugin has security benefits, but seems to have compatibility issues on some systems. There is a new hidden setting for this: (A) In a new tab, type or paste '''about:config''' in the address bar and press Enter. Click the button promising to be careful. (B) In the search box above the list, type or paste '''flash''' and pause while the list is filtered (C) Double-click the '''dom.ipc.plugins.flash.disable-protected-mode''' preference to switch its value from false to true. This might not take effect until all Flash has been unloaded for a few minutes, or you close Firefox. ---- The clean reinstall strips alien and inconsistent files from Firefox's program folders. The fact that this was partially successful at first suggests that some process might be tampering with that folder. Have you considered running some supplemental malware scans? Our support article lists tools other Firefox users have found helpful: [[Troubleshoot Firefox issues caused by malware]]. Those programs are generally free and take considerable time to run. If they seem to finish quickly and especially if they indicate you need to pay for cleaning, your computer may have a serious infection. The specialized forums listed in the article would be a good next step in that case.