X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Thunderbird crashes on startup. Probably Hardware Acceleration with nvdia graphics

Kuphostiwe

Even fresh new Thunderbird profile crashes on startup. Thunderbird starts ok in safe-mode (new and all profile/s).

Ideas, suggestions pls?

Win7, v31.1.1

Crash report ID: bp-04e7adc1-d92e-4d51-9938-200662140922

Even fresh new Thunderbird profile crashes on startup. Thunderbird starts ok in safe-mode (new and all profile/s). Ideas, suggestions pls? Win7, v31.1.1 Crash report ID: bp-04e7adc1-d92e-4d51-9938-200662140922

Okulungisiwe ngu Wayne Mery

Isisombululo esikhethiwe

Hi Matt,

thanks for your suggestion. Previously I have tried to downgrade couple versions back (forgot to mention it in the initial post) occasionally TB have started ok but most of the times it crashed...

Working solution I have found meanwhile => 64 bit TB http://www.mozilla64bit.com/index.php/thunderbird-64-bit-download

Still do not know what could be possibly causing this issue but HW acceleration is definitely worth a try. Will try to disable it the day I decide to go back to 32 bit.

Resolved...

Funda le mpendulo ngokuhambisana nalesi sihloko 0

Eminye Imininingwane Yohlelo

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:32.0) Gecko/20100101 Firefox/32.0 Waterfox/32.0

Eminye Imininingwane

Toad-Hall
  • Top 10 Contributor
1842 izisombululo 12429 izimpendulo
Kuphostiwe

If starting Thunderbird in safe mode is ok, then you probably have an addon which is causing a conflict.

You need to disable all the addon extensions and then enable one at a time and test to see which one causes the issue.

there may be an addon which needs updating.

If starting Thunderbird in safe mode is ok, then you probably have an addon which is causing a conflict. You need to disable all the addon extensions and then enable one at a time and test to see which one causes the issue. there may be an addon which needs updating.

Impendulo Ewusizo

Hi Toad-Hall,

as indicated in the crash report there are no addons used. Additionally the problem persists even if I create new profile ("-p" parameter => create new profile).

Hi Toad-Hall, as indicated in the crash report there are no addons used. Additionally the problem persists even if I create new profile ("-p" parameter => create new profile).
Matt
  • Top 10 Contributor
  • Moderator
3364 izisombululo 23314 izimpendulo
Kuphostiwe

Given that hardware acceleration was again turned on in V31 ( it was something of a hit and miss mess last time) and the fact the crashing DLL is part of the nVidia developer toolkit that might be the issue here.

Please, I am going to suggest you edit the prefs.js file in notepad. Make a backup copy before we start just to be sure. It is not meant to be edited outside Thunderbird really, even though it is a text file.

I will assume if your up on creating profiles you can find your profile (if not speak up)

open the prefs.js file in notepad and add the following at the beginning

after this block and a blank line

# Mozilla User Preferences
/* Do not edit this file.
 *
 * If you make changes to this file while the application is running,
 * the changes will be overwritten when the application exits.
 *
 * To make a manual change to preferences, you can visit the URL about:config
 */

user_pref("gfx.direct2d.disabled", true);

save and close the file Try and start Thunderbird.

Given that hardware acceleration was again turned on in V31 ( it was something of a hit and miss mess last time) and the fact the crashing DLL is part of the nVidia developer toolkit that might be the issue here. Please, I am going to suggest you edit the prefs.js file in notepad. Make a backup copy before we start just to be sure. It is not meant to be edited outside Thunderbird really, even though it is a text file. I will assume if your up on creating profiles you can find your profile (if not speak up) open the prefs.js file in notepad and add the following at the beginning after this block and a blank line # Mozilla User Preferences /* Do not edit this file. * * If you make changes to this file while the application is running, * the changes will be overwritten when the application exits. * * To make a manual change to preferences, you can visit the URL about:config */ user_pref("gfx.direct2d.disabled", true); save and close the file Try and start Thunderbird.

Isisombululo Esikhethiwe

Hi Matt,

thanks for your suggestion. Previously I have tried to downgrade couple versions back (forgot to mention it in the initial post) occasionally TB have started ok but most of the times it crashed...

Working solution I have found meanwhile => 64 bit TB http://www.mozilla64bit.com/index.php/thunderbird-64-bit-download

Still do not know what could be possibly causing this issue but HW acceleration is definitely worth a try. Will try to disable it the day I decide to go back to 32 bit.

Resolved...

Hi Matt, thanks for your suggestion. Previously I have tried to downgrade couple versions back (forgot to mention it in the initial post) occasionally TB have started ok but most of the times it crashed... Working solution I have found meanwhile => 64 bit TB http://www.mozilla64bit.com/index.php/thunderbird-64-bit-download Still do not know what could be possibly causing this issue but HW acceleration is definitely worth a try. Will try to disable it the day I decide to go back to 32 bit. Resolved...
Toad-Hall
  • Top 10 Contributor
1842 izisombululo 12429 izimpendulo
Kuphostiwe

I know you are ok, but Just had a thought:

when you downloaded and installed the standard (not 64 bit) Thunderbird, did you install it in : C:\Program Files\Mozilla Thunderbird\thunderbird.exe  ? or C:\Program Files(86)\Mozilla Thunderbird\thunderbird.exe  ?

this would be the correct place for a 64 bit Windows.

  • C:\Program Files(86)\Mozilla Thunderbird\thunderbird.exe
I know you are ok, but Just had a thought: when you downloaded and installed the standard (not 64 bit) Thunderbird, did you install it in : C:\Program Files\Mozilla Thunderbird\thunderbird.exe ? or C:\Program Files(86)\Mozilla Thunderbird\thunderbird.exe ? this would be the correct place for a 64 bit Windows. * C:\Program Files(86)\Mozilla Thunderbird\thunderbird.exe

Impendulo Ewusizo

Yes I have left the default destinations during the installation process => C:\Program Files (x86)\Mozilla Thunderbird

Yes I have left the default destinations during the installation process => C:\Program Files (x86)\Mozilla Thunderbird
hholmstr 0 izisombululo 3 izimpendulo
Kuphostiwe

I used Thunderbird for years without problems until I installed McAffe. Since then Thunderbird has been slow, crashing and almost useless, no matter what I tried. Yesterday I returned to Norman as virus protection, and voila: Thunderbird immediately returned to normal!

I used Thunderbird for years without problems until I installed McAffe. Since then Thunderbird has been slow, crashing and almost useless, no matter what I tried. Yesterday I returned to Norman as virus protection, and voila: Thunderbird immediately returned to normal!
Wayne Mery
  • Top 25 Contributor
  • Moderator
600 izisombululo 5743 izimpendulo
Kuphostiwe

> working solution I have found meanwhile => 64 bit TB http://www.mozilla64bit.com/index.php/thunderbird-64-bit-download

> Still do not know what could be possibly causing this issue but HW acceleration is definitely worth a try. Will try to disable it the day I decide to go back to 32 bit.

marjar,

Please try beta from http://www.mozilla.org/en-US/thunderbird/channel/ it offers a setting in Tools | options | advanced | general to disable hardware acceleration

> working solution I have found meanwhile => 64 bit TB http://www.mozilla64bit.com/index.php/thunderbird-64-bit-download > Still do not know what could be possibly causing this issue but HW acceleration is definitely worth a try. Will try to disable it the day I decide to go back to 32 bit. marjar, Please try beta from http://www.mozilla.org/en-US/thunderbird/channel/ it offers a setting in Tools | options | advanced | general to disable hardware acceleration