Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

I open Firefox ividi seems to have taken over as my home page, how can I change this? Has my computer been corrupted?

  • 3 uphendule
  • 9 zinale nkinga
  • 2711 views
  • Igcine ukuphendulwa ngu d.gingrich

more options

When I open Firefox, it opens to iVIDI home page. As far as I know I have never consented to this change. Why did this happen? Has my computer been corrupted? How can I delete this and continue to have firefox as my home page?

Isisombululo esikhethiwe

You can use the SearchReset extension to reset some preferences to the default values.

Note that the SearchReset extension only runs once and then uninstalls automatically, so it won't show on the "Firefox > Add-ons" page (about:addons).

Your System Details list shows that you have a user.js file in the profile folder to initialize prefs each time Firefox starts.

The user.js file is only present if you or other software has created this file and normally it wouldn't be there. You can check its content with a plain text editor (right-click: Open with) if you didn't create this file yourself.

The user.js file is read each time Firefox is started and initializes preferences to the value specified in this file, so preferences set via user.js can only be changed temporarily for the current session.

Delete a possible user.js file and numbered prefs-##.js files and rename (or delete) the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in the current Firefox release.

You can use this button to go to the currently used Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder)
Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (3)

more options

It could be the work of one of your add-ons, or even add / mal-ware. Look thru your add-ons list and make sure you know what each one is there for. Also, check the programs that are on your computer Go thru the list and use a web search to check any that you don't know what they are.

Troubleshoot Firefox Issues Caused By Malware {web link}

more options

Isisombululo Esikhethiwe

You can use the SearchReset extension to reset some preferences to the default values.

Note that the SearchReset extension only runs once and then uninstalls automatically, so it won't show on the "Firefox > Add-ons" page (about:addons).

Your System Details list shows that you have a user.js file in the profile folder to initialize prefs each time Firefox starts.

The user.js file is only present if you or other software has created this file and normally it wouldn't be there. You can check its content with a plain text editor (right-click: Open with) if you didn't create this file yourself.

The user.js file is read each time Firefox is started and initializes preferences to the value specified in this file, so preferences set via user.js can only be changed temporarily for the current session.

Delete a possible user.js file and numbered prefs-##.js files and rename (or delete) the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in the current Firefox release.

You can use this button to go to the currently used Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder)
more options

Thank you. I went with SearchReset extension and it restored my Mozilla as my home page Thank you