顯示問題標籤 顯示所有問題
  • 封存

Help! I'm over my honeymoon phase with HTML5 video - maybe we need plugin-container back?

After being puzzled by Firefox making it more difficult to use Adobe Flash Player and apparently being forcibly shown HTML5 I was geeking out and hoping it means Adobe Fl… (閱讀更多)

After being puzzled by Firefox making it more difficult to use Adobe Flash Player and apparently being forcibly shown HTML5 I was geeking out and hoping it means Adobe Flash Crasher is on its way into obsolescence and extinction. Although it looks ike Youtube's video quality has decreased, at least for now.

I hate Adobe Flash Player. while I'm sure its coding must be impressive IMO it is the worst video playing software ever. Slow, inconsistent, buggy, crashy, tricky. In my experience it can't do the one thing it exists to do very well: play .FLV files. The .FLV filetype is ok though and there are other programs like RealPlayer and VLC that can technically deal with it, but I guess Adobe doesn't want them meddling.

But now I'm seeing HTML5 is causing similar problems. After each time I rerun Firefox after an APPCRASH (they happen so regularly and predictably) I know it's just a matter of time until the next one. And the cause is almost always YouTube, running FireFox's memory up even when I don't have many tabs open. Then I start getting blotches of the black screen of death and I know that session is now in its death throes. Memory Fox and clearing cache may buy me another 45 minutes, tops.

Is there some way I can have my streamed media confined like we use to have it when FireFox was good and only the video would crash but not the whole application? I'm actually missing that now.

YoullSee 於 5 年前 詢問

guigs 最近回覆 於 5 年前

  • 封存

HTML5 loads slowly using Firefox 37.01

Anyone else noted that in Firefox 37.01 HTML5 loads annoyingly slowly and the loading keeps sticking several times: in FF36 YouTube video of 4 minutes would be loaded in … (閱讀更多)

Anyone else noted that in Firefox 37.01 HTML5 loads annoyingly slowly and the loading keeps sticking several times: in FF36 YouTube video of 4 minutes would be loaded in few seconds, in FF37.01 it takes half the videos length before loading fully.

kuopiofi 於 5 年前 詢問

FredMcD 最近回覆 於 5 年前

  • 封存

Poor YouTube HTML5 video performance in Firefox - fine in IE

I have a quite low end system set up, so I'm not expecting miracles from it, but there seems to be some problems playing Youtube videos on Firefox. If I load a video on … (閱讀更多)

I have a quite low end system set up, so I'm not expecting miracles from it, but there seems to be some problems playing Youtube videos on Firefox.

If I load a video on Internet Explorer, it will play fine, even on 1080p with CPU usage of about 20%. Firefox often exhibits problems playing videos.

If I launch Firefox immediately from signing in, the videos will play fine. If I navigate to another video, there will usually be dropped frames and high CPU usage.

I understand that Internet Explorer will use the h.264 codec which is GPU accelerated whilst FF will use a more CPU intense task, but that doesn't really explain why sometimes the videos will play fine and others, it won't.

I have tried on a completely clean install of Firefox, so it will unlikely be extensions, profiles or add-ons. I have then changed the timing of the sessions saving and disabled smooth scrolling as advised elsewhere, with no success.

All help gratefully received.

optomo84 於 5 年前 詢問

TheCheetahwings 最近回覆 於 5 年前

  • 封存

Can't put HTML5 Youtube to Fullscreen without Firefox Crashing.

Every time I attempt to put Youtube into Fullscreen mode Firefox crashes. The only add-on I have is U Block. I've already run a fresh install of Firefox, and it still c… (閱讀更多)

Every time I attempt to put Youtube into Fullscreen mode Firefox crashes. The only add-on I have is U Block. I've already run a fresh install of Firefox, and it still crashes upon trying to fullscreen. I am running Yosemite on a Macbook Pro 2010. Youtube works fine in the Safari browser, and all other video types (Silverlight for Netflix) work fine on Firefox.

williawr11 於 5 年前 詢問

FredMcD 最近回覆 於 5 年前

  • 封存

I use GNU/Linux, and Adobe has crippled flash for Linux, so sometimes flash won't work; What is the best plugin to make use of html5?

I have tried Flash Control, HTML5 Everywhere, Flash Block, Shumway and so far none are doing what I want or are very intuitive. I am grateful that Mozilla is developing h… (閱讀更多)

I have tried Flash Control, HTML5 Everywhere, Flash Block, Shumway and so far none are doing what I want or are very intuitive. I am grateful that Mozilla is developing html5 to replace unsafe flash. Adobe appears to be working with Microsoft and Google to force older computers into the trash pile that do not have sse2 instruction, force issues onto GNU/Linux users by not fully supporting flash, and also making Firefox appear to have "performance issues" to coerce people into using less secure browsers like Chrome or IE.

Is there a simple and obvious way to choose to use my older version of flash or HTML5, depending on the web site? What plugin is best?

LongTimeMozillaUser 於 5 年前 詢問

FredMcD 最近回覆 於 5 年前

  • 封存

How to manage HTML5 in-built plugin?

I want to keep it disabled like Flash player unless I asked to "allow plugin" and second this is it buffers full length video occupying and sometimes wasting bandwidth. H… (閱讀更多)

I want to keep it disabled like Flash player unless I asked to "allow plugin" and second this is it buffers full length video occupying and sometimes wasting bandwidth. How to manage both?

Eshant 於 5 年前 詢問

the-edmeister 最近回覆 於 5 年前

  • 封存

Can I kill HTML5 video process?

My PC becomes unresponsive after several days without a reboot. I open several tabs and use Facebook, watch YouTube videos, and read worthless Yahoo news. Ever since HT… (閱讀更多)

My PC becomes unresponsive after several days without a reboot. I open several tabs and use Facebook, watch YouTube videos, and read worthless Yahoo news. Ever since HTML5 videos have replaced Flash, my WinXP PC has required more frequent reboots of Firefox and of the PC, itself. I used to be able to open Task Manger and kill "plug-in container" and everything would be fine. Is there such an option for HTML5 videos? Note: I have No Script installed. Even with No Script, the HTML5 videos auto-load and slow down my machine, as they add up and don't let go of memory.

Thanks for volunteering and helping the community. We appreciate it.

mazcar 於 5 年前 詢問

jscher2000 最近回覆 於 5 年前

  • 封存

Cannot play YouTube HTML5 HD 60fps Videos

Cannot play a single HD video on YouTube using FireFox using HTML5 and Flash. The video stutters and then drops frames and an insane rate while the audio keeps going. I u… (閱讀更多)

Cannot play a single HD video on YouTube using FireFox using HTML5 and Flash. The video stutters and then drops frames and an insane rate while the audio keeps going. I used to be able to play 720p 60fps videos on Firefox but even those drop frames now. I don't understand why since YouTube works fine on Microsoft Edge but I would much rather continue using FIrefox than that so some help here would be greatly appreciated. My specs (laptop): Windows 10 Pro 64-bit AMD E-450 APU with Radeon HD 6320 Graphics 1.65 GHz 4.00 GB RAM Wired connection.

Thank you.

Dessembrae 於 5 年前 詢問

cor-el 最近回覆 於 5 年前

  • 封存

HTML5 Audio AACPlus Problem

I have made a player in HTML5 with controls <audio> have more experienced problems in matters of running AAC with the mozilla, when testing with Chrome worked perfe… (閱讀更多)

I have made a player in HTML5 with controls <audio> have more experienced problems in matters of running AAC with the mozilla, when testing with Chrome worked perfectly and the view speaks manual that compatible with AAC Mozilla more still does not work, I am using a central Shoutcast to transmit Audio, some could help me solve this issue? I am using the following code to get the audio in Chrome, and I believe it has no difference for Mozilla, it is worth remembering that when put into Mp3 wheel usually more when using the AAC player simply disappears from view.

Code: <audio src="http://serverip:port/;" controls autoplay></audio>


OBS: IP and port were concealed for security reasons;

lucianozanita 於 5 年前 詢問

jscher2000 最近回覆 於 5 年前

  • 封存

You Tube Videos Only Play After Computer Restart

I'm a musician and I need access to You Tube videos. I didn't have any luck on their forum, and the Firefox Forum rocks, so: The You Tube videos only play after a comple… (閱讀更多)

I'm a musician and I need access to You Tube videos. I didn't have any luck on their forum, and the Firefox Forum rocks, so:

The You Tube videos only play after a complete computer restart. This is on Windows 7 on a Lenovo laptop.

All I get is the spinning circle. This occurs even if I just put the computer to sleep.

I'm using the HTML5 protocol.

Merely restarting Firefox does not help. Neither does using Internet Explorer.

I'd appreciate any suggestions.

Thanks!

Skyscrapersax 於 5 年前 詢問

FredMcD 最近回覆 於 5 年前

  • 封存

Firefox crashes/freezes computer with Youtube, hardware-video-decoding.failed setting ineffective

Ever since the HTML5 player has taken over Youtube, I've had problems with it perma-freezing my computer as soon as any window was opened. Until recently I got around tha… (閱讀更多)

Ever since the HTML5 player has taken over Youtube, I've had problems with it perma-freezing my computer as soon as any window was opened. Until recently I got around that by setting media.windows-media-foundation.enabled to false, forcing Youtube to use the Flash player. Lately, though, it's somehow gone back to the HTML5 player with 360p resolution only, so I went digging through the config file again in search of solutions. That's when I found two settings I hadn't noticed before, media.hardware-video-decoding.enabled (which I found true) and media.hardware-video-decoding.failed (which I also found true, though I hadn't touched it before). Re-enabling windows-media-foundation caused the hard-freezes to reoccur, but I discovered that by setting media.hardware-video-decoding.enabled to false I was able to leave the windows-media-foundation option true, and I can now use Youtube's HTML5 player in all resolutions. I conclude from this that the media.hardware-video-decoding.failed setting is bugged somehow, since it didn't seem to prevent the freezes.

y3kcjd5 於 5 年前 詢問

jscher2000 最近回覆 於 5 年前

  • 封存

Firefox 43 overheating gpu on youtube html5

hello. firstly sorry my english weak. i hope u guys understand me and my problem. today ill upgrade my firefox 42 to firefox 43. after the update ive problem with gpu tem… (閱讀更多)

hello. firstly sorry my english weak. i hope u guys understand me and my problem.

today ill upgrade my firefox 42 to firefox 43.

after the update ive problem with gpu temp on youtube html5 videos. before the update my gpu temp was 40~45 C but now its over 52-55 C if ill get watchin youtube videos

my gpu amd r9 390

ill test flash player gpu temps on twitch its seems normal like 43-45. ill playing csgo its normal again like 45 49

ill try disable hardware acceleretion. its workin actually my gpu temps look normal when disable hardware acc. BUT this time my firefox fonts corrupted

example image

ffnmg 於 4 年前 詢問

the-edmeister 最近回覆 於 4 年前

  • 封存

How do I stop "The Primetime Content Decryption Module provided by Adobe Systems, Incorporated plugin has crashed" in Netflix on Firefox 42?

I was watching Netflix fine last night, but now all of the sudden it's giving me this message when I try to watch videos: > The Primetime Content Decryption Module pro… (閱讀更多)

I was watching Netflix fine last night, but now all of the sudden it's giving me this message when I try to watch videos:

> The Primetime Content Decryption Module provided by Adobe Systems, Incorporated plugin has crashed

I suppose Netflix is trying to use HTML5 instead of Silverlight, of course getting away from Flash only to come back to Adobe isn't that ideal.

The plugin is automatically downloaded by Firefox, so this is a Firefox issue: https://support.mozilla.org/en-US/kb/enable-drm

Anyway, I have "Play DRM content" selected in Options ==> Content. What else could fix this?

PatPeter 於 4 年前 詢問

cpearce 最近回覆 於 4 年前

  • 封存

On my new website I cannot get a webm to play

Hi all, First off I'm using Firefox 44 currently and I've used a copy on my work PC that has well used user profile and also a fresh install on my home laptop without any… (閱讀更多)

Hi all,

First off I'm using Firefox 44 currently and I've used a copy on my work PC that has well used user profile and also a fresh install on my home laptop without any additional addons with the same result.

I'm struggling to make html5 videos work across all browsers. I thought I had this nailed until I realised it had stopped working in Firefox. I'm currently using the following code to load video via a html5 webpage (I know this is html talk but please bear with me as I believe it more likely be a bug with firefox than my code):


EDIT: ok so it won't show my html 5 code properly and I can't find any instructions on how I should put html5 code into the questions on this support forum, so here it is in [tags], just replace the [] with <>

<!-- first try HTML5 playback: if serving as XML, expand `controls` to `controls="controls"` and autoplay likewise -->
<!-- warning: playback does not work on iOS3 if you include the poster attribute! fixed in iOS4.0 -->
<video width="900" height="506" poster="videos/poster.jpg" onclick="this.play()" preload="none" controls>
<source src="videos/playme.webmhd.webm" type="video/webm" /><!-- Chrome10+, Ffx4+, Opera10.6+ -->
<source src="videos/playme.mp4" type="video/mp4" /><!-- Safari / iOS, IE9 -->
<source src="videos/playme.oggtheora.ogv" type="video/ogg" /><!-- Firefox3.6+ / Opera 10.5+ -->						

<!-- fallback to Flash: -->
<object width="900" height="506" type="application/x-shockwave-flash" data="videos/player.swf">
<!-- Firefox uses the `data` attribute above, IE/Safari uses the param below -->
<param name="movie" value="videos/player.swf" />
<param name="allowFullScreen" value="true" />
<param name="allowScriptAccess" value="sameDomain" />
<param name="flashvars" value='autostart=true&amp;controlbar=over&amp;file=https://www.examplesite.com/videos/playme.mp4' />
<!-- fallback image -->
<img src="videos/No_Playback.jpg" width="900" height="506" alt="Oops No Playback"  title="Your browser cannot play this file, please use another browser" />
</object>
</video>

The page has several videos listed all with the same result. I don't believe its the code causing any issue either as even if I load the webm video directly in the url it still will not play. I've loaded the webm video in chrome without problem.

I can see from the network tab of the web console that it is trying to load the webm file and that the MIME type is correct, but it just displays the poster for the video and the correct length of the video. If I hit play it won't play, similarly if I try to seek it won't either. I've tried it with multiple videos too.

I did initially convert the videos from mp4 h264 into a webm using the webmhd preset in miro video converter. However I've also used the following command using ffmpeg to reconvert the video as suggested elsewhere online:

ffmpeg -i input.webm -codec copy -avoid_negative_ts 1 output.webm

As it is suggested that it could be a bug with negative timestamps in some version of firefox, but this still fails to load anything but the first video frame.

I've attached a screenshot of what I can see. The poster is a yellow jpg which states press play, so what you're actually seeing is the first frame of the webm video after I've hit play (as preload has been set to none).

I'm assuming it doesn't use the mp4 as a fallback because the webm should be working? I don't want to have to put the mp4 first as its larger in file size and not an open standard that will be permanently adopted. Plus the mp4s seem to take an age to load on android mobiles.

Now this code works fine in all other browsers, as does the webm files as stated above, except for either Firefox or Firefox Mobile on Android (can't test it on Mac as not an apple owner). I've tied it on various PCs and laptops (windows 7 & 10), and also my Sony xperia Z3. Currently using my windows 10 hp omen to type this.

ffmpeg video conversion output:

C:\ffmpeg\bin>ffmpeg -i input.webmhd.webm -codec copy -avoid_negative_ts 1 output.webm ffmpeg version N-79889-g9486de5 Copyright (c) 2000-2016 the FFmpeg developers

 built with gcc 5.3.0 (GCC)
 configuration: --enable-gpl --enable-version3 --disable-w32threads --enable-avisynth --enable-bzlib --enable-fontconfig --enable-frei0r --enable-gnutls --enable-iconv --enable-libass --enable-libbluray --enable-libbs2b --enable-libcaca --enable-libfreetype --enable-libgme --enable-libgsm --enable-libilbc --enable-libmodplug --enable-libmfx --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libopenjpeg --enable-libopus --enable-librtmp --enable-libschroedinger --enable-libsnappy --enable-libsoxr --enable-libspeex --enable-libtheora --enable-libtwolame --enable-libvidstab --enable-libvo-amrwbenc --enable-libvorbis --enable-libvpx --enable-libwavpack --enable-libwebp --enable-libx264 --enable-libx265 --enable-libxavs --enable-libxvid --enable-libzimg --enable-lzma --enable-decklink --enable-zlib
 libavutil      55. 24.100 / 55. 24.100
 libavcodec     57. 40.100 / 57. 40.100
 libavformat    57. 36.100 / 57. 36.100
 libavdevice    57.  0.101 / 57.  0.101
 libavfilter     6. 45.100 /  6. 45.100
 libswscale      4.  1.100 /  4.  1.100
 libswresample   2.  0.101 /  2.  0.101
 libpostproc    54.  0.100 / 54.  0.100

Input #0, matroska,webm, from 'input.webmhd.webm':

 Metadata:
   encoder         : Lavf54.3.100
   creation_time   : 1970-01-01 00:00:00
 Duration: 00:01:28.54, start: -0.002000, bitrate: 232 kb/s
   Stream #0:0(eng): Video: vp8, yuv420p, 1280x716, SAR 1:1 DAR 320:179, 15 fps, 15 tbr, 1k tbn (default)
   Stream #0:1(eng): Audio: vorbis, 44100 Hz, stereo, fltp (default)

[webm @ 000000000258e740] Using AVStream.codec to pass codec parameters to muxers is deprecated, use AVStream.codecpar instead.

   Last message repeated 1 times

Output #0, webm, to 'output.webm':

 Metadata:
   encoder         : Lavf57.36.100
   Stream #0:0(eng): Video: vp8, yuv420p, 1280x716 [SAR 1:1 DAR 320:179], q=2-31, 15 fps, 15 tbr, 1k tbn (default)
   Stream #0:1(eng): Audio: vorbis, 44100 Hz, stereo (default)

Stream mapping:

 Stream #0:0 -> #0:0 (copy)
 Stream #0:1 -> #0:1 (copy)

Press [q] to stop, [?] for help frame= 1328 fps=0.0 q=-1.0 Lsize= 2509kB time=00:01:28.52 bitrate= 232.1kbits/s speed=2.34e+003x video:1794kB audio:674kB subtitle:0kB other streams:0kB global headers:0kB muxing overhead: 1.643398%

I am happy to provide sample webm videos or any other necessary information you may require. Please let me know.

Any help would be greatly appreciated, thank you.

bottyz 於 4 年前 詢問

jscher2000 最近回覆 於 4 年前

  • 封存

Approach for legacy site that use Flash or other legacy tech

Mozilla announced last year that it will stop support some legacy technology and as we know Firefox will block flash starting August 2016. What are some ways to deal with… (閱讀更多)

Mozilla announced last year that it will stop support some legacy technology and as we know Firefox will block flash starting August 2016.

What are some ways to deal with site that still using Flash or legacy technology, so the apps do not break. Chrome introduced Legacy Browser Support (LBS) plugin that redirected sites. Is Mozilla going to introduce any such tool or other approach, so it does not effect user experience and gives developers more time to make their apps compatible.

This is an open question, and I am looking to hear bunch of ideas as to what would happen an Enterprise network for those sites.

SAI157 於 4 年前 詢問

jscher2000 最近回覆 於 4 年前

  • 封存

Tabs on Firefox crashes whenever I have HTML5 running in the background

After I've updated the Firefox browser to 50.0, I started having issues browsing multiple tabs. Whenever I have a tab that runs HTML5 (Youtube video or Twitch stream), an… (閱讀更多)

After I've updated the Firefox browser to 50.0, I started having issues browsing multiple tabs. Whenever I have a tab that runs HTML5 (Youtube video or Twitch stream), and I'm on other tabs browsing, there is a high chance that my tabs crashes.

It doesn't happen in Safe mode, but even after I've manually disabled the few addons I have, it still crashes (I have no theme to my browser).

https://crash-stats.mozilla.com/report/index/17185f37-b4aa-4b57-8b4b-5f1752161129

KalKent 於 4 年前 詢問

philipp 最近回覆 於 3 年前

  • 封存

Yet another youtube black screen!?

Bonjour, having issue with flash and simple playlist shuffle handling by youtube I decided to give HTML5 a try. Now, my playlist seems to be working good (most of the … (閱讀更多)

Bonjour,

  having issue with flash and simple playlist shuffle handling by youtube I decided to give HTML5 a try.

Now, my playlist seems to be working good (most of the time anyway!) but after a couple of videos I end up with only a black screen within youtube but still hearing the music (at least!).

I am writting this because I had the same issue many, many months, if not years ago. I have deactivated Video Acceleration within Firefox which fix the problem for a little while (I can now see a couple of videos before I get the black screeen).

What is puzzling me is how come, years after youtube switched to html5, this problem is still around and not fixed!?

Is there any way to fix the issue!? Is this a Firefox issue? Youtube issue?

I'm running Windows 10 64bits, fully patched and latets release of Firefox.

wpphili 於 3 年前 詢問

FredMcD 最近回覆 於 3 年前

  • 封存

MacBook Pro overheats when playing video in Firefox

Anytime I play video in Firefox (YouTube, Facebook, other embedded videos) my MacBook Pro heats up rapidly. In general, the computer runs at least 20 degrees hotter when … (閱讀更多)

Anytime I play video in Firefox (YouTube, Facebook, other embedded videos) my MacBook Pro heats up rapidly. In general, the computer runs at least 20 degrees hotter when running the video in Firefox as compared to Safari.

twpaul 於 3 年前 詢問

FredMcD 最近回覆 於 3 年前

  • 封存

The animation in the banner does not work correctly

Hello, technical support specialists! I created a banner using HTML5 and javascript, but it does not display correctly ... In previous versions of Firefox, everything wor… (閱讀更多)

Hello, technical support specialists! I created a banner using HTML5 and javascript, but it does not display correctly ... In previous versions of Firefox, everything works fine, but in the latest version, the banner animation is only done when the cursor moves ... What is it related to and how can I solve this problem?

fjodor92 於 2 年前 詢問

James 最近回覆 於 2 年前

  • 封存

Random crashes when i listen to youtube music in the background.

Hello guys! I'm having some periodic crashes when i listen to youtube music in background. It happenes randomly, maybe once a week or sometimes twice a day. I tried remov… (閱讀更多)

Hello guys! I'm having some periodic crashes when i listen to youtube music in background. It happenes randomly, maybe once a week or sometimes twice a day.

I tried removing some unnecessary plugins but it didn't help.

Here are my logs in pending folder (or is there any way i can upload them in some readable form?)

https://drive.google.com/open?id=1nSkZKb2SSgUYPoNvrrBBYXNmoCugthPI

Dzinsham 於 2 年前 詢問

FredMcD 最近回覆 於 2 年前