X
點擊此處開啟此網站的行動版。

技術支援討論區

New windows in Firefox 29 on Windows 8.1 don't open fully maximized when clicked through a link

已張貼

New problem in firefox 29:

When I click a link that opens the new page in a new window, the window pops open in the last partially maximized state that it was in. Should I maximize the new window (in Windows 8.1) and close it and re-click the original link, the window opens again in the partially maximized state, not the last fully maximized state that I previously closed it in.

To create it as I've encountered it:

-go to https://news.google.com

-click on any article. the default behavior should be to open the article in a new window

-the window won't be maximized in my experience

-you can maximize the window and then close the window/ article

-re-click on the same article and the new window should appear again in the non-maximized state, not the fully maximized state that you closed it in previously


One point of note. Right-clicking the same link that opens the new window and specifically choosing "Open Link in New Window" DOES open the new window in a fully maximized state. I repeat, the new window does open fully maximized when you choose "Open Link in New Window" from the right-click drop downs menu. But, this doesn't happen with the simple left-click, which I'm concerned with.

New problem in firefox 29: When I click a link that opens the new page in a new window, the window pops open in the last partially maximized state that it was in. Should I maximize the new window (in Windows 8.1) and close it and re-click the original link, the window opens again in the partially maximized state, not the last fully maximized state that I previously closed it in. To create it as I've encountered it: -go to https://news.google.com -click on any article. the default behavior should be to open the article in a new window -the window won't be maximized in my experience -you can maximize the window and then close the window/ article -re-click on the same article and the new window should appear again in the non-maximized state, not the fully maximized state that you closed it in previously One point of note. Right-clicking the same link that opens the new window and specifically choosing "Open Link in New Window" DOES open the new window in a fully maximized state. I repeat, the new window does open fully maximized when you choose "Open Link in New Window" from the right-click drop downs menu. But, this doesn't happen with the simple left-click, which I'm concerned with.

由 bolcrom 於 修改

額外的系統細節

已安裝的外掛程式

  • Version 5.3.1.18536
  • Shockwave Flash 13.0 r0
  • Google Update
  • Next Generation Java Plug-in 10.55.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Unity Player 4.3.5f1
  • 5.1.30214.0
  • VLC media player Web Plugin 2.1.3
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.06
  • Adobe Shockwave for Director Netscape plug-in, version 12.0.7.148
  • GEPlugin
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

應用程式

  • User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0

更多資訊

aubbieed 1 個解決方法 39 個答案

Novgorod may be celebrating too early like I did. When FF 31 was released, this problem disappeared for me and I was stoked!

However, 3 days later, it started happening again.

Novgorod may be celebrating too early like I did. When FF 31 was released, this problem disappeared for me and I was stoked! However, 3 days later, it started happening again.
Novgorod 0 個解決方法 14 個答案

Hmm, still works fine for me... Maybe one of your addons is interfering (though I have a lot of them myself)? Did you try it without any addons (e.g. blank profile) except the "hide tab bar with only one tab" addon? Also, I have Win7 and it can behave differently on Win8..

The problem cannot start out of nothing and there wasn't any update since FF31, so it must be something you changed within those 3 days...

Hmm, still works fine for me... Maybe one of your addons is interfering (though I have a lot of them myself)? Did you try it without any addons (e.g. blank profile) except the "hide tab bar with only one tab" addon? Also, I have Win7 and it can behave differently on Win8.. The problem cannot start out of nothing and there wasn't any update since FF31, so it must be something you changed within those 3 days...
aubbieed 1 個解決方法 39 個答案

I also have Win 7 and I did not change anything in those 3 days, nor since.

I've got my profile exactly as I like it. The only change I want to make is to hide the Unsorted Bookmarks folder in the library, but everyone says that's not possible.

I also have Win 7 and I did not change anything in those 3 days, nor since. I've got my profile exactly as I like it. The only change I want to make is to hide the Unsorted Bookmarks folder in the library, but everyone says that's not possible.
cor-el
  • Top 10 Contributor
  • Moderator
17530 個解決方法 158495 個答案

You can't select individual item in a treelist and that folder in the Bookmarks Manager (Library) is shown in such a list. You can't hide this folder in the sidebar either, but you can in the "Show your bookmarks" drop-down list and in the Bookmarks menu.


You can't select individual item in a treelist and that folder in the Bookmarks Manager (Library) is shown in such a list. You can't hide this folder in the sidebar either, but you can in the "Show your bookmarks" drop-down list and in the Bookmarks menu. ---- *https://developer.mozilla.org/en/XUL_Tutorial/Styling_a_Tree
aubbieed 1 個解決方法 39 個答案

Yes, I know it can be hidden in the drop-down, which I've done.

Anyhow, let me just say that I am SHOCKED that a moderator actually replied to this thread! Can you shed some light on Mozilla's utter failure to address this issue?

Yes, I know it can be hidden in the drop-down, which I've done. Anyhow, let me just say that I am '''SHOCKED''' that a moderator actually replied to this thread'''!''' Can you shed some light on Mozilla's utter failure to address this issue?
ElectronicTrader 0 個解決方法 1 個答案

I had the same problem & found a work-around that functions suitably for me.

So FWIW, go to Tools --> Options --> Tabs.

Check the box that says "Open new windows in a new Tab instead" , and Check the box that says: "When I open a new link in a new tab, open it immediately".

I had the same problem & found a work-around that functions suitably for me. So FWIW, go to Tools --> Options --> Tabs. Check the box that says "Open new windows in a new Tab instead" , and Check the box that says: "When I open a new link in a new tab, open it immediately".
aubbieed 1 個解決方法 39 個答案

Yeah, that works, but it actually poses a new problem.

When I use tabbed browsing, I like to hit right-click, Open In A Tab, and do this repeatedly on several links at once. You can't really do that with your fix as you have to add a new step of swapping back to the original tab every time you open a new tab. That's a pain in the ass.

Oh well, I suppose it's better than nothing since Mozilla is either too damn lazy or stupid to make their users happy and fix their screw-up.

Yeah, that works, but it actually poses a new problem. When I use tabbed browsing, I like to hit right-click, Open In A Tab, and do this repeatedly on several links at once. You can't really do that with your fix as you have to add a new step of swapping back to the original tab every time you open a new tab. That's a pain in the ass. Oh well, I suppose it's better than nothing since Mozilla is either too damn lazy or stupid to make their users happy and fix their screw-up.
cyberpainter 0 個解決方法 24 個答案

Like I wrote before, my issue was fixed, as it was for some others.

"To fix this issue go into Customize and toggle "Title Bar" in the lower left corner. "

This fixed the issue for me. I have vista and (now) firefox 32.0.3. I don't use tabs.

Like I wrote before, my issue was fixed, as it was for some others. "To fix this issue go into Customize and toggle "Title Bar" in the lower left corner. " This fixed the issue for me. I have vista and (now) firefox 32.0.3. I don't use tabs.
aubbieed 1 個解決方法 39 個答案

Yes, that works too, but like all other so-called "fixes", it creates another problem. Have you never realized this, or did you decide not to mention that?

In a few cases, I will use tabs, but with your "fix", when you open a tab, it will shift the menu bar up.

For most, that may not matter, but the problem is, I also use custom buttons and I have a number of buttons on the unused portion of the menu bar, and when the menu bar shifts up, some buttons disappear under the minimize/restore/'exit.

Yes, that works too, but like all other so-called "fixes", it creates another problem. Have you never realized this, or did you decide not to mention that? In a few cases, I will use tabs, but with your "fix", when you open a tab, it will shift the menu bar up. For most, that may not matter, but the problem is, I also use custom buttons and I have a number of buttons on the unused portion of the menu bar, and when the menu bar shifts up, some buttons disappear under the minimize/restore/'exit.
Novgorod 0 個解決方法 14 個答案

What are you all talking about!?

Firstly, the initial issue had nothing to do with tabs but with opening new windows via links which were not maximized - that's fixed since FF31! Stop whining about it already or hijacking the thread for unrelated issues!

Secondly, if you "don't use tabs", you're obviously using the "hide tab bar with only one tab" addon - otherwise you have a space-wasting empty tab bar on all of the FF windows. If you do use tabs occasionally, the tab bar is automatically shown as soon as you have at least 2 tabs within the window.

Thirdly, the "hide tab bar with only one tab" addon only works properly with the title bar enabled! (@cyberpainter: you have to specify what you mean by "toggle", otherwise your advice is useless...) If you disable the title bar in the customize menu, it will be automatically re-enabled by the addon when it hides the tab bar - this means FF-windows can only be displayed without a title bar if the tab bar is enabled! But who needs a window without a title bar anyway?

So in order to have nice and consistent behavior if you don't want to have a tab bar most of the time, you must enable the title bar - so what? No big deal! If you then open a second tab inside a window, the tab bar appears without messing around with the menu or anything... Just keep your goddamn title bar enabled (like every sane application on this planet) and you'll be just fine O_o...

What are you all talking about!? Firstly, the initial issue had nothing to do with tabs but with opening new windows via links which were not maximized - '''that's fixed since FF31!''' Stop whining about it already or hijacking the thread for unrelated issues! Secondly, if you "don't use tabs", you're obviously using the "hide tab bar with only one tab" addon - otherwise you have a space-wasting empty tab bar on all of the FF windows. If you '''do''' use tabs occasionally, the tab bar is automatically shown as soon as you have at least 2 tabs within the window. Thirdly, the "hide tab bar with only one tab" addon only works properly '''with the title bar enabled'''! (@cyberpainter: you have to specify what you mean by "toggle", otherwise your advice is useless...) If you '''disable''' the title bar in the customize menu, it will be automatically re-enabled by the addon when it hides the tab bar - this means FF-windows can only be displayed without a title bar '''if the tab bar is enabled!''' But who needs a window without a title bar anyway? So in order to have nice and consistent behavior if you don't want to have a tab bar most of the time, you '''must enable the title bar''' - so what? No big deal! If you then open a second tab inside a window, the tab bar appears without messing around with the menu or anything... Just keep your goddamn title bar enabled (like every sane application on this planet) and you'll be just fine O_o...
aubbieed 1 個解決方法 39 個答案

If you are going to comment, at least try to understand the point being made.

The so-called fix made since FF31 only created other issues. As such, my comments to that effect show that I am not hijacking the thread, and your jackass comments only serve to embarrass yourself.

If you are going to comment, at least try to understand the point being made. The so-called fix made since FF31 only created other issues. As such, my comments to that effect show that I am not hijacking the thread, and your jackass comments only serve to embarrass yourself.
Novgorod 0 個解決方法 14 個答案

Oh great, so what was your point again?

- It magically "stopped working" after 3 days, but now it somehow seems to work again? Yeah, congrats..

- You're talking about bookmarks in the library -> OT..

- Your menu shifts up if you use the tab bar? Then enable the damn title bar (which would solve ALL of your "problems") or don't use the addon - this has been mentioned several times before! Don't be a jackass and repeat problems which are long time solved...

Oh great, so what was your point again? - It magically "stopped working" after 3 days, but now it somehow seems to work again? Yeah, congrats.. - You're talking about bookmarks in the library -> OT.. - Your menu shifts up if you use the tab bar? Then enable the damn title bar (which would solve ALL of your "problems") or don't use the addon - this has been mentioned several times before! Don't be a jackass and repeat problems which are long time solved...
cyberpainter 0 個解決方法 24 個答案

I want to respond to your question novgorod, but you aren't very polite I must say. When you talk about other people whining, it's just rude. If I'm going to respond to you since you seem to be addressing me, I'd appreciate it if any response is polite. Thank you.

I am talking about a desktop computer with vista. I have no tabs showing, as I do not like tabs in this environment. (I use tabs in my android devices.) I have: firefox menu row, then search row, then bookmark row, then the windows that are open, and at the bottom is my vista taskbar that shows a "tab" for each window that is open. Because I have that, firefox tabs are redundant. I am not crazy, just sensible.

Go to the far right in firefox where the horizontal bars are, click it, then look at the bottom left of that window and click customize. When you get to the next screen look lower left. You will see a button that says title bar. Any button is either on or off. By toggle I mean switched on or off.

Audobleed were you talking to me when you said it creates other problems? I can't tell. I have no other problems, so I don't have a reason to mention any. Sorry if the solution that worked for me did not work for you. :(

I want to respond to your question novgorod, but you aren't very polite I must say. When you talk about other people whining, it's just rude. If I'm going to respond to you since you seem to be addressing me, I'd appreciate it if any response is polite. Thank you. I am talking about a desktop computer with vista. I have no tabs showing, as I do not like tabs in this environment. (I use tabs in my android devices.) I have: firefox menu row, then search row, then bookmark row, then the windows that are open, and at the bottom is my vista taskbar that shows a "tab" for each window that is open. Because I have that, firefox tabs are redundant. I am not crazy, just sensible. Go to the far right in firefox where the horizontal bars are, click it, then look at the bottom left of that window and click customize. When you get to the next screen look lower left. You will see a button that says title bar. Any button is either on or off. By toggle I mean switched on or off. Audobleed were you talking to me when you said it creates other problems? I can't tell. I have no other problems, so I don't have a reason to mention any. Sorry if the solution that worked for me did not work for you. :(
Novgorod 0 個解決方法 14 個答案

You're welcome... By "useless advice" I mean that if you say "toggle" it's ambiguous - instead, you should have told whether you switched it on or off to solve your problem. As I pointed out, the title bar must be switched on for the tab hiding addon to work properly.

I also generally don't use tabs but rather different window instances for different web pages, managed by the task bar. That's the reason we're all in this thread - the "open in new window" function is meant exactly for that. It was screwed up in FF29 and fixed in FF31. Everything is fine, as long as you enable the title bar, so can we all go home now?

Oh and by the way, try to be more precise when you're describing your situation, so we all have the same initial conditions to relate to. For example, "no tabs showing" is not a trivial firefox option, i.e. the tab bar cannot be easily disabled. Either you have to set it in about:config (which is not permanent) or via the addon - I assumed you have the latter, which you unfortunately never confirmed...

You're welcome... By "useless advice" I mean that if you say "toggle" it's ambiguous - instead, you should have told whether you switched it '''on''' or '''off''' to solve your problem. As I pointed out, the title bar must be switched '''on''' for the tab hiding addon to work properly. I also generally don't use tabs but rather different window instances for different web pages, managed by the task bar. That's the reason we're all in this thread - the "open in new window" function is meant exactly for that. It was screwed up in FF29 and fixed in FF31. Everything is fine, as long as you enable the title bar, so can we all go home now? Oh and by the way, try to be more precise when you're describing your situation, so we all have the same initial conditions to relate to. For example, "no tabs showing" is not a trivial firefox option, i.e. the tab bar cannot be easily disabled. Either you have to set it in about:config (which is not permanent) or via the addon - I assumed you have the latter, which you unfortunately never confirmed...
cyberpainter 0 個解決方法 24 個答案

Oh and by the way, I can open a tab anytime I want with the right click menu. It just doesn't open that way by default.

Oh and by the way, I can open a tab anytime I want with the right click menu. It just doesn't open that way by default.
cyberpainter 0 個解決方法 24 個答案

You can go home anytime you like, no one is stopping you.

I do not remember whether I switched it on or off, and don't feel like trying it out. Anyone could try it out themselves to see what happens. And yes I do have the add on and forgot about that, it was quite a while ago now. So I guess the two together were necessary to fix the issue on my computer.

You can go home anytime you like, no one is stopping you. I do not remember whether I switched it on or off, and don't feel like trying it out. Anyone could try it out themselves to see what happens. And yes I do have the add on and forgot about that, it was quite a while ago now. So I guess the two together were necessary to fix the issue on my computer.
aubbieed 1 個解決方法 39 個答案

cyberpainter, thanks for the comments. And yes, your fix caused a problem for me.

What Novgorod doesn't seem to understand is the fix made in FF 31 doesn't work for everyone. I know others with the issue. For some reason, he's taking offense to this.

My posts were meant to find a solution, but I can see this thread isn't going to help, so I'm out.

cyberpainter, thanks for the comments. And yes, your fix caused a problem for me. What Novgorod doesn't seem to understand is the fix made in FF 31 doesn't work for everyone. I know others with the issue. For some reason, he's taking offense to this. My posts were meant to find a solution, but I can see this thread isn't going to help, so I'm out.
Novgorod 0 個解決方法 14 個答案

You didn't describe your problem properly. You said what happens if the title bar is switched off (apparently), which is the wrong usage anyway, but you didn't say that switching the title bar on won't work! If it doesn't then what happens?

You didn't describe your problem properly. You said what happens if the title bar is switched off (apparently), which is the wrong usage anyway, but you didn't say that switching the title bar '''on''' won't work! If it doesn't then what happens?