搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Firefox 25 Beta 8 update doesn't show Soundcloud properly, no obvious fix, any tips?

  • 18 回覆
  • 114 有這個問題
  • 4300 次檢視
  • 最近回覆由 usernick

more options

Using Mac OS X 7.5, I updated Firefox when prompted, now Soundcloud widgets say 'data connection failure', direct links to Soundcloud pages don't load but send me to a generic 'something went wrong' page with low-res graphics. Everything else seems to work, including video streams, bandcamp etc.

I have looked at advice here for similar issues - safe restart, clearing cookies and cache don't help. I don't have adblocker or firewall, almost no add-ons, the problem occurred both before and after updating Flash.

Chrome works fine with Soundcloud, so it looks like it is a Firefox issue. Any advice?

被選擇的解決方法

Try to set the security.ssl.enable_ocsp_stapling pref to false on the about:config page.

See also:

從原來的回覆中察看解決方案 👍 14

所有回覆 (18)

more options
more options

Thanks, but the same thing happened when I tried that.

In case it makes a difference to any other suggestion you might make, I don't have a Soundcloud account, I just play music via widgets that sites have embedded, or go directly to an artists' page and stream from there - neither of these requires a log-in.

more options

I have the same issue which has only arisen since the latest beta update.

Is there a resolution to this, or should I uninstall Firefox Beta 25?

Creating a new profile doesn't resolve the issue, btw - same error message.

由 usernick 於 修改

more options

Can you post a link to a page that uses SoundCloud?

more options

Same here, and only with FF 25 beta 6 (or 7 ? don't remember when it has started) or more.

Here a screen with JS error of SoundCloud (see attachment)

Have a nice day.

more options

I get the same thing as shown in the post above when going to a Soundcloud page.

For a site using a Soundcloud embed: http://thelineofbestfit.com/new-music/blog/moko-honey-cocaine-139540 is typical, with an error message in the space the player should be:

由 mouldy 於 修改

more options

Now finding another error message - "The OCSP response contains out-of-date information". Maybe this means something to someone....

more options

Works here:

  • https://w.soundcloud.com/player/?url=http%3A%2F%2Fapi.soundcloud.com%2Ftracks%2F114247692&secret_token=s-LD9A7

You can check the date and time in the clock on your computer: (double) click the clock icon on the Windows Taskbar.

more options

@ cor-el - thanks for your help, some progress.

I updated to FF25 b9, although that didn't make any difference. Soundcloud embeds and artist pages have continued to work normally in Chrome and Safari throughout this time, fwiw.

Re your post - the link you put just gave me a full-page version of the image in my last post, with the extra detail "(Error code: sec_error_ocsp_old_response) ".

Date and time are correct, that's not the issue, but your support link discusses OCSP issues, so I tried disabling the OCSP and instantly I could load a Soundcloud page as normal, so that has identified the problem.

I enabled it again after this test as I'm unsure if or how I might be vulnerable when it is off. I will look for more information about this but I would be grateful if you have any advice about whether it is ok to leave the OCSP disabled. I would be even more grateful if Firefox would work normally with OCSP enabled....

I typically use Soundcloud numerous times each day and would like to find a safe, permanent solution.

more options

I'm experiencing the same problems on Windows 7 x64 SP1, with addons disabled or not doesn't matter. Cleared cache, cookies, no proxy, etc etc. IE 10 does work flawlessly.

This has happened with I believe the last two or maybe three beta's.

Also, this has been a problem since I can remember: after a while of listening to different tracks (30+) the player stops working and I need to close Firefox and restart. But this might also be Flash (if still used), I don't know for sure.

more options

Having this issue as well. Error page in Firefox (25) but works fine in every other browser.

I had a look at what happens in the web console in Firefox and in Chrome while loading a Soundcloud page Firefox fails at. How about this, Firefox will show a javascript error, Chrome doesn't.

Here's the error: [18:03:50.160] ReferenceError: require is not defined @ https://soundcloud.com/gavinharrison:3

Either Firefox is doing something wrong while loading the page and running the script or there is something wrong with Soundclouds javascript and it won't work in Firefox 25 and send you to an error page?

more options

Try to rename the cert8.db file in the Firefox profile folder to cert8.db.old or delete the cert8.db file to remove intermediate certificates that Firefox has stored.

If that helped to solve the problem then you can remove the renamed cert8.db.old file.
Otherwise you can rename (or copy) the cert8.db.old file to cert8.db to restore the previous intermediate certificates.
Firefox will automatically store intermediate certificates when you visit websites that send such a certificate.

If that didn't help then remove or rename secmod.db (secmod.db.old) as well.


Create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":

If the new profile works then you can transfer some files from an existing profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over the problem.

more options

Hi Cor-El, this doesn't fix it for me, still the same issue.

more options

cor-el

that doesn't fix it for me either, and I now find that when using Twitter user's icons aren't loading in Firefox although are fine in Safari.

Disabling OCSP fixes both of these issues.

more options

Just for your infomation, Opera recently have the same OCSP problem about twitter (twimg). Not sure about SoundCloud tho.

more options

選擇的解決方法

Try to set the security.ssl.enable_ocsp_stapling pref to false on the about:config page.

See also:

more options

cor-el

fixed, thanks for your help with this.

Please advise if there is there any reason to be concerned about changing this from the default setting.

more options

Hi cor-el,

Yes, that fixed it - SoundCloud now has no issues! :)

Many thanks.