搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Whenever I watch a video in HD, the browser starts hanging all the time. This isn't happening in any other browser. Can someone help me?

  • 4 回覆
  • 4 有這個問題
  • 458 次檢視
  • 最近回覆由 rexsis

more options

Watching videos on YouTube is one of the things I primarily do on the internet. My GPU is capable of handling HD videos. That's why I enable it. Although, Firefox seems to not like it. It starts hanging is intervals of 4-6 seconds. And the most interesting part is that other browsers (Chrome, IE and Opera) don't do this. I tried everything said in the help resources but nothing changed. Please help me!

被選擇的解決方法

Did you try to disable protected mode in the Flash plugin?

從原來的回覆中察看解決方案 👍 1

所有回覆 (4)

more options

Please check if all your plugins are up-to-date. To do this, go to the Mozilla Plugin Check site.

Once you're there, the site will check if all your plugins have the latest versions. If you see plugins in the list that have a yellow Update button or a red Update now button, please update these immediately.

To do so, please click each red or yellow button. Then you should see a site that allows you to download the latest version. Double-click the downloaded file to start the installation and follow the steps mentioned in the installation procedure.


Hello,

Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.

You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

Then perform these steps:

  • Click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options.
  • In the Firefox options window click the Advanced tab, then select "General".
  • In the settings list, you should find the Use hardware acceleration when available checkbox. Uncheck this checkbox.
  • Now, restart Firefox and see if the problems persist.

Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles:

Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems

Upgrade your graphics drivers to use hardware acceleration and WebGL

Did this fix your problems? Please report back to us!

Thank you.

more options

Thank you for the reply! Sadly, none of these suggestions worked. :( I already have the latest drivers available for my system. Could it be the computer itself?

more options

選擇的解決方法

Did you try to disable protected mode in the Flash plugin?

more options

cor-el, thank you so much! This made everything better!!!!