為了改善您的使用體驗,本網站正在進行維護,部分功能暫時無法使用。若本站的文件無法解決您的問題,想要向社群發問的話,請到 Twitter 上的 @FirefoxSupport 或 Reddit 上的 /r/firefox 發問,我們的社群成員將很快會回覆您的疑問。

搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Proxy authentication confirmation prompt keeps popping up although the user/password is saved

  • 2 回覆
  • 4 有這個問題
  • 597 次檢視
  • 最近回覆由 sabine47

more options

I'm using Firefox 17.0.1 I have a proxy configured which requires authentication. The username and password are stored in the password manager. However every time I restart Firefox it requires a confirmation of the user/password settings. How can I turn this off? I set the signon.autologin.proxy to true, as suggested in another post, but the confirmation request is still shown. Thanks!

I'm using Firefox 17.0.1 I have a proxy configured which requires authentication. The username and password are stored in the password manager. However every time I restart Firefox it requires a confirmation of the user/password settings. How can I turn this off? I set the signon.autologin.proxy to true, as suggested in another post, but the confirmation request is still shown. Thanks!

被選擇的解決方法

Hello ideato

I set network.automatic-ntlm-auth.allow-proxies to false, as was suggested in other forums. I found that the following combination of settings finally made it work:

signon.autologin.proxy;true
network.proxy.share_proxy_settings – FALSE
network.automatic-ntlm-auth.allow-proxies – FALSE
network.auth.use-sspi – FALSE

With these settings, Firefox doesn't show a confirmation window at the startup anymore.
Thanks for your help,
kind regads
sabine

從原來的回覆中察看解決方案 👍 1

所有回覆 (2)

more options

Hello sabine47

the network.automatic-ntlm-auth.allow-proxies is TRUE (the default) ?


thank you

more options

選擇的解決方法

Hello ideato

I set network.automatic-ntlm-auth.allow-proxies to false, as was suggested in other forums. I found that the following combination of settings finally made it work:

signon.autologin.proxy;true
network.proxy.share_proxy_settings – FALSE
network.automatic-ntlm-auth.allow-proxies – FALSE
network.auth.use-sspi – FALSE

With these settings, Firefox doesn't show a confirmation window at the startup anymore.
Thanks for your help,
kind regads
sabine

由 cor-el 於 修改