搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

What is tha latet version of Firefox compatile with MAC OS 10.4.11

  • 1 回覆
  • 31 有這個問題
  • 383 次檢視
  • 最近回覆由 cor-el

more options

When I down load the latest version of firefox supposidly compatible with my compute I get a message it is not compatible and I should dowm load the latest version tha tis compatible with my system, 10.4.11 running on a G 5 based machine. NOT INTELL! So what is the appropriate version and please send me a link!!

被選擇的解決方法

Firefox 4 versions and later do not run on a PowerPC Mac.

Firefox 4 and later require at least OS X 10.5 and an Intel Mac.

For an unofficial Firefox 9 compatible version TenFourFox that runs on PowerPC Macs with OS X 10.4.11 and OS X 10.5.8 you can look at:

Firefox 3.6.x (Mac OS X 10.4 and later) can be found here:

從原來的回覆中察看解決方案 👍 7

所有回覆 (1)

more options

選擇的解決方法

Firefox 4 versions and later do not run on a PowerPC Mac.

Firefox 4 and later require at least OS X 10.5 and an Intel Mac.

For an unofficial Firefox 9 compatible version TenFourFox that runs on PowerPC Macs with OS X 10.4.11 and OS X 10.5.8 you can look at:

Firefox 3.6.x (Mac OS X 10.4 and later) can be found here: