X
點擊此處開啟此網站的行動版。

技術支援討論區

webifyme.org questionnaire fails at final submit with "CSRF verifications failed" error.

已張貼

I just updated to Firefox 6.0 on Windows 7 Pro 64-bit. The Mozilla "Webify Me" ad sounded interesting, so I went and filled out the whole questionnaire. At the final question, when you can save your results or whatever, I got an error: "CSRF verification failed. Request aborted."

I just updated to Firefox 6.0 on Windows 7 Pro 64-bit. The Mozilla "Webify Me" ad sounded interesting, so I went and filled out the whole questionnaire. At the final question, when you can save your results or whatever, I got an error: "CSRF verification failed. Request aborted."

額外的系統細節

這發生了

只有一、兩次

問題發生於...

Just now

已安裝的外掛程式

  • ActiveTouch General Plugin Container Version 105
  • Octoshape embedded video plugin
  • Office Plugin for Netscape Navigator
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.0
  • Google Update
  • Shockwave Flash 10.3 r181
  • Picasa plugin
  • Next Generation Java Plug-in 1.6.0_26 for Mozilla browsers
  • 4.0.60310.0
  • Office Authorization plug-in for NPAPI browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Version 1.1.9, copyright 1996-2011 The VideoLAN Teamhttp://www.videolan.org/
  • Nitro PDF Plug-In For Firefox and Netscape

應用程式

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:6.0) Gecko/20100101 Firefox/6.0

更多資訊

I would like to include an image of the error.
The URL:
https://webifyme.org/en-US/quiz/
Page text content:
Forbidden (403)
CSRF verification failed. Request aborted.
More information is available with DEBUG=True.

Gnostici 0 個解決方法 1 個答案

I'm one of the (at this time) three who have had this problem and said so here.

Go back to the very first webify page (linked from the Mozilla start page), and disable any script blockers you have installed *at that page*. If it works for you as it did for me, you won't get an opportunity after that page.

I'm one of the (at this time) three who have had this problem and said so here. Go back to the very first webify page (linked from the Mozilla start page), and disable any script blockers you have installed *at that page*. If it works for you as it did for me, you won't get an opportunity after that page.

由 Gnostici 於 修改

Hasan 469 個解決方法 5600 個答案

-> Type about:config in the address bar and press Enter.

  • When you see a Warning, click I'll be careful, I promise button
  • In the Filter bar, type network.http.sendRefererHeader
  • If the preference network.http.sendRefererHeader appears in BOLD text, right-click it and choose Reset

Check and tell if its working.

-> Type '''about:config''' in the address bar and press Enter. * When you see a Warning, click '''I'll be careful, I promise''' button * In the '''Filter bar''', type ''network.http.sendRefererHeader'' * If the preference ''network.http.sendRefererHeader'' appears in BOLD text, right-click it and choose '''Reset''' Check and tell if its working.

提出問題者

I did not have any script blockers, and the network.http.sendRefererHeader preference is the default (2).

What I'm getting at: the webifyme page is being advertised on the welcome splash-screen page after the installation of Firefox 6. That means a lot of people are going to try it. If a percentage of these people go through the whole survey only to have it blow up in smoke with a CSRF-related error, it looks very bad for the Firefox brand.

I did not have any script blockers, and the network.http.sendRefererHeader preference is the default (2). What I'm getting at: the webifyme page is being advertised on the welcome splash-screen page after the installation of Firefox 6. That means '''a lot of people are going to try it'''. If a percentage of these people go through the whole survey only to have it blow up in smoke with a CSRF-related error, '''it looks very bad for the Firefox brand.'''
Hasan 469 個解決方法 5600 個答案
Clear Cookies & Cache * https://support.mozilla.com/en-US/kb/Template:clearCookiesCache Clear the Network Cache * https://support.mozilla.com/en-US/kb/How%20to%20clear%20the%20cache#w_clear-the-cache Troubleshooting extensions and themes * https://support.mozilla.com/en-US/kb/Troubleshooting%20extensions%20and%20themes Check and tell if its working.
cor-el
  • Top 10 Contributor
  • Moderator
17693 個解決方法 160088 個答案

This issue can be caused by corrupted cookies.

Clear the cache and the cookies from sites that cause problems.

"Clear the Cache":

  • Tools > Options > Advanced > Network > Offline Storage (Cache): "Clear Now"

"Remove Cookies" from sites causing problems:

  • Tools > Options > Privacy > Cookies: "Show Cookies"

Also make sure that you do not block cookies.

This issue can be caused by corrupted cookies. Clear the cache and the cookies from sites that cause problems. "Clear the Cache": * Tools > Options > Advanced > Network > Offline Storage (Cache): "Clear Now" "Remove Cookies" from sites causing problems: * Tools > Options > Privacy > Cookies: "Show Cookies" ---- Also make sure that you do not block cookies. * https://support.mozilla.com/kb/Cookies * https://support.mozilla.com/kb/Enabling+and+disabling+cookies * http://kb.mozillazine.org/Websites_report_cookies_are_disabled