X
点击这里打开本站的移动版本。
An updated version of Firefox is available to address the issues with Add-ons disabled or fail to install on Firefox. You can download the update for your OS here: https://www.mozilla.org/firefox/new/ For Known Issues and Workarounds, please check out the update at https://support.mozilla.org/kb/add-ons-disabled-or-fail-to-install-firefox

技术支持论坛

Forbidden (403) CSRF verification failed. Request aborted. More information is available with DEBUG=True.

发布于

Got the following msg when trying to do the 'webify me' thing:

Forbidden (403)

CSRF verification failed. Request aborted.

More information is available with DEBUG=True.

I use Windows Vista Home, everything was fine, Firefox did an update, now I'm getting errors?

Please explain how I can fix this.

Thank You

Got the following msg when trying to do the 'webify me' thing: Forbidden (403) CSRF verification failed. Request aborted. More information is available with DEBUG=True. I use Windows Vista Home, everything was fine, Firefox did an update, now I'm getting errors? Please explain how I can fix this. Thank You

补充系统细节

这发生于

只有一两次

在此时开始...

Firefox updated on 21 Aug. 2011

已安装的插件

  • Office Plugin for Netscape Navigator
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.5"
  • Shockwave Flash 10.3 r183
  • Adobe Shockwave for Director Netscape plug-in, version 11.5.8.612
  • Next Generation Java Plug-in 1.6.0_26 for Mozilla browsers
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • BlackBerry WebSL Browser Plug-In

应用程序

  • 用户代理(User Agent): Mozilla/5.0 (Windows NT 6.0; rv:6.0) Gecko/20100101 Firefox/6.0

详细信息

Hasan 469 个解决方法 5600 个回答

-> Type about:config in the address bar and press Enter

  • When you see a Warning, click I'll be careful, I promise button
  • In the Filter bar, type network.http.sendRefererHeader
  • If the preference network.http.sendRefererHeader appears in BOLD text, right-click it and choose Reset

Check and tell if its working.

-> Type '''about:config''' in the address bar and press Enter * When you see a Warning, click '''I'll be careful, I promise''' button * In the '''Filter bar''', type ''network.http.sendRefererHeader'' * If the preference ''network.http.sendRefererHeader'' appears in BOLD text, right-click it and choose '''Reset''' Check and tell if its working.

由Hasan于修改

提问者

I got to the preference screen, but my reset option was 'grayed' out?

Options I got with right-click was:

- Modify (in bold) - Copy - Copy Name - Copy Value - New - Reset - 'grayed out' unable to select

I got to the preference screen, but my reset option was 'grayed' out? Options I got with right-click was: - Modify (in bold) - Copy - Copy Name - Copy Value - New - Reset - 'grayed out' unable to select
Hasan 469 个解决方法 5600 个回答
Clear Cookies & Cache * https://support.mozilla.com/en-US/kb/Template:clearCookiesCache Clear the Network Cache * https://support.mozilla.com/en-US/kb/How%20to%20clear%20the%20cache#w_clear-the-cache Troubleshooting extensions and themes * https://support.mozilla.com/en-US/kb/Troubleshooting%20extensions%20and%20themes Check and tell if its working.

由Hasan于修改

lazyhawk 0 个解决方法 4 个回答

I got this same thing. The next response is just way to confusing and technical for me. Is there an easy fix, or will Mozilla fix this?

I got this same thing. The next response is just way to confusing and technical for me. Is there an easy fix, or will Mozilla fix this?
lazyhawk 0 个解决方法 4 个回答

Sorry, I got the same problem as AnjieJ

Sorry, I got the same problem as AnjieJ
cor-el
  • Top 10 Contributor
  • Moderator
17104 个解决方法 154461 个回答

有帮助的回复

CSRF involves cookies (at least on this forum) to verify that the form that you send was supplied by the server.
Make sure that you allow cookies from the involved sites.

Clear the cache and the cookies from sites that cause problems.

"Clear the Cache":

  • Tools > Options > Advanced > Network > Offline Storage (Cache): "Clear Now"

"Remove Cookies" from sites causing problems:

  • Tools > Options > Privacy > Cookies: "Show Cookies"
CSRF involves cookies (at least on this forum) to verify that the form that you send was supplied by the server.<br /> Make sure that you allow cookies from the involved sites. Clear the cache and the cookies from sites that cause problems. "Clear the Cache": *Tools > Options > Advanced > Network > Offline Storage (Cache): "Clear Now" "Remove Cookies" from sites causing problems: *Tools > Options > Privacy > Cookies: "Show Cookies" *http://kb.mozillazine.org/Cookies
lazyhawk 0 个解决方法 4 个回答

Thank you for the response. I followed your instructions and removed all cookies and I still get the Forbidden (403) CSRF message.

Thank you for the response. I followed your instructions and removed all cookies and I still get the Forbidden (403) CSRF message.
cor-el
  • Top 10 Contributor
  • Moderator
17104 个解决方法 154461 个回答

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance/Themes).

You can try to check with the the Live HTTP Headers extension to see if that cookie is send.

Start Firefox in <u>[[Safe Mode]]</u> to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance/Themes). *Don't make any changes on the Safe mode start window. *https://support.mozilla.org/kb/Safe+Mode You can try to check with the the Live HTTP Headers extension to see if that cookie is send. * https://addons.mozilla.org/firefox/addon/live-http-headers/
lazyhawk 0 个解决方法 4 个回答

有帮助的回复

Again thank you but no go. I will just use a different browser when I want to use Pinterest.

Again thank you but no go. I will just use a different browser when I want to use Pinterest.