搜尋 Mozilla 技術支援網站

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why only for me my webpage is little bit broken?

  • 11 回覆
  • 1 有這個問題
  • 3 次檢視
  • 最近回覆由 cor-el

more options

Why only for me my webpage is little bit broken not showing correctly? With other browsers is OK, but then i using Firefox 4+ version it's little bit broken, my friends using same browser like me, but for they website looking good. Please help me, because i don't like use old firefox versions :/ You can see how for me it look's: http://img818.imageshack.us/img818/8585/unledal.jpg At normally the text from panel's should little bit exposed from panel.

所有回覆 (11)

more options

it's difficult to see what you mean from your screenshot.

Could you please post the link to the site and then we can have a look at it.

more options

URL is in more system details - http://sentel.lt/index2.php

Firefox is displaying that page in the Quirks Mode and Firefox 4/0+ versions are less tolerant in Quirks Mode than earlier versions were.

http://validator.w3.org/check?uri=http://sentel.lt/index2.php

more options

Time to get a new pair of glasses for me Ed. :P

more options

What should i do ? Other friends has same version firefox and for them everything working perfect.

more options

Fix your coding so your web pages are displayed in "standards mode" rather then the "quirks mode". The problem with the quirks mode is that it forces Firefox to guess your intentions about how something is to be displayed, when your friends view that page Firefox guesses right, but for you Firefox is guessing wrong. Eliminate the "guess" factor and Firefox should display your web page the same for all users.
http://en.wikipedia.org/wiki/Quirks_Mode

Plus, once you fix the code, maybe you can get rid of that NO IE logo that appears when someone uses IE to view that page. Times are changing, IE 8 and even more so IE9, can display web pages almost as good as Firefox, Opera, and Chrome, and if not the web page is more than likely at fault.

more options

You mean i need to fix css at Quirks Mode? Because i never faced with this problem.. These tables too show badly

more options

This validation report basically tells you what needs to be fixed, but once you set a proper Parse Model and DTD that may change a bit. So those need to be set first before trying to do any real fixing of code.
http://validator.w3.org/check?uri=http://sentel.lt/index2.php

more options

But i don't understand, validator says i need to add DOCTYPE, but i added it and error same..

more options

Did you upload that change to the server? I am not seeing anything added to the source code that wasn't there an hour ago - as far the doctype goes.

Did you read this? http://validator.w3.org/docs/help.html#faq-doctype


Why not try posting at the Web Development / Standards Evangelism forum at MozillaZine, as this is a bit beyond Firefox user support. The helpers over there are more knowledgeable about web page development issues with Firefox than I am and might be able to refer to better information than I am aware of for this issue.
http://forums.mozillazine.org/viewforum.php?f=25
You'll need to register and login to be able to post in that forum.

more options

Yes i uploaded but validator can't validate. I readed that. That's index begin <meta http-equiv="content-type" content="text/html; charset=utf-8" /> DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/html4/strict.dtd">

<title>Sentel</title>

由 mikrafa 於 修改

more options

You can remove the <br> and set the style to .panelebg {word-wrap: break-word;} to make Firefox break the lines automatically.

If you have increased the minimum font size then try the default setting "none" as a high value can cause issues like you described.

  • Tools > Options > Content : Fonts & Colors > Advanced > Minimum Font Size (none)
  • Tools > Options > Content : Fonts & Colors > Advanced > [X] "Allow pages to choose their own fonts, instead of my selections above"