搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Translate Icon and Menu Item do not appear?

  • 2 回覆
  • 0 有這個問題
  • 4 次檢視
  • 最近回覆由 Mike Pureka

more options

I was browsing a webpage that turned out to be in Portuguese, and I was looking for how to translate it, but the internet indicated that Firefox has built in transation! However, neither the Translate Toolbar Icon nor the Translate menu option appear, even if I visit a site that absolutely should be translatable (https://fr.wikipedia.org/wiki/Mozilla_Firefox)

Additionally, if I go to Settings -> General, there is a Translations section, but if I click the Settings button, there are no languages in any of the boxes and no option to add any.

I am on Firefox 126.0 for Windows.

Here are the things I have tried:

  • Restarting Firefox
  • Rebooting my PC
  • Disabling all my extensions
  • Running Firefox in Troubleshooting Mode
  • Clearing my Startup Cache
  • Performing a "Refresh Firefox"
  • Toggling and Untoggling browser.translations.enable and browser.translations.automaticallyPopup

Does anyone have any suggestions of something I could have missed?

I was browsing a webpage that turned out to be in Portuguese, and I was looking for how to translate it, but the internet indicated that Firefox has built in transation! However, neither the Translate Toolbar Icon nor the Translate menu option appear, even if I visit a site that absolutely should be translatable (https://fr.wikipedia.org/wiki/Mozilla_Firefox) Additionally, if I go to Settings -> General, there is a Translations section, but if I click the Settings button, there are no languages in any of the boxes and no option to add any. I am on Firefox 126.0 for Windows. Here are the things I have tried: * Restarting Firefox * Rebooting my PC * Disabling all my extensions * Running Firefox in Troubleshooting Mode * Clearing my Startup Cache * Performing a "Refresh Firefox" * Toggling and Untoggling browser.translations.enable and browser.translations.automaticallyPopup Does anyone have any suggestions of something I could have missed?
附加的畫面擷圖

所有回覆 (2)

more options

You can set browser.translations.logLevel => All in about:config, and then close and restart Firefox and check for issues with translation in the Browser Console.

Do not forget to reset the pref after you are done testing.

有幫助嗎?

more options

I followed your instructions, but did not see any errors that looked translation related in the browser console, even after switching to multiprocess.

It's almost like translation is somehow just disabled and not even being attempted.

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先登入帳號 來回覆文章。還沒有帳號的話,只能發問新問題