搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

了解更多

Getting PR_CONNECT_RESET_ERROR on websites which use TLS/SSL

more options

For the past few days when I have tried to log into a few websites which use TLS/SSL I have gotten PR_CONNECT_RESET_ERROR. Please see the attached screenshot for more details. This issue was observed ever since I updated to Firefox version 124.x. Prior to that the websites were working fine.

When I try to access the same websites and try to log into them using Microsoft Edge, I do not face a similar issue. They work fine.

I have cleared the browser cache, restarted firefox, and then tried. Still faced the same issue. I have cleared the DNS cache of Firefox browser (about:networking#dns) and then tried. Still faced the same issue. I have opened Firefox in Safe mode (Menu > Help > Troubleshooting mode) and still faced the same issue.

Can someone please help me in fixing the issue? I would like to refrain from using MS Edge or chrome browser.

For the past few days when I have tried to log into a few websites which use TLS/SSL I have gotten PR_CONNECT_RESET_ERROR. Please see the attached screenshot for more details. This issue was observed ever since I updated to Firefox version 124.x. Prior to that the websites were working fine. When I try to access the same websites and try to log into them using Microsoft Edge, I do not face a similar issue. They work fine. I have cleared the browser cache, restarted firefox, and then tried. Still faced the same issue. I have cleared the DNS cache of Firefox browser (about:networking#dns) and then tried. Still faced the same issue. I have opened Firefox in Safe mode (Menu > Help > Troubleshooting mode) and still faced the same issue. Can someone please help me in fixing the issue? I would like to refrain from using MS Edge or chrome browser.
附加的畫面擷圖

被選擇的解決方法

Try renaming the cert9.db file in your profile folder while Firefox is not running so that a new one is generated.

從原來的回覆中察看解決方案 👍 4

所有回覆 (10)

more options

I am running Firefox version 124.0.2 on Windows 10 22H2. I am not running any Kaspersky product on my computer. I hope this helps.

由 ixian 於 修改

有幫助嗎?

more options

Hi ixian, that RESET error indicates that the server (or a security service protecting the server) told Firefox to stop trying to connect.

You already tried many of the relevant actions. Could you also clear the site's cookies? Here's how:

On Settings page, Privacy & Security panel, Cookies and Site Data section, click the "Manage Data" button. This should launch a little dialog that allows you to remove cookies and offline storage data for the bank's site; you also could remove the data for any obviously related sites.

Any difference the next time you visit the site (in a new tab)?

有幫助嗎?

more options

有幫助嗎?

more options

Try changing DNS over HTTPS (DoH) to "Off" or "Max Protection" and in Connection Settings change "Use system proxy settings" to "No proxy".

Does it still happen in a new profile? An easy way to test a new profile is to install Developer Edition and see if it happens there or refresh your existing profile. Make sure you stay signed out of your sync account when testing.

有幫助嗎?

more options

jonzn4SUSE said

Have a look at this. https://forum.kaspersky.com/topic/getting-pr_connect_reset_error-in-firefox-when-using-kaspersky-total-security-28248/#comment-116161

I do not have Kaspersky installed on my computer. Are you suggesting that I contact my Anti-Virus product support for the same ?

有幫助嗎?

more options

jscher2000 - Support Volunteer said

Hi ixian, that RESET error indicates that the server (or a security service protecting the server) told Firefox to stop trying to connect. You already tried many of the relevant actions. Could you also clear the site's cookies? Here's how: On Settings page, Privacy & Security panel, Cookies and Site Data section, click the "Manage Data" button. This should launch a little dialog that allows you to remove cookies and offline storage data for the bank's site; you also could remove the data for any obviously related sites. Any difference the next time you visit the site (in a new tab)?

I did that. I cleared all the cookies. Restart Firefox browser and still the issue persists. Please see the attached screenshot.

有幫助嗎?

more options

zeroknight said

Try changing DNS over HTTPS (DoH) to "Off" or "Max Protection" and in Connection Settings change "Use system proxy settings" to "No proxy". Does it still happen in a new profile? An easy way to test a new profile is to install Developer Edition and see if it happens there or refresh your existing profile. Make sure you stay signed out of your sync account when testing.

I tried the following

1) Switched off DNS over HTTPS protection levels in Firefox to OFF. -Did not solve the problem. 2) Changed the Configure Proxy Access to the Internet in Connection Settings to OFF. -Did not solve the problem. 3) Created a new Profile and tried in that and then checked. -It worked.

Switched back to my default profile and the issue was still occurring. So I looked at the SSL certificate and in that I found that it was showing "Connection Not Encrypted." Please see the attached screenshot for the details. When I checked in Microsoft Edge i found that at the login page, where I get the PR_CONNECT_RESET_ERROR in Firefox, in Edge is shows me the Encryption as "Connection Encrypted (TLS_AES_256_GCM_SHA384, 256 bit keys, TLS 1.3)". But in Firefox it does not.

So this leads me to question why does the encryption not work only in Firefox and that too in the default profile? Should I delete all the profiles and then create a new profile? Or is this something else that is going on? Could it be an infection or a malicious extension/add on or something else?

Further when I started Firefox in safe mode, i.e. Troubleshooting mode, the issue still persists. So does that mean that the Troubleshooting mode, i.e. Safe Mode, is different than a new Profile mode?

有幫助嗎?

more options

選擇的解決方法

Try renaming the cert9.db file in your profile folder while Firefox is not running so that a new one is generated.

有幫助嗎?

more options

zeroknight said

Try renaming the cert9.db file in your profile folder while Firefox is not running so that a new one is generated.

Wow this worked. Thanks.

So how do I avoid this from happening in the future? Should I periodically flush my profiles and create a new profile? Or should I uninstall Firefox and then install a fresh copy of the browser from the website? Or do something else?

And more importantly what role does cert9.db plays? Is it a SQLite DB file?

有幫助嗎?

more options

The cert9.db file stores root certificates that Firefox trusts, plus certificates saved as you browse or that you import as trusted, plus personal certificates you may install (if you use any sites that require them). If Firefox doesn't find it, it will build a new one. I really don't know what in the file might have caused the RESET problem. That seems very random.

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先登入帳號 來回覆文章。還沒有帳號的話,只能發問新問題