搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Permission denied when opening file from another drive

  • 5 回覆
  • 0 有這個問題
  • 64 次檢視
  • 最近回覆由 zeroknight

more options

When opening a file from another drive, I get an error: Access to the file was denied

I know this can happen on the Snap version, but I have Firefox installed from a deb!

When opening a file from another drive, I get an error: Access to the file was denied I know this can happen on the Snap version, but I have Firefox installed from a deb!

被選擇的解決方法

Ubuntu has an apparmor profile for /usr/lib/firefox/firefox. You can add paths you want to be accessible to /etc/apparmor.d/tunables/home.

從原來的回覆中察看解決方案 👍 0

所有回覆 (5)

more options

Show the error message. I assume the drive is already mounted. Can you access the file via the file explorer in you OS? I'm curious to know what file you're trying to access via the internet browser instead of the normal file explorer? See what happens with Firefox from Mozilla. Just download, unzip, and run firefox-bin to see if you have the same issue. https://www.mozilla.org/en-US/firefox/all/#product-desktop-esr

有幫助嗎?

more options

Yes, I can access the file with the file explorer. It also works fine when I open it with Firefox ESR from that link and the stable version of Firefox from that link. The permissions on the file look correct: -rw-rw-r--. Is there a way to tell whether Firefox was installed through snap from within Firefox itself? It seems to be installed through apt, but I know that some apt packages are secretly installed as snaps, which apparently can cause issues.

apt list --installed | grep firefox

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

firefox/jammy,now 119.0+build2-0ubuntu0.22.04.1~mt1 amd64 [installed,automatic]

有幫助嗎?

more options

選擇的解決方法

Ubuntu has an apparmor profile for /usr/lib/firefox/firefox. You can add paths you want to be accessible to /etc/apparmor.d/tunables/home.

有幫助嗎?

more options

Thanks!

I don't want other apps to access this drive so I added /e/* r, to /etc/apparmor.d/usr.bin.firefox. My drive is mounted at /e. To anyone else using this answer, reload the apparmor profile with sudo service apparmor reload after making changes and see if it works

有幫助嗎?

more options

Changing the apparmor profiles directly will conflict with updates, instead you should use a local override in /etc/apparmor.d/local/usr.bin.firefox.

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先登入帳號 來回覆文章。還沒有帳號的話,只能發問新問題