搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Firefox 82.0.3 (64 bit) for Windows 10 ignoring hosts file

  • 6 回覆
  • 1 有這個問題
  • 39 次檢視
  • 最近回覆由 FredMcD

more options

Hi, it looks like Firefox 82.0.3 (64 bit) for Windows 10 is ignoring hosts file. This did not happen with previous versions of FF.

I tried adding a domain to hosts file and tested it with Chrome and Opera, they both open the IP configured in hosts file whilst FF doesn't.

I also disabled all addons, but no joy.

Any help?

Thank you Ale

被選擇的解決方法

Update. I installed live hosts addon ( https://addons.mozilla.org/en-US/firefox/addon/livehosts/ ) , this allowed me to temporarily get around the problem. Once I uninstalled the addon Firefox resumed reading hosts file as usual. This behavior seems very strange to me, but for the moment the problem is solved. Thanks everibody for your help.

從原來的回覆中察看解決方案 👍 0

所有回覆 (6)

more options

Try deleting the hosts file. Also, make sure it is not Read Only.

more options

Hosts file is a Windows system file located in: C:\Windows\System32\drivers\etc

Why should I delete it? It is not read only, and as as I wrote above Chrome and Opera have no problems reading it.

more options

Once deleted, a new file will be created. If the problem remains, we can check elsewhere.

more options
more options

選擇的解決方法

Update. I installed live hosts addon ( https://addons.mozilla.org/en-US/firefox/addon/livehosts/ ) , this allowed me to temporarily get around the problem. Once I uninstalled the addon Firefox resumed reading hosts file as usual. This behavior seems very strange to me, but for the moment the problem is solved. Thanks everibody for your help.

由 Ale 於 修改

more options

That was very good work. Well Done.