搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Initiating sync makes my entire computer slow and almost unresponsive

  • 1 回覆
  • 1 有這個問題
  • 28 次檢視
  • 最近回覆由 xKiv

more options

This seems to be a newish issue - as in, I think it has not been happening until at least a few weeks ago. The computer (linux) is always on, and firefox is also always running (except when I update to a new version). But I was not using the computer for a while. Today I sat at the computer expecting to see all my tabs that I sent to it via "send tab to device", but as soon as firefox started syncing, everything slowed down to a crawl (to the point where even typing to a terminal would have upwards to several seconds of lag). Weirdly, it doesn't seem as if there's a lot of CPU or IO being used, according to top and iotop - but I was seeing multiple "migration" processes (that went away after quitting firefox), suggesting that there are many threads doing very little work in aggregate. After googling a bit I tried setting sync.log.appender.console to Debug and looking at debug console, which didn't tell me anything interesting - it actually looks as if the sync itself completes fast. And, in fact, my bookmarks seem to have synced to today's state correctly. (restarting after updating to current version does not seem to help; running in safe mode also doesn't seem to help)

1) What's up? How do I stop this from happening?

2) How do I get my "sent" tabs? Even a list for the past 2 weeks would be fine. Working it out from browsing history would be ... a lot of needles in even more piles of hay.

所有回覆 (1)

more options

Update: so far, this seems to no longer be happening with firefox 83.0. Either that, or the underlying cause somehow expired. I did not get my old "sent tabs" back in any way. A new sent tab arrived within a few minutes.

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題