搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

How can I disable 'backspace' key from navigating back a page?

  • 2 回覆
  • 1 有這個問題
  • 56 次檢視
  • 最近回覆由 updates

more options

How can I disable 'backspace' key from navigating back a page?

I found an old article that said to set a value who knows where to 2, but that wasn't helpful. And I found a page that listed all the shortcuts, but didn't say how to change them. That wasn't helpful either, doggone it!

I agree with a previous poster that this "feature" is inappropriate -- using a text edit key while editing text should not cause navigation to occur.

Thanks!

Ed

How can I disable 'backspace' key from navigating back a page? I found an old article that said to set a value who knows where to 2, but that wasn't helpful. And I found a page that listed all the shortcuts, but didn't say how to change them. That wasn't helpful either, doggone it! I agree with a previous poster that this "feature" is inappropriate -- using a text edit key while editing text should not cause navigation to occur. Thanks! Ed

被選擇的解決方法

Hi Ed, when the cursor is in a form field, Backspace shouldn't trigger Back. But some fancy editors could be an exception.

I'm not sure what you mean by this:

updates said

I found an old article that said to set a value who knows where to 2, but that wasn't helpful.

Do you mean the article didn't have enough information to make that change, or making that change didn't solve the problem?

For reference:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste backsp and pause while the list is filtered

(3) Double-click the browser.backspace_action preference to display an editing field, and change the value to 2 then press Enter or click the blue check mark button to save the change.

That has always worked for me.

More info on about:config: Configuration Editor for Firefox.

從原來的回覆中察看解決方案 👍 0

所有回覆 (2)

more options

選擇的解決方法

Hi Ed, when the cursor is in a form field, Backspace shouldn't trigger Back. But some fancy editors could be an exception.

I'm not sure what you mean by this:

updates said

I found an old article that said to set a value who knows where to 2, but that wasn't helpful.

Do you mean the article didn't have enough information to make that change, or making that change didn't solve the problem?

For reference:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste backsp and pause while the list is filtered

(3) Double-click the browser.backspace_action preference to display an editing field, and change the value to 2 then press Enter or click the blue check mark button to save the change.

That has always worked for me.

More info on about:config: Configuration Editor for Firefox.

more options

Perfect! and wonderfully explicit instructions, most appreciated. Thanks!