Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

All webpages show up as garbage text

  • 31 回覆
  • 1 有這個問題
  • 178 次檢視
  • 最近回覆由 David

more options

I was using Firefox and my system was low on resources so it killed the process using the most memory which was Firefox. When it restarted every page showed up as garbage. I've cleared cache. I've refreshed Firefox. I've reinstalled. I've rebooted. Nothing seems to work. mozilla.org appears to work but every other site I try looks like the attached image. When I view the source of a page that looks like garbage, the source looks perfectly fine. I'm running 77.0.1 64 bit on Windows 7. Any ideas?

附加的畫面擷圖

被選擇的解決方法

Do you possibly have disabled multi-process in Firefox by using the MOZ_FORCE_DISABLE_E10S=1 environment variable?

  • Bug 1638652 - Content-Encoding not honored when e10s is turned off via browser.tabs.remote.autostart=false or MOZ_FORCE_DISABLE_E10S=1

(please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)

從原來的回覆中察看解決方案 👍 1

All Replies (20)

more options

選擇的解決方法

Do you possibly have disabled multi-process in Firefox by using the MOZ_FORCE_DISABLE_E10S=1 environment variable?

  • Bug 1638652 - Content-Encoding not honored when e10s is turned off via browser.tabs.remote.autostart=false or MOZ_FORCE_DISABLE_E10S=1

(please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)

由 cor-el 於 修改

Helpful?

more options

hello Start Firefox in Safe Mode {web link} A small dialog should appear. Click Start In Safe Mode (not Refresh). While you are in safe mode;

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Poke around safe websites. Are there any problems?

Then restart.

Helpful?

more options

MOZ_FORCE_DISABLE_E10S=1 was the problem. I downgraded to 76 and it worked. I then upgraded to 77 and removed the variable the garbage went away.

Helpful?

more options

Note that you can adjust the number of content processes in Options/Preferences.

Helpful?

more options

Rookie needs help. I'm having the same problem as reported by brian119.

The only thing that works is to downgrade FF to 76 from 77. But the software keeps wanting to upgrade.

Is "MOZ_FORCE_DISABLE_E10S=1" supposed to be set to 1 or 0?

Is "browser.tabs.remote.autostart=false" supposed to be set false or true?

Maybe these are not being saved correctly after changes?

Tried turning off "Use Hardware Acceleration." made no difference.

My "content process limit" is set to default 8

Helpful?

more options

Many site issues can be caused by corrupt cookies or cache.

   Clear the Cache and 
   Remove Cookies
   Warning ! ! This will log you out of sites you're logged in to. 

Type about:preferences<Enter> in the address bar.

   Cookies; Select Privacy. Under History, select Firefox will Use Custom Settings. Press the button on the right side called Show Cookies. Use the search bar to look for the site. Note; There may be more than one entry. Remove All of them.
   Cache; Select Advanced > Network. Across from Cached Web Content, Press Clear Now. 

If there is still a problem, Start Firefox in Safe Mode {web link} A small dialog should appear. Click Start In Safe Mode (not Refresh). While you are in safe mode;

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Poke around safe websites. Are there any problems?

Then restart.

Helpful?

more options

David said

Rookie needs help. I'm having the same problem as reported by brian119. The only thing that works is to downgrade FF to 76 from 77. But the software keeps wanting to upgrade. Is "MOZ_FORCE_DISABLE_E10S=1" supposed to be set to 1 or 0? Is "browser.tabs.remote.autostart=false" supposed to be set false or true? Maybe these are not being saved correctly after changes? Tried turning off "Use Hardware Acceleration." made no difference. My "content process limit" is set to default 8

David, set browser.tabs.remote.autostart to false. For MOZ_FORCE_DISABLE_E10S, just delete that environment variable completely. After that reboot to make sure the setting is cleared.

As for always wanting to upgrade, if you make those 2 changes it should fix the garbage problem for you on version 77. But if you still want to stop it from upgrading, go to Options > General > Firefox Updates and set Allow Firefox to: Check for updates but let you choose to install them

Helpful?

more options

I've tried all of your suggestions over the past 3 days of troubleshooting.

Like I stated in my post it works fine if I downgrade to ver 76. So its a fresh install, their is nothing in cookies, cache, browser history.

Obviously something in FF is changed when going from 76 to 77.

Am I not doing something correctly in changing

"MOZ_FORCE_DISABLE_E10S=1" 

"browser.tabs.remote.autostart=false"

Helpful?

more options

Did you delete the MOZ_FORCE_DISABLE_E10S and reboot? I don't mean setting it to 0. I mean getting rid of it completely. If you look at your windows process list you should be seeing multiple firefox.exe processes instead of only 1.

Helpful?

more options

Thanks David,

"MOZ_FORCE_DISABLE_E10S=1" removed ok,

"browser.tabs.remote.autostart=false" this shows ok

Still the same problem, garbage text.

Also hyperlinks don't work anymore, only way is "right click" "open link in new tab" the result is garbage text. If I enter keyword in search bar = ok result, pages won't load by clicking link,

Helpful?

more options

ok Brian,

Deleted MOZ and reboot. No longer shows up in about:config But task manger shows only 1 firefox process even though have 3 FF tabs opened, something still wrong here.

I'm using IE to troubleshooting and opening more than 1 process for the IE browser which is working fine.

Helpful?

more options

The browser.tabs.remote.autostart pref needs to be true to enable multi-process, because disabling multi-process is causing this issue.

Helpful?

more options

cor-el said

The browser.tabs.remote.autostart pref needs to be true to enable multi-process, because disabling multi-process is causing this issue.

That's odd. I have browser.tabs.remote.autostart=false and multi-process is working just fine.

Helpful?

more options

I still see browser.tabs.remote.autostart as a pref in about:config, but I don't know what effect this pref has and best is to keep it true.

Helpful?

more options

At the moment I've gone back to ver 76 due to my work and its stable. Just tried for both true and false re browser.tabs.remote.autostart in about:config and there was no change. Tomorrow I will try going back to ver 77 and try this possible solution. Will report back at that time.

Any other options not already posted and tried would be appreciated.

Thanks

Helpful?

more options

Wanted to try one last time. I downgraded to ver 76 was using for a few days works fine, upgrade to ver 77 as a test and back to on screen garbage text.

Tried changing browser.tabs.remote.autostart set to true or false neither made any difference.

Unless anyone else has any new ideas to test I think for now I will have to settle for ver 76 and keep using FF that way. I've been using it on the same desktop for years with no problems, only now with the new auto upgrade to ver 76.

Could it be a rare bug?

Helpful?

more options

Just noticed on Brian's original question he says "my system was low on resources so it killed the process using the most memory which was Firefox."

On mine I was not involved with any resources or processes at the time, it was only a usual auto FF upgrade it happened to be to ver 77.

should maybe start a new tread?

Helpful?

more options

You can find the current multi-process state on the Troubleshooting Information page (about:support).

  • "Help -> Troubleshooting Information" -> "Application Basics":
    Multiprocess Windows
    Remote Processes

See also the Remote Processes section further down for more detail.


You can delete possible user.js and numbered prefs#-##.js files and rename/remove the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in current Firefox releases.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.


You can create a new profile as a quick test to see if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

Helpful?

more options

States:

Launcher process = Enabled Multi process Windows = 0/1 Disabled forcibly Remote Process = 0

Now checking into profiles

Helpful?

more options

That was too hard to read;

Launcher process = Enabled

Multi process Windows = 0/1

Disabled forcibly Remote Process = 0

Helpful?

  1. 1
  2. 2
問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題