Search Support

client certificate on smartcard leads to SEC_ERROR_LIBRARY_FAILURE

  • 4 回覆
  • 1 有這個問題
  • 21 次檢視
  • 最近回覆由 cor-el

more options

SSL client certificates do not work on Firefox 74.0 64-bit (Windows 10) and smartcards as expected. The smartcard gets accessed via PKCS #11 library.

When the client certificate is placed into the software security module, Firefox can send it to the requesting web server and it works as expected.

Once the very same certificate was successfully imported into a smartcard and removed from the software security module, authentication fails in Firefox with "SEC_ERROR_LIBRARY_FAILURE". The nginx web server reports: SSL_do_handshake() failed (SSL: error:14094438:SSL routines:ssl3_read_bytes:tlsv1 alert internal error:SSL alert number 80) while SSL handshaking, client:, server:

When using Chrome, the same client certificate from the same smartcard gets used and successfully connects to the web server.

Is there a known issue for this? How can this problem be narrowed down? Is there some kind of debug log file to get further information?

All Replies (4)

more options

Hi 0xFF

This is beyond my skill level :-) I searched for a bug but couldn't find one. Here's my search, maybe you'll find a bug that's similar but I didn't see one:

Anyhow please file a bug:




more options

Instead of loading your PKCS#11 module, can you enable osclientcerts by setting `security.osclientcerts.autoload` to `true` in about:config?


more options

Hi 0xFF:

To use that pref you will have to use Firefox 75 beta (security.osclientcerts.autoload is in 75 but not in 74)

Cheers! ...Roland


more options

^To use that pref you will have to use Firefox 75 beta

I think that for Windows this pref got added in Firefox 72 and 68.4 ESR, so this should work with the current release. For Mac it got added in Firefox 75.

  • 1584401 - build osclientcerts in-tree (windows) [72]
  • 1586915 - build osclientcerts in-tree (macos) [75]



如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題